Linux 4.12 + virtio = Netzwerk langsam

  • Hallo Forum,


    ich möchte hier mal eine interessante Entdeckung teilen. Vielleicht kann sie für den ein oder anderen auch nützlich sein.


    Problem:

    Ich hatte die letzten Tage das Problem, dass das Netzwerk einer meiner VPS nach einem Upgrade auf den Linux Kernel 4.12 ziemlich langsam geworden war (max 1-2 Mbit/s) und ich mir nicht erklären konnte woher das auf einmal kam. Als OS nutze ich hier Arch Linux. Dies betraf aber nur Verbindungen ins Internet (z.B. OS-Updates etc. oder auch Downloads von https://lg.netcup.net). Die Verbindung zu Netcup internen Servern war hingegen einwandfrei (getestet mit iperf3, bin mir aber mittlerweile nicht mehr so sicher, ob das ein guter Vergleich ist).


    Lösung:

    Nach einigem Debugging konnte ich folgende Lösungen ermitteln:

    * Kernel Downgrade (z.B. auf die 4.9 LTS Version) und/oder

    * Wechsel auf den e1000 Netzwerk-Treiber

    Danach war die Netzwerk-Performance wieder super und ich konnte Dateien mit max. Geschwindigkeit herunterladen.


    Vielleicht ist diese Erkenntnis ja auch für Netcup interessant. Zudem würde mich mal interessieren, ob andere Kunden das Phänomen ebenfalls nachstellen können. Wäre bestimmt interessant zu erfahren, ob das Problem an einem kaputten virtio Treiber im 4.12er Kernel liegt und/oder nur in Verbindung mit dem KVM Netzwerk von Netcup :-).


    Gruß

    Paul

  • Hallo Paul,


    wir untersuchen seit gestern genau dieses Problem und haben schon vieles ausprobiert.


    Mit aktuellem Kernel und e1000 ist die Geschwindigkeit besser aber es treten weiterhin RX drops auf.


    Ich hänge den Link zu diesem Thread an unser Support Ticket.


    Gruß

    Michael