Posts by phatair

    Hallo zusammen,


    ich habe auf meinem Webspace 3 Wordpress Installationen. 1 wurde über die NetCup Anwendungen installiert, die anderen beiden manuell. Jede WordPress Installation gehört zu einer bestimmten Domain. Insgesamt gibt es in dem Account aber 5 Domains.


    Im neuen WebhostingControlPanel kann ich mir diese ja unter dem Punkt "Anwendungen" anzeigen lassen. Hier stehen die 3 Wordpress Seiten aber mehrmals drinnen. Ebenso werden die Wordpress Seiten in dem Menüpunkt "Websites und Domains" für jede Domain angezeigt. Dabei liegen die Wordpress Seiten natürlich nur auf jeweils einer bestimmten Domain.


    Ist das normal? Es sieht sehr merkwürdig aus - Im Menüpunkt "Wordpress" im WebhostingControlPanel stehen auch nur die 3 Webseiten drinnen.


    Zum besseren Verständnis habe ich noch Screenshots angehängt.

    Für Hilfe wäre ich sehr dankbar.


    EDIT: Ok, ich war etwas zu schnell - habe die Lösung gefunden.

    Es liegt am Dokumentenstamm. Die ungenutzen Domains zeigen auf httpdocs - die genutzten Domains auf httpdocs/SEITENNAME

    Die ungenutzten Domains zeigen dann trotzdem die Wordpress Installationen an, da auch die Unterordner von httpdocs durchsucht werden.

    Ich habe nun die ungenutzen Domains auf den Dokumentenstamm httpdocs/disabled verlinkt. Nun tauchen dort auch die WordPress Installationen nicht mehr auf.

    Hi debonner,


    ja, ich hatte diese INfo schon hier gefunden.

    Das erkärt auch warum es über Thunderbird geht, Autoconfig scheint sauber zu funktionieren.

    Autodiscover anscheinend nicht. Auch für iOS muss man selber was bauen bzw. in der Apache Config hinterlegen...


    Ich selber nutze ein Note 8 mit Android 8 aber die User verwenden unterschiedliche Betriebssysteme/Programme/Handys. Deswegen würde ich gerne eine Lösung haben, die 90% abdeckt.


    Bedeutet aber wohl, dass ich ein Autoconfig benötige (habe ich ja schon), ein autodiscover und die iOS Lösung. So viel zu Standards ^^

    Hallo zusammen,


    ich habe folgende Konfiguration.

    Einen Webhosting Tarif (Webhosting Complete 1) hier habe ich mehrere Mail Adressen angelegt.

    Diese würde ich gerne per Autodiscover einrichten lassen, damit die User nicht die Konfig per Hand vornehmen müssen.


    Im CCP sind im DNS folgende Werte schon eingetragen:

    autoconfig -> CNAME -> autoconfig.netcup.net

    @ -> MX -> 10 -> "MailServer.netcup.net"

    @ -> MX -> 50 -> "mail.meinedomain.de"


    Wenn ich über den Thunderbird meine Mail hinzufüge, wird automatisch der korrekte Ein und Ausgangsserver gewählt, nämlich Mailserver.netcup.net.

    Wenn ich das gleiche an meinem Samsung Handy über die Samsung Mail App mache, wird als Ein und Ausgangsserver imap.meinedomain.de und smtp.meinedomain.de gewählt. Das funktioniert natürlich nicht.


    Warum dieses unterschiedliche Verhalten? Muss ich das Autodiscover noch irgendwo anpassen? Es soll ja der Mailserver.netcup.net genommen werden, damit auch die Zertifikate passen. Mir wurde mal gesagt, dass eben nur über die *.netcup.net Mailserver sauber die Verschlüsselung per Mail funktioniert (da man selber keine LE Zertifikate für seine Mail Domain hinterlegen kann).


    Über https://mxtoolbox.com erhalte ich bei einem MX Lookup meiner Domain auch den korrekten Mailserver mit der jeweiligen Prio von Netcup zurück.


    Für Hilfe wäre ich sehr dankbar.

    Gruß

    Eine Frage habe ich doch noch.

    Wenn ich bei Clients die automatische Kontoerstellung nutze (zb. Outlook oder Samsung Mail) und er sich die IMAP Server automatisch sucht, wird hier immer der imap.meinedomain.de genommen.


    Die Zertifikate sind ja auf mxf000.netcup.net ausgestellt und soweit ich weiß kann man das für mails ja auch nicht auf seine eigene Mail ausstellen lassen.

    Gibt es eine Möglichkeit das automatisch die mxf... Server übernommen werden?


    Hintergrund ist, ich würde gerne weitere Mail Konten für einige Freunde und Familie erstellen. Wenn diese aber immer bei der Einrichtung manuell die Server anpassen müssen, wäre das etwas unschön.


    Für Tips wäre ich dankbar.

    Gruß

    Hallo zusammen,


    ich habe einen Webhosting Complete 1 Tarif.

    Ich möchte hier die Mails für meinen alltäglichen Gebrauch drüber laufen lassen. Mail Adresse habe ich im neuen Mailhosting schon angelegt.

    Eine Webmail (rainloop) habe ich mir auf dem Webhosting installiert und das läuft soweit auch schon.


    Muss ich jetzt noch irgendwelche weiteren DNS Einträge ändern/anpassen damit alles auch sauber konfiguriert sind?

    Soll ich als IMAP und SMTP Server die Netcup Server verwenden oder meine eigenen konfigurieren?


    Ich wäre für Tips sehr dankbar.

    Gruß

    Hallo zusammen,


    ich habe meine bestehenden Seiten per Soft Migration auf die neue Version migriert.

    Wenn ich dort nun meine Mail Adressen anlege und per Webmail verfügbar mache, ist immer noch die sehr alte Roundcube Version 1.2.3 in Verwendung.

    Wird Netcup hier mal die aktuelle Version einspielen oder ist das ein Thema was nicht wirklich upgedated und supported wird?

    Die Aktuelle Version ist ja 1.3.7


    Wie kann man den eine eigene Webmail Möglichkeit erstellen ohne gleich nen eigenen Mail Server zu betreiben?

    Danke und Gruß

    Hallo zusammen,


    ich habe noch einen alten Webhosting Tarif und würde nun gerne die Softmigration auf einen neuen Tarif durchführen.

    Die Daten der Webseiten habe ich schon gesichert, ebenso die SQL Datenbank.


    Einzig die Mails sind mir noch unklar. Müssen diese überhaupt gesichert werden? Diese liegen ja sowieso auf einem extra Mailserver, oder?

    Bleibt das Postfach von der Softmigration unberührt oder muss ich hier auch noch irgendwas sichern/migrieren?


    Vielen Dank.

    Gruß

    Danke euch! Das hilft mir schon sehr weiter.

    Wie es scheint gibt es hier einfach viele Wege die nach Rom führen :)


    Da ich auf dem Server auch schon eine Nextcloud Instanz laufen haben, würde ich jetzt ungern die ganze Struktur ändern.

    Daher würde ich wohl Lösung 1 bevorzugen. So wie ich euch verstehe sind alle 3 Lösungen "sicher" - nur eben etwas anders aufgebaut.


    Die Berechtigungen machen dann ja auch erst Sinn bzw. schützen den Server, wenn jemand über eine Sicherheitslücke oder Fehler im Script Zugriff auf meinen Server erhält. Dann könnte er bei einer Berechtigung, z.B. von 770, auch Daten schreiben, da er dann als www-data Schreibzugriff hat. Das verstehe ich doch richtig, oder?


    Die Grundsätzliche Frage hat sich somit geklärt. Nun habe ich eine Frage dich sich dem anschließt. Vielleicht könnt ihr mir hier auch noch einen Denkanstoß geben.

    Die User laden Daten in das Verzeichnis "Upload" hoch. Das heißt der www-data muss hier Schreibrechte haben.

    Ich habe somit root:www-data auf den Ordner Upload 770 Rechte gegeben. User können nun Daten hochladen.

    Die Ordner und Dateien die erstellt werden erhalten automatisch die Berechtigung www-data:www-data mit 755 für Ordner und 644 für Dateien. Das wäre dann ja soweit in Ordnung, oder?

    Normalerweise wird der Owner für deine auszuliefernden Dokumente, sprich die PHP Dateien deines Portals, also alles im WebRoot auf www-user:www-user gesetzt.

    solange der www-user alle Dateien nur lesen kann und Schreibzugriff nur auf die Ordner/Dateien besteht, wo er dies auch soll

    Das verstehe ich dann aber nicht - einmal sagst du, dass im WebRoot alles auf www-user:www-user gesetzt wird.

    Das würde ja bedeuten das www-user auf alle Dateien auch schreibrehcte hat (wenn man diese auf 640 setzt).

    Das aber soll ja dann laut deiner eigenen Aussage aber nur auf Dateien passieren, wo das auch passieren soll.


    Irgendwie stehe ich noch auf dem Schlauch :(

    Danke Oliver,


    also ich rede hier von Usern die nicht auf den Server Zugriff haben.Es geht hier nur um User die sich auf der Webseite anmelden können und in einer Mariadb angelegt werden.

    Ich habe jetzt schon mehrere Seiten gelesen und überall wird etwas anderes erzählt. Mein letzter Stand war jetzt, dass es aus Sicht der Sicherheit am besten ist den Owner nicht als www-data laufen zu lassen und nur die Gruppe als www-data zu setzen. Oder ich habe das komplett falsch verstanden.


    Wenn ich dich richtig verstehe ist die grundsätzliche Berechitung von Ordnern 750 und Dateien 640 aber soweit erstmal richtig.

    Dann wäre jetzt die Frage ob man das mit www-data:www-data laufen läßt.

    Verstehe ich das richtig?


    Meinst du mit www-user den auch www-data? Oder ist www-user eine manuell erstelle Gruppe/User?

    Ich nutze Ubuntu und hier ist die Apache Systemgruppe/User www-data

    Hallo zusammen,


    ich benötige eure Hilfe bei der korrekten Berechtigung eines Verzeichnisses im Apache WebRoot.


    Ich möchte auf meinem Server ein kleines privates Soziales Netzwerk betreiben in dem Familie und Freunde Bilder, Videos usw. austauschen können.

    Die Seite ist nur mit Login erreichbar und es gibt keine offene Registrierung. Es kann nur per Einladung teilgenommen werden.

    Das Script ist in PHP geschrieben und habe ich über Envato/codecanyon gekauft.


    Ich habe dazu ein neues Verzeichnis in /var/www angelegt - > /var/www/mysite


    Die Berechtigung habe ich wie folgt gesetzt:

    /var/www/mysite -> owner: root group: www-data -> Berechtigung 750


    Alle Dateien und Unterordner haben ebenso "owner: root" und "group: www-data".

    Die Verzeichnisse sind mit 750 berechtigt, alle Dateien mit 640.


    Nun die erste Frage. Ist das soweit korrekt berechtigt?

    1. sollte ich den owner von root zu einem andren User ändern? Ich bin der einzige, der den User administriert.

    2. ist es problematisch meinen User mit in die www-data Gruppe aufzunehmen, damit ich in den Verzeichnissen lesen kann?



    Nun kommen wir zum 2. Punkt.

    Da die User natürlich auch Bilder und Videos hochladen sollen, gibt es einen Ordner uploads (in /var/www/mysite/uploads).

    Darunter befinden sich dann die Ordner für Bilder, Videos, Sounds usw.

    Hier können die User im Moment nichts hochladen, da die Berechtigung wie oben beschrieben gilt und somit www-data nicht schreiben darf.


    Die Frage lautet nun, wie vergebe ich hier die Berechtigung korrekt, dass www-data schreiben darf aber die Sicherheit nicht leider.

    Ich hätte jetzt für jeden Unterordner unter "uploads" (also Bilder, Videos, Sounds) mit der Berechtigung 770 ausgestattet. Damit darf auch www-data in diese Verzeichnisse schreiben.


    Nun klappt auch das hochladen von Bildern usw. über die Webseite. Allerdings werden dann Unterordner angelegt

    /var/www/mysite/uploads

    ---- Bilder

    ---- 2018

    ----- 02


    Diese Verzeichnisse werden vom Webserver angelegt und haben dann folgende Berechtigung:

    Verzeichnisse: www-data:www-data (anstatt root:www-data) mit 755 Berechtigung

    Dateien: www-data:www-data (anstatt root:www-data) mit 644 Berechtigung


    Ist das in Ordnung? Wie würde ich es hinbekommen, dass neue Unterordner und DAteien auch mit root:www-data und den Berechtigungen 750 (Verzeichnisse) und 640 (Dateien) angelegt werden?


    Ich hatte schon mit setfacl und getfacl gearbeitet und versucht mit umask die Berechtigung für neue Ordner und Dateien zu realisieren. Bin aber leider gescheitert.

    Für Hilfe wäre ich sehr dankbar.

    Gruß

    Steffen

    Hallo zusammen,


    ich habe noch mal eine Frage in Bezug auf meinen Root Server.

    Die Konfiguration sieht im Moment wie folgt aus:

    - Ubuntu 16.04

    - LAMP mit Apache2 2.4.18, MariaDB 10.0.29 und PHP 7.0 bzw. 5.6

    - SSH mit verändertem Port und KeyFile+Passwort

    - UFW Firewall aktiviert und Zugriffe nur für 443,80 und geänderten SSH Port zugelassen

    - Fail2ban konfiguriert

    - SSL Verschlüsselung über Lets Encrypt

    - 2 Seiten werden über den Server betrieben (cloud.wolkee.de und book.wolkee.de).


    Bisher habe ich Nextcloud alleine betrieben. Hier ist php über den Apache Handler gelaufen. PHP war 7.0


    Nun betreibe ich noch eine weitere Seite. Diese benötigt im Moment aber noch zwingend php5.6.

    Also habe ich php5.6 zusätzlich installiert und das ganze über PHP-FPM realisiert.

    Dazu habe ich meinen virtualhosts folgendes hinzugefügt:



    Über "SetHandler php70-fcgi-www" oder "SetHandler php56-fcgi-www" kann ich nun in den VirtualHosts entscheiden ob PHP5.6 oder PHP7.0 als FPM/FastCGI läuft.

    Das ganze habe ich auch mit einer info.php geprüft. Die Server API und die PHP Version stimmt.


    Beide Seiten laufen als private Seiten. Das heißt man kann nur nach einer Registrierung auf die Webseiten zugreifen. Seht ihr hier irgendwelche Gefahren, habe ich irgendwas falsch eingerichtet?

    Ich bin noch am lernen was Linux angeht, daher würde ich mich über Antworten und eure Hilfe sehr freuen.


    Ansonsten noch einen schönen Sonntag.

    Gruß,

    Steffen

    Habe den Fehler gefunden. Ich hatte in der book.conf in der ersten Zeile folgendes stehen


    <VirtualHost book.wolkee.de:443>

    das habe ich jetzt durch

    <VirtualHost *:443>


    ersetzt. So stand es nämlich auch in der cloud.conf

    Nun scheint es zu gehen. Beide Seiten sind über https erreichbar und sslshopper zeigt auch alles korrekt an.


    Danke euch für die Hilfe.

    Ich habe aber noch eine andere kurze Frage. Vielleiht könnt ihr mir ja hier auch helfen.
    Wenn man im Browser meine IP eingibt, kommt man auf der book subdomain raus.

    Kann man das irgendwie verhindern bzw. ist das "schlecht"?




    Hi,


    so nun habe ich wieder das Problem.

    ich habe für book.wolkee.de mit dem Befehl


    sudo certbot --apache -d book.wolkee.de


    das Zertifikat erstellt. Nun ist aber für cloud.wolkee.de auf einmal der comon name und der SANs book.wolkee.de hinterlegt.

    Prüfe ich das oder gehe nur auf die Seite https://cloud.wolkee.de erhalte ich jetzt eine Fehlermeldung. https://book.wolkee.de funktiniert dagegen.


    beide virtualhost Dateien haben aber das richtigen SSLCertificateFile und SSLCertificateKeyFile eingetragen. Es gibt auch eine book-le-ssl.conf und cloud-le-ssl.conf

    Das verstehe ich nicht.

    Hi janxb,


    ja das stimmt, sorry. Manchmal ist man irgendwie zu paranoid ...


    Also im Moment ist folgender Stand:

    cloud.wolkee.de ist über lets encrypt verschlüsselt

    book.wolkee.de läuft im Moment nur über http


    Die IP meines root Servers lautet: 185.194.140.66


    Wenn ich book.wolkee.de über https://www.sslshopper.com/ssl…l#hostname=book.wolkee.de prüfe, steht hier als name cloud.wolkee.de drinnen.

    Liegt das dann daran, dass er das nächst liegende Zertifikat nimmt? Wäre das nicht aber das netcup Zertifikat? Prüfe ich nämlich eine nicht existierende Sub Domain, wird das Netcup Zertifikat angezeigt.


    Was wäre der nächste Schritt?


    Ich hätte über folgenden Befehl ein Zertifikat angefordert:

    sudo certbot --apache -d book.wolkee.de


    Soweit richtig oder muss ich noch eine Zwischenschritt beachten? Gibt es vielleicht irgendeine falsche Konfiguration bei mir die ich vorher anpassen sollte?


    Vielen Dank noch mal für deine Hilfe.

    Gruß

    Hallo zusammen,


    meine Konfiguration sieht wie folgt aus.

    Ich habe einen root Server und auf dem läuft Ubuntu 16.04 mit einem LAMP.

    Hier habe ich eine Nextcloud Installation laufen.Die Domain ist in meinem Webhostingpaket enthalten. Damit ich die Domain mit dem root Server nutzen kann, habe ich im CCP unter Domains im DNS einen Type A Eintrag für die Sub Domain eingetragen. Als Ziel ist die IP meines root Servers eingetragen.


    Das funktioniert auch wunderbar. Über lets encrypt habe ich dann mein Zertifikat erstellt und die Seite cloud.meinedomain.de ist per SSL erreichbar.


    Nun möchte ich auf dem root Server noch eine weitere Seite hosten. Diese soll ebenso eine Subdomain "book" unter meinedomain.de erhalten Dazu habe ich auf dem Server alles angelegt. Ebenso habe ich im CCP unter Domains einen weiteren Type A Eintrag vorgenommen.


    Sieht also wie folgt aus

    cloud Type A IP meines root Servers

    book Type A IP meines root Servers


    Beide Seiten sind erreichbar. Die Subdomain cloud ist ja schon über SSL erreichbar. book nur über http. Wenn ich jetzt aber die Sub Domain book über die Seite sslshopper.com prüfe, erhalte ich folgende Info:

    Common name: cloud.meinedomain.de
    SANs: cloud.meinedomain.de


    Habe ich hier irgendwas falsch konfiguriert? Warum zeigt die book subdomain im Zertifikat auf die cloud sub domain?

    Für Tipps und Hilfe wäre ich sehr dankbar.

    Gruß

    Steffen

    Hallo zusammen,


    ich habe im SCP eine Meldung erhalten, dass es eine neue KVM Version gibt und ich meinen Server neustarten soll.

    So ganz genau habe ich noch nicht verstanden was die/das KVM ist. Ist das die Virtualisierung im Hintergrund?

    Gibt es irgendwo eine Übersicht, was es für Neuerungen gibt oder sind die eher uninteressant?


    Vielen Dank schon mal.