Posts by j-f

    Auch nach umfangreichen Tests konnte das Problem leider nicht identifiziert werden, daher wurde mir angeboten, meinen Server auf einen anderen Node zu migrieren. Dies habe ich natürlich angenommen und siehe da, auf dem neuen Node besteht das Problem nicht mehr. Auf dem alten Node lieferte ioping teilweise Antwortzeiten von bis zu 8.000ms und aufeinanderfolgende Werte von über 500ms waren mehrfach am Tag zu verzeichnen.


    Jetzt läuft mein Server läuft wieder mit der von netcup gewohnten Performance und bisher gab es nur ganz kurze Spitzen mit max. 490ms Antwortzeit.


    Viele Grüße
    j-f

    [UPDATE] Installation eines Root-Servers auf Basis von LEMP (Debian 7.6.0) und Ajenti-V
    Version 03.11.2014


    Installation LEMP und Ajenti-V - 20141103


    System: Debian 7.6.0 Wheezy
    Webserver: Nginx 1.6.2-1
    PHP: 5.6.1-1 (PHP5-FPM)
    Datenbank: MySQL 5.6.19
    SMTP: Exim 4.80-7
    IMAP/POP3: Courier 4.10.0 / 0.68.2-1
    FTP: Pure-FTPd 1.0.36-1.1
    Spamschutz: SPF, DKIM, DMARC, greylistd 0.8.8
    IPS: iptables, fail2ban 0.8.6-3
    Monitoring: Munin 2.0.6-4, Logwatch 7.4.0
    Admin-Panel: Ajenti + Ajenti-V 1.2.22.16, phpMyAdmin 3.4.11.1-2
    Backup: Rsync 3.0.9-4, bzip2 1.0.6-4
    Apps: ownCloud 7.0.2, Tine 2.0 2013.09.1, Pydio 5.2.4, Tiny Tiny RSS 1.14


    Über Anregungen und Kommentare würde ich mich freuen.


    Viel Spaß damit
    J-F

    Hallo,


    ich habe seit einiger Zeit Performance-Probleme mit meinem Root-Server Weltmeister. Die I/O-Performance ist sporadisch so schlecht, dass ich teilweise nur auf 5 MB/s bei Schreibzugriffen komme. Das ist aus meiner Sicht nicht akzeptabel. Unten habe ich mal die aktuellen Messungen aufgeführt, die ich heute über das Rettungssystem durchgeführt habe.


    In diesem Zusammenhang, hier ein Auszug aus der Produktbeschreibung:


    Quote

    "Ein schneller Festplattenzugriff wird über 2 SAS-Festplatten mit einer Nettokapazität von 40 GB gewährleistet. Um die Datensicherheit zu erhöhen, werden die Festplatten als RAID1 gespiegelt."


    Natürlich habe ich das Problem dem Support gemeldet, doch bei der Antwort, die ich daraufhin erhalten habe, ist mit die Kinnlade runtergeklappt.


    Quote

    "…Der Node arbeitet fehlerfrei und unsere Aufzeichnungen zeigen auch zu den von Ihnen genannten Zeitpunkten keine erhöhten Zugriffszahlen oder erhöhte Auslastungswerte.


    Wenn Ihnen die Systemleistung eines Root-Server Weltmeister nicht ausreicht, so müssen Sie auf einen Tarif mit mehr Leistung umsteigen."


    Mit einer solchen Antwort habe ich wirklich nicht gerechnet. Man könnte fast den Eindruck gewinnen, dass dieses Produkt nur ein Lockangebot war und man auf diesem Weg versucht, einen teureren Tarif zu verkaufen oder will man damit wirklich sagen, das Schreibzugriffe mit 5 MB/s für dieses Produkt normal sind.


    Ich finde das sehr ärgerlich und bisher hatte ich eigentlich nur sehr gute Erfahrungen mit netcup gemacht.


    Nun würde mich mal interessieren, ob andere mit dem Root-Server Weltmeister ähnliche Probleme haben und welcher Durchsatz bei Schreibzugriffen auf diesem System mindestens erreicht werden sollte. Nach Aussage des Supports soll der Root-Server Weltmeister eine ähnliche Performance liefern wie der Root-Server M, nur das eben weniger Haupt- und Festplattenspeicher zur Verfügung steht.


    Hier nun die Messungen von heute Morgen. Diese wurde extra im Rettungssystem durchgeführt, um andere Fehlerquellen auszuschließen.


    Code
    1. root@rescue:~# ps -a
    2. PID TTY TIME CMD
    3. 1293 pts/0 00:00:00 ps
    4. root@rescue:~# mount /dev/vda1 /mnt/


    Allein das Mounten des Datenträgers hat ca. 2 Minuten gedauert.


    29.10.2014 - 07:00 Uhr

    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 24.3039 s, 5.5 MB/s


    29.10.2014 - 07:01 Uhr

    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 25.9357 s, 5.2 MB/s


    29.10.2014 - 07:05 Uhr

    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 8.59053 s, 15.6 MB/s


    29.10.2014 - 07:10 Uhr

    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 8.43397 s, 15.9 MB/s


    29.10.2014 - 07:25 Uhr

    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 0.116682 s, 1.2 GB/s


    29.10.2014 - 07:30 Uhr

    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 1.35728 s, 98.9 MB/s


    Gruß
    j-f

    [UPDATE] Installation eines Root-Servers auf Basis von LEMP (Debian 7.6.0) und Ajenti-V
    Version 26.10.2014


    Installation LEMP und Ajenti-V - 20141026


    System: Debian 7.6.0 Wheezy
    Webserver: Nginx 1.6.2-1
    PHP: 5.6.1-1 (PHP5-FPM)
    Datenbank: MySQL 5.6.19
    SMTP: Exim 4.80-7
    IMAP/POP3: Courier 4.10.0 / 0.68.2-1
    FTP: Pure-FTPd 1.0.36-1.1
    Spamschutz: SPF, DKIM, DMARC, greylistd 0.8.8
    IPS: iptables, fail2ban 0.8.6-3
    Monitoring: Munin 2.0.6-4, Logwatch 7.4.0
    Admin-Panel: Ajenti + Ajenti-V 1.2.22.16, phpMyAdmin 3.4.11.1-2
    Backup: Rsync 3.0.9-4, bzip2 1.0.6-4
    Apps: ownCloud 7.0.2, Tine 2.0 2013.09.1, Pydio 5.2.4, Tiny Tiny RSS 1.14


    Über Anregungen und Kommentare würde ich mich freuen.


    Viel Spaß damit
    J-F

    [UPDATE] Installation eines Root-Servers auf Basis von LEMP (Debian 7.6.0) und Ajenti-V
    Version 21.10.2014


    Installation LEMP und Ajenti-V - 20141021


    System: Debian 7.6.0 Wheezy
    Webserver: Nginx 1.6.2-1
    PHP: 5.6.1-1 (PHP5-FPM)
    Datenbank: MySQL 5.6.19
    SMTP: Exim 4.80-7
    IMAP/POP3: Courier 4.10.0 / 0.68.2-1
    FTP: Pure-FTPd 1.0.36-1.1
    Spamschutz: SPF, DKIM, DMARC, greylistd 0.8.8
    IPS: iptables, fail2ban 0.8.6-3
    Monitoring: Munin 2.0.6-4, Logwatch 7.4.0
    Admin-Panel: Ajenti + Ajenti-V 1.2.22.16, phpMyAdmin 3.4.11.1-2
    Backup: Rsync 3.0.9-4, bzip2 1.0.6-4


    Über Anregungen und Kommentare würde ich mich freuen.


    Viel Spaß damit
    J-F

    Ich habe heute um 06:50 Uhr den Root-Server mit dem Rettungssystem gestartet und das Device /dev/vda1 mehrfach mit dd gemessen. Die Ergbenisse sind stark schwankend von 16 MB/s bis zu 785 MB/s. Im Durchschnitt lag der Wert bei ca. 100 MB/s.


    Code
    1. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    2. 1+0 records in
    3. 1+0 records out
    4. 134217728 bytes (134 MB) copied, 8.29374 s, 16.2 MB/s
    5. [...]
    6. root@rescue:~# dd if=/dev/zero of=/mnt/test.file bs=128M count=1 oflag=direct
    7. 1+0 records in
    8. 1+0 records out
    9. 134217728 bytes (134 MB) copied, 0.171072 s, 785 MB/s

    Sonntag, 21:15 Uhr


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 10,6621 s, 12,6 MB/s


    22:07 Uhr,


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 13,1798 s, 10,2 MB/s


    22:50 Uhr - ca. 5 min nach einem Reboot (Swap = 0,0),


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 13,9661 s, 9,6 MB/s


    und Montag 07:20 Uhr.


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 6,53432 s, 20,5 MB/s


    Damit kann man nicht arbeiten!!!


    Gruß
    j-f

    Hier nochmal mein Root-Server Weltmeister vom Samstag 06:40 Uhr!


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 3,21305 s, 41,8 MB/s


    Auf die Frage, ob auch für den Root-Server Weltmeister Qualitätseinbußen wie beim VPS-Preisbrecher hinzunehmen sind hat Fleix wie folgt geantwortet.


    Dieser hat keine SAS-Festplatten, dadurch einen entsprechend schlechteren IO-Durchsatz. Auch hat er nur 512 MB RAM was heutzutage für kleine Dienste ausreicht. Die Qualität der Hardware ist aber entsprechend hochwertig, nicht so minderwertig wie beim VPS-Preisbrecher. D.h. redundante Anbindung von Strom- und Netzwerk, Markenhardware, XEON-CPUs.


    Hier dazu ein Auszug aus der Produktbeschreibung:


    Quote

    Ein schneller Festplattenzugriff wird über 2 SAS-Festplatten mit einer Nettokapazität von 40 GB gewährleistet. Um die Datensicherheit zu erhöhen, werden die Festplatten als RAID1 gespiegelt.


    Auch der Support hatte mir gesagt, dass der Root-Server Weltmeister lediglich weniger RAM hat und ansonsten sehr performant ist. Bis vor einigen Tagen war das bei meinem Server ja auch der Fall, aber nun kann ich das nicht mehr bestätigen.


    Ich habe mich bei der Bestellung natürlich auf die Produktbeschreibung verlassen. Was triftt nun wirklich zu?


    Gruß
    j-f

    134217728 Bytes (134 MB) kopiert, 0,25575 s, 525 MB/s


    Bei meinem Root-Server Weltmeister sieht es leider so aus:


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 12,984 s, 10,3 MB/s


    Hier nochmal nach einem Reboot


    Code
    1. root@v1234567890:~# dd if=/dev/zero of=test.file bs=128M count=1 oflag=direct
    2. 1+0 Datensätze ein
    3. 1+0 Datensätze aus
    4. 134217728 Bytes (134 MB) kopiert, 2,39161 s, 56,1 MB/s


    Wie geschrieben bitte ich um konkrete Zahlen um besser weiterhelfen zu können, sollte das Problem noch bestehen.


    Reicht das?


    Gruß
    j-f

    Wie Sie richtig angemerkt haben, handelt es sich bei beiden Produkten um sehr kostengünstige Tarife. Besonders beim VPS-Preisbrecher sind hier im Gegenzug Qualitätseinbußen hinzunehmen.


    Trifft das auch auf en Rootserver-Weltmeister zu?


    Besonders der Root-Server Weltmeister kann aufgrund des geringen RAMs, je nach Anwendungsfall, stark den SWAP nutzen. Das verlangsamt IO-Durchsätze extrem. Daher wäre es gut, wenn Sie die Tests im Rettungssystem ausführen.


    Mir ist das ja schon während einer Debian 7.6.x Minimalinstallation aufgefallen. Diese hat auf dem gleichen System plötzlich länger gedauert und nachdem die Installation abgeschlossen war (Swap= 0,0 MB), reagierte apt-get bereits so träge. Ich hatte auf dem System zuvor schon einige Testinstallationen durchgeführt, aber da trat das Problem noch nicht auf.


    Gruß
    j-f

    Auch ich habe seit einigen Tagen (von heute auf morgen) Probleme mit der Performance bei meinem Rootserver-Weltmeister und ich gehe ebenso von einem I/O-Problem aus. Auch bei mir braucht "apt-get install" selbst für kleine Pakete recht lange - der Download ist dabei aber nicht das Problem. Ich habe es auch schon dem Support gemeldet, doch aus dessen Sicht ist alles in Ordnung und man sieht hier bisher offensichtlich keinen Handlungsbearf.


    Ich denke daher schon wieder über einen Wechsel nach.


    Gruß
    j-f

    [UPDATE] Installation eines Root-Servers auf Basis von LEMP (Debian 7.6.0) und Ajenti-V
    Version 09.10.2014


    Installation LEMP und Ajenti-V - 20141009


    System: Debian 7.6.0 Wheezy
    Webserver: Nginx 1.6.2-1
    PHP: 5.6.1-1 (PHP5-FPM)
    Datenbank: MySQL 5.6.19
    SMTP: Exim 4.80-7
    IMAP/POP3: Courier 4.10.0 / 0.68.2-1
    FTP: Pure-FTPd 1.0.36-1.1
    Spamschutz: SPF, DKIM, DMARC, greylistd 0.8.8
    IPS: iptables, fail2ban 0.8.6-3
    Monitoring: Munin 2.0.6-4, Logwatch 7.4.0
    Admin-Panel: Ajenti + Ajenti-V 1.2.22.12, phpMyAdmin 3.4.11.1-2
    Backup: Rsync 3.0.9-4, bzip2 1.0.6-4


    Über Anregungen und Kommentare würde ich mich freuen.


    Viel Spaß damit
    J-F

    [UPDATE] Installation eines Root-Servers auf Basis von LEMP (Debian 7.6.0) und Ajenti-V
    Version 04.10.2014


    Installation LEMP und Ajenti-V - 20141004


    System: Debian 7.6.0 Wheezy
    Webserver: Nginx 1.6.2-1
    PHP: 5.6.1-1 (PHP5-FPM)
    Datenbank: MySQL 5.6.19
    SMTP: Exim 4.80-7
    IMAP/POP3: Courier 4.10.0 / 0.68.2-1
    FTP: Pure-FTPd 1.0.36-1.1
    Spamschutz: SPF, DKIM, DMARC, greylistd 0.8.8
    IPS: iptables, fail2ban 0.8.6-3
    Monitoring: Munin 2.0.6-4, Logwatch 7.4.0
    Admin-Panel: Ajenti + Ajenti-V 1.2.22.12, phpMyAdmin 3.4.11.1-2
    Backup: Rsync 3.0.9-4, bzip2 1.0.6-4


    Über Anregungen und Kommentare würde ich mich freuen. Sendet diese bitte direkt per PN.


    Viel Spaß damit
    J-F

    Version 24.09.2014


    Installation LEMP und Ajenti-V - 20140924


    Diese Anleitung ist im Rahmen einer persönlichen Dokumentation entstanden und beschreibt die Installation eines Debian 7.6.0 Systems auf einem Root-Server von netcup. Folgend eine Übersicht der Softwareumgebung und Funktionen, die nach Abschluss der Installation zur Verfügung stehen.


    System: Debian 7.6.0 Wheezy
    Webserver: Nginx 1.6.2-1
    PHP: 5.6.0-1 (PHP5-FPM)
    Datenbank: MySQL 5.6.19
    SMTP: Exim 4.80-7
    IMAP/POP3: Courier 4.10.0 / 0.68.2-1
    FTP: Pure-FTPd 1.0.36-1.1
    Spamschutz: SPF, DKIM, DMARC, greylistd 0.8.8
    IPS: iptables, fail2ban 0.8.8
    Monitoring: Munin 2.0.6-4, Logwatch 7.4.0
    Admin-Panel: Ajenti + Ajenti-V 1.2.22.12, phpMyAdmin 3.4.11.1-2
    Backup: Rsync 3.0.9-4, bzip2 1.0.6-4


    Über Anregungen und Kommentare würde ich mich freuen. Sendet diese bitte direkt per PN.


    Viel Spaß damit
    J-F