Posts by IanFrey

    ok dann fangen wir mal an.. zur nächst die httpd.conf - ich nutze den prefork



    PHP aus YUM-Repo. mit nachinstalliertem APC


    ...und ein Teil der MySQL-Config



    Am Kernel schraub ich nicht, geht ja auch gar nicht :)

    Hi,


    ich nutze CentOS 64bit mit Apache/2.2.3, PHP 5.3.4, MySQL 5.5 auf einem v(olks)Server 1000 und bin (eigentlich) recht zufrieden. Sofern die erste Verbindung vorbei ist, laden alle Elemente recht flott.


    Jedoch ärgert mich diese Erstverbindungs-Verzögerung. Wie sieht diese aus? ca. 2-3 sek vergehen, bevor der Browser anfängt etwas zu parsen/laden.


    Ich habe die selbe Seite mit selber Konfiguration etc. mal auf bei einem Webspace-Anbieter laufen lassen und deren Response-Time ist um einiges besser... < 1 sek.


    Wisst ihr vielleicht wo das Bottleneck ist? Braucht ihr ggf. die httpd.conf ?



    Gruß,
    Jan

    killerbees19;20498 wrote:

    Das geht wie oben erwähnt über die RewriteEngine viel leichter...


    Das als .htaccess im Ordner www speichern ;)



    MfG Christian


    Vielen Dank!


    Das ist des Rätsel's Lösung ;-)

    ferrarajunior;20488 wrote:

    hab ich auch nur in meinen logs ...
    mein einziger Tipp installier dir "fail2ban" per aptitude install fail2ban
    Nach 3 falschen Versuchen bannt er dann den "bruteforcer"


    Ansonsten vllt. auch einfach mal den SSH-Port ändern.. hat bei mir eine menge Logzeilen eingespart ;-)

    In der "www"-Datei steht nur


    <?php include($_SERVER['DOCUMENT_ROOT']."/index.php"); ?>


    Werde es mal eben ausprobieren...


    EDIT:
    Noch kein gewünschter Erfolg. :(


    Vllt nochmal als Nachtrag... ich rufe meine URL auf.

    Code
    1. z.B. http://domain.tld/www/home/login


    Da die WWW Datei als PHP-Datei agieren soll, die die index.php included, kann ich in der index.php die URL auseinanderpflücken und muss nicht mit den $_GET-Variablen arbeiten..

    Hi,


    ich laufe mittlerweile vor eine Wand! Ich habe jetzt etliche Szenarien durchgespielt und jedes mal bekomme ich einen 404 Fehler.


    Mein Ziel: Die Datei "www" als PHP-Datei zu parsen. Die mache ich über die .htaccess-Datei wo folgendes drin steht:


    Code
    1. <Files www>
    2. ForceType application/x-httpd-php
    3. </Files>


    Auf einem anderem System ohne ISPCP/Plesk funktioniert es einwandfrei.


    Der VirtualHost im Apache hat auch aktive Optionen wie:
    Options +All
    und
    AllowOverride All


    Mir fällt mittlerweile nicht's mehr ein...


    Habt ihr eine Idee?



    Gruß

    Die Fehlermeldung ist doch eigentlich eindeutig oder nicht? ;-)


    Code
    1. eAccelerator: Could not allocate [B]50331648 bytes[/B], the maximum size the kernel allows is [B]33554432 bytes[/B]. Lower the amount of memory request or increase the limit in [B]/proc/sys/kernel/shmmax[/B].


    Klingt doch eigentlich logisch.. der kann sich nicht mehr rausnehmen, als ihm vom Kernel zur Verfügung steht.


    Du willst 48 MB nutzen, hast aber nur 32 MB zur Verfügung. Um mehr nutzen zu können, musst du den Kernel-Parameter kernel.shmmax erhöhen. Meines Wissens ist es aber auf einem vServer nicht möglich und muss, in dem Fall, durch netcup angepasst werden.



    Gruß,
    Jan