Posts by CS2017

    Bei meiner Recherche zum Thema habe ich auch Meinungen gelesen, die vom Einsatz solcher Plugins wie Better Search Replace abraten und die Änderungen per phpmyadmin empfahlen. Sieht so aus, als ob jetzt alles wieder laufen würde. Das Kontaktformular hab ich einfach neu erstellt. Bleibt die Frage, ob ich mir über die offensichtlich in der Datenbank verbliebenen http-Einträge (siehe oben) Gedanken machen muss?

    Danke DerRené für deine Hinweise!

    Allerdings konnte ich mit "Tabellenname" und "Feldname" nicht viel anfangen. Ich habe mir mit diesen Befehlen geholfen, die ich im Netz gefunden habe:


    UPDATE wp_options SET option_value = replace(option_value, 'http://www.ihreseite.de', 'https://www.ihreseite.de') WHERE option_name = 'home' OR option_name = 'siteurl'; UPDATE wp_posts SET guid = replace(guid, 'http://www.ihreseite.de','https://www.ihreseite.de'); UPDATE wp_posts SET post_content = replace(post_content, 'http://www.ihreseite.de', 'https://www.ihreseite.de'); UPDATE wp_postmeta SET meta_value = replace(meta_value,'http://www.ihreseite.de','https://www.ihreseite.de');


    Das hat soweit auch funktioniert. Allerdings erhalte ich, wenn ich in der Datenbank nach http://www.ihreseite.de suche, immer noch 14 Treffer. Alle in "wp_options". Wie bekomme ich das auch noch geändert?


    Und ich habe festgestellt, dass mein Kontaktformular nicht mehr funktioniert: "Beim Versuch, deine Mitteilung zu versenden, ist ein Fehler aufgetreten. Bitte versuchen Sie es später noch einmal!"


    Ich habe, wie oben beschrieben, die Datenbank modifiziert, in Wordpress unter Einstellungen-Allgemein die Wordpress-Adresse und die Website-Adresse auf https gestellt und im WCP in den Hosting-Einstellungen 301 Redirect von http auf https eingestellt.

    Du solltest nur nach deiner Domain suchen und diese ersetzen!

    In SQL gibts eine Replace()-Funktion die das kann. Also suchen nach deiner kompletten Domain (mit http://) und diese ersetzen durch deine komplette Domain mit https://


    Du kannst das natürlich auf keinen Fall für alle Seiten machen denn es soll ja Seiten geben die 2018 immer noch nicht über https erreichbar sind!

    Alles klar, dann versuch' ich mal mein Glück.

    Hallo geekmonkey ,


    Ich habe jetzt das Let's Encrypt-Zertifikat meiner Website zugewiesen. Der nächste Schritt wäre dann ja das Anpassen der Datenbank. Ich habe versucht, deinen Tipp nachzuvollziehen und per phpmyadmin nach http:// zu suchen. Da erhalte ich 1257 Einträge. Nur finde ich keine Möglichkeit, etwas zu ersetzen. Gibt es dafür irgendwo eine spezielle Suchen-Ersetzen-Funktion?


    Und noch etwas ist mir aufgefallen: Wenn ich in den Suchergebnissen auf eine der Tabellen klicke und mir die Details anschaue, sehe ich nicht nur Links die sich auf meine Website beziehen, sondern auch Links zu externen Seiten wie z. B. http://rpc.pingomatic.com/. Diese URLs würden doch auch auf HTTPS geändert und das wäre dann wohl nicht der Sinn der Sache, oder habe ich da etwas falsch verstanden?

    Ich habe gestern Abend die Domain auf den neuen Webspace geschaltet. Mittlerweile scheint das auch alles zu funktionieren.

    An dieser Stelle noch einmal ganz herzlichen Dank an ThomasChr für die schnelle Hilfe!!! Hätte ich allein nicht hinbekommen.


    Das nächste Projekt wird dann die Umstellung auf HTTPS sein. Da graut mir jetzt schon davor. ;-) Gegebenenfalls werde ich mich hier im Forum noch einmal dazu melden, wenn ich es alleinnicht hinkriege.


    Eine Frage noch zum Thema Umstellung und e-Mail: Ich habe für zwei meiner Domains je eine Mailadresse. Beide Domains sind nun auf den neuen Webspace geschaltet. Die Mailadressen sind eingerichtet und ich kann von beiden Accounts aus Mails verschicken. Wenn ich allerdings Mails an die beiden Adressen verschicke, kommt momentan eine Mail bei einem der alten Mailkonten an (diese Domain habe ich schon vor ein paar Tagen umgestellt), die andere kommt weder beim alten noch beim neuen Konto an (diese Domain habe ich gestern Abend umgeschaltet). Woran könnte es liegen? Bin für jeden Tipp dankbar.

    Hallo mlohr,

    offensichtlich fehlten ein paar Files eines WP-Plugins. Das habe ich inzwischen behoben.

    Allerdings hängts jetzt an anderer Stelle: Wenn ich im WCP die Vorschau der Seite im neuen Hosting aufrufe, werde ich zur alten Website (im alten Hosting) weitergeleitet. Ich kann mir nicht erklären, warum! Ich habe versucht, die .htaccess im neuen Hosting zu löschen - trotzdem werde ich weitergeleitet. Die Domain ist noch NICHT auf das neue Hosting geschaltet.

    Vielleicht kann ThomasChr bei Gelegenheit noch einmal draufschauen??

    Danke für eure Antworten!


    mlohr : Ich kann im WCP auf Protokolle klicken und sehe dann für den Zugriff einen Fehler 500. Gibt es noch eine andere Möglichkeit, Logs einzusehen?


    @geemonkey: Die Schritte 1-6 habe ich so befolgt. Die Domain zeigt noch nicht auf den neuen Hosting-Tarif, da ich das noch nicht eingestellt habe. Ich möchte ja erst meine Wordpress-Installation migrieren, schauen ob alles läuft und dann die Domain auf das neue Hosting umschalten.


    Wenn ich domain.de/wordpress/index.php aufrufe, bekomme ich ebenfalls einen weißen Bildschirm.


    Ich bin mir auch unsicher, ob es reicht, die Datenbank korrekt in de wp-config.php einzutragen oder muss ich im WCP die Datenbank einer Website zuweisen? Das habe ich, wie oben beschrieben, nicht gemacht, weil die Domain ja noch nicht auf den neuen Tarif zeigt und damit als Auswahlmöglichkeit gar nicht auftaucht. Andererseits - für irgend etrwas muss diese Einstellmöglichkeit ja da sein.

    Hallo allerseits!


    Ich bin relativer Wordpress-Neuling und auch sonst mit dem ganzen Thema Websites & Co. noch nicht wirklich fit. Ich habe mich aber trotzdem an den Umzug meiner Wordpress-Installation von einem alten Confixx-Tarif zu einem aktuellen Hosting gewagt. Ich bekomme es irgendwie nicht hin und hoffe, jemand kann helfen?!


    Ich beschreibe hier einmal, was ich bisher gemacht habe:


    - per FTP das komplette Verzeichnis „meinedomain“, auf das meine Domain geroutet ist, vom alten Webspace heruntergeladen

    - dieses Verzeichnis komplett auf den neuen Webspace hochgeladen, so dass der Pfad zur Startdatei jetzt so aussieht: httpdocs/meinedomain/index.php, Wordpress liegt hier: httpdocs/meinedomain/wordpress/

    - alte Datenbank aus phpMyAdmin exportiert und heruntergeladen

    - im neuen Hosting im WCP eine neue Datenbank angelegt. Im Gegensatz zur hier beschriebenen Anleitung (https://www.netcup-wiki.de/wiki/Umzug_des_Webhostings) kann man dort den alten Datenbanknamen nicht übernehmen, da zwangsweise ein Kürzel vorangestellt wird, so dass der neue Name der Datenbank „k25355_meinedatenbank.sql“ lautet. Das Gleiche gilt für den Datenbankbenutzer.

    - nach dem Anlegen der neuen Datenbank „k25355_meinedatenbank.sql“, die alte Datenbank „meinedatenbank.sql“ importiert

    - Im WCP kann man der angelegten Datenbank einer Website zuweisen. Das habe ich bisher noch nicht gemacht, da die Website ja noch im alten Tarif läuft und demzufolge im WCP noch nicht als Option auftaucht. Ist das korrekt?

    - in der wp-config.php DB_NMAE, DB_USER, DB_PASSWORD, DB_HOST entsprechend geändert und auch den Pfad für ein Caching-Plugin angepasst


    Jetzt möchte ich natürlich vor dem switchen der Domain auf den neuen Webspace testen, ob die migrierte Wordpress-Installation läuft. Dazu habe ich die vorläufige Domain + Pfad zur Start-Datei (vorläufigeURL/meinedomain/index.php) im Browser eingegeben. Ich bekomme nur einen weißen Bildschirm. Wenn ich im WCP unter Protokolle nachschaue, sehe ich für den Aufruf einen Error 500.

    Ich habe nun ewig herumprobiert und gegoogelt und komme nicht weiter. Der Netcup-Support verweist leider auch nur auf das Wiki und eben dieses Forum. Könnte bitte jemand helfen?


    1000Dank und LG,

    Christoph

    Offenbar hat es so nicht geklappt. Mein Befehl zum Löschen aller Dateien, die älter als 2 Tage sind, sieht jetzt so aus:

    Code
    1. find /var/www/web123/html/ordner001/ordner01/* -mtime +2 -type f -delete

    Sollte doch korrekt so sein. Oder habe ich da einen Fehler drin?

    Das werde ich gleich ausprobieren. Vielen Dank für die schnelle Antwort!

    Ob SSH möglich ist, weiß ich nicht. Ich habe zumindest in Par. Confixx nichts dazu gefunden. Aber Renés Tipp zur Ermittlung des Serverpfades hat prima funktioniert. Jetzt läuft alles so, wie es soll. Nochmals vielen Dank für die Hilfe und eure Geduld!