[gelöst] Vanilla-Minecraftserver: Authentifizierungsprobleme beim Verbinden

  • Hallöchen zusammen,


    ich habe seit heute einen Root-Server M bei netcup und habe mir als OS dort ein Debian Jessie über "offizielle Images" auf dem VCP Panel eingespielt.
    Da ich vorhabe dort unter anderem einen Minecraftserver laufen zu lassen, habe ich erstmal diverse Pakete (u.a. openjdk-8-jdk über Jessie Backports) installiert. Das war für mich nichts außergewöhnliches und hat auch alles problemlos geklappt, da ich nicht zum ersten Mal einen Minecraftserver auf Linux aufsetze.


    Ich hab mir also mein Server Setup auf den vServer hochgeladen und dann in einem tmux den Server gestartet:

    Code
    1. minecraft@_zensiert_#~/Minecraft$ ./ServerStart.sh


    Dies ist meine ServerStart.sh:

    Shell-Script
    1. #!/bin/bash
    2. # auskommentierte Variation habe ich erfolglos probiert
    3. # java -server -Xms2048M -Xmx4096M -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts -Djava.net.preferIPv4Stack=true -jar minecraft_server.1.8.9.jar nogui
    4. java -server -Xms2048M -Xmx4096M -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts -jar minecraft_server.1.8.9.jar nogui


    Dies ist meine server.properties von meinem praktisches leerem und neuen Testserver:


    Ich starte also den Server und sehe bei mir in meinem lokalem Client in der Server Liste, dass der Server online ist. Wenn ich mich aber versuch darauf zu verbinden bekomme ich die Meldung "Authentication Servers are down. Please try again later". Auf dem Server sieht man folgendes:


    Dass die Login Server von Mojang offline sind ist ja was recht gängiges, aber das ist hier definitiv nicht das Problem, da ich auf meinem privatem Setup mich problemlos auf den Server verbinden kann und auch andere Server erreichbar sind.
    Meine IP Tables sind standardmäßig (zumindestens noch) leer und ich kann mir momentan absolut nicht vorstellen, warum ich mich hier nicht auf den Server verbinden kann. Ich hab einige Minecraft Server auf privater Hardware gehostet und hatte nie irgendwelche Probleme dieser Art.


    Ich möchte nochmal anmerken, was ich bereits probiert habe:

    • DNS Server ohne Erfolg geändert
    • Mojang Login Server sind per ping erreichbar ($ ping authserver.mojang.com)
    • openjdk-8-jdk deinstalliert und durch openjdk-7-jdk ersetzt, ohne Erfolg
    • Mein Server Setup gelöscht und neu aufgesetzt, ohne Erfolg
    • Variation meines Start Scripts (mit prefer IPv4 stack, siehe oben) getestet, ohne Erfolg
    • Uhrzeit vom System ist korrekt eingestellt
    • onlinemode auf false setzen, dann kann ich micht tatsächlich verbinden, allerdings möchte ich das bei meinem Server Setup nicht so haben

    Daher möchte ich einfach mal in die Runde fragen: Hat jemand von euch schoneinmal dieses Problem gehabt und weiß woran das möglicherweise liegen könnte?


    EDIT - Problem gelöst:


    Okay, ich entschuldige mich nochmal für meinen Post, da ich mittlerweile die Ursache des Problems gefunden hab:
    Anscheinend gab es ein Problem damit, dass der Server keine verschlüsselte Verbindung zu Mojang aufbauen konnte. Gelöst habe ich das mit einem "update-ca-certificates -f".

  • [...]


    EDIT - Problem gelöst:


    Okay, ich entschuldige mich nochmal für meinen Post, da ich mittlerweile die Ursache des Problems gefunden hab:
    [...]

    Du musst Dich nicht dafür entschuldigen, einen Thread zu dem Thema eröffnet zu haben.
    Du hast das Problem selber gelöst, das ist doch toll!
    Da Du die Lösung genannt hast kann Dein Beitrag noch hilfreich sein für andere User, die ähnliche Probleme haben.
    Vorrausgesetzt sie nutzen die Suchfunktion des Forums :-)

    [table='liebe Grüße - schentuu, ']
    [*]~[*] Tutorial-Empfehlung: vi(m) lernen
    [*]Betreibt 3 netcup Root-Server mit Funtoo-Linux [*] IRC von Kunden für Kunden: #nc-kunden (iz-smart.net)
    [*]darunter Minecraft Gameserver, git server, etherpad u.v.m.[*]Für Server Anfänger: Linux Selbsttest
    [/table]