Posts by Pinguin

    Zu deinem Problem beim mittels SSH, siehe owncloud console (occ) funktioniert nur nach config Änderung und legt Weboberfläche lahm
    Beachte, das nach jedem update von OwnCloud du diese Änderung wieder eintragen musst.


    Zu /dev/urandom könntest durch ändern in:

    Code
    1. /var/www/vhosts/hostingxxxx.afxxx.netcup.net/dev/urandom

    in allen Php Dateien ca. 14 verschiedene Stellen das Problem beheben um die starken Zufallszahlen und nicht die schwachen vom Php-Interpreter nutzen zu können. Schmeist aber ab Version 9 eine Warnung, da der Code Kryptografisch signiert ist.


    Die anderen Dinger lassen sich nur durch einen nicht kastrierten Rootserver lösen und führen momentan zu Problemen beim Teilen zwischen Owncloud Installationen.Läuft bei mir 8.2.3 und 9 soweit ganz gut.


    Was genau geht bei Version 9 nicht?

    Versuch mal /etc/initramfs-tools umzubenennen in zB. /etc/initramfs-tools-Sicherung, alle Änderungen in aptitude etc. aufheben, initramfs-tools neu installieren, Kernel auktualisieren oder neu installieren. Bin mir nicht sicher, ob es dieser Fehler ist, aber damit habe ich dieses Problen, das sich der Kernel nicht aktualisiern lies beheben können.

    Vielen Dank Christian,


    damit funktioniert es. Ich würde gerne wissen, ob dies eine Fehlkonfiguration ist und damit nur ich betroffen bin, mit obiger Änderung war, oder nur wenig versuchen die occ zu nutzen. Oder ob ich dies als Verbesserung bei Owncloud einreichen soll.


    Wie ist es hier üblich, Thema als gelöst markieren, wenn Problem behoben, oder wenn wie hier die Diskussion erwünscht ist auf ungelöst lassen?
    MfG Pinguin

    Moin,


    owncloud läuft mit dem Eintrag in der config.php:

    Code
    1. 'datadirectory' => '/var/www/vhosts/hostingxxxx.afxxx.netcup.net/httpdocs/data',

    auf der Weboberfläche alles fein, wird über

    Code
    1. /usr/local/php56/bin/php httpdocs/occ status

    die Owncloud Konsole gestartet kommt es zur Fehlermeldung. Wird obige Variable so gekürzt,

    Code
    1. 'datadirectory' => '/httpdocs/data',

    das es der Sichtweise aus der chroot Umgebung entspricht funktioniert die Owncloud Konsole, aber die Weboberfläche nicht.
    Der Fehler ist meiner Meinung nach der, mein in der Bash gestarteter php Aufruf hat eine andere Umgebung als der php Prozess, welcher über einen http... Aufruf gestartet wird.
    Gibt es eine Umgebungsvariable, die bei einem manuellen Aufruf gesetzt werden muss, damit das ohne Änderungen funktioniert? Bzw. kann jemand bitte bei seiner oc Installation (in einem Expert shared hosting) dies prüfen.


    Bin auf Erklärungen und Lösungsansätze gespannt.
    Ein gutes neues Jahr.
    Pinguin