Posts by tldev

    Der Vergleich ist schon deswegen Bullshit, weil ein IT Provider mit einem IT Broker verglichen wird.


    Es ist ja kein Geheimnis, dass die Systel vom eigenen RZ weggeht bzw. damit eigentlich schon fast fertig sein sollte. Die kaufen ja bei AWS und Co ein. Sprich, Netcup ist von der Sache nicht das gleiche, sondern das, was für die Systel ein einfacherer Zulieferer wäre.

    Und das ist kein Argument gegen den Kontrahierungszwang ;)

    Das problematische an der Systel-Geschichte ist meiner Meinung nach der Kontrahierungszwang. Die Systel kann ja gern verlangen, was sie möchte - muss dann aber auch den Wettbewerb mit anderen Anbietern eingehen und den Preis durch die Leistung rechtfertigen.


    Durch den Konteahierungszwang muss innerhalb des Konzern wohl die Systel beauftragt werden, d.h. es gibt nicht einmal eine Wahl. Für eine Testumgebung sind 300€/Monat definitiv zu viel, da würden es die 15€ bei netcup auch tun bzw die ~100€ bei AWS & co ;)

    Haben eine Instanz der managed Cloud 1000 G9 bestellt. Leistungstechnisch echt ein Monster. Das System gibt's bzw gabs zumindest (noch) nicht auf der Webseite, ist aber schon in der netcup XML enthalten ;) Dazu kommt ein eigenes /23 Netz, welches wir bei netcup announcen lassen. Prinzipiell ist geplant, das Cluster mit weiteren Nodes zu erweitern, da wollen wir aber erstmal ein paar Monate Erfahrung sammeln ;)

    Entscheidend ist das Rechnungsdatum, nicht der Intervall des Vertrages ;)

    stimmt so leider nicht ganz - entscheidend ist das Leistungsdatum. Wenn man es ganz genau nimmt müsste netcup je nach Monat unterschiedliche MwSt Sätze auf die Rechnung nehmen. Da wir alle ja im voraus bezahlen bin ich mir nicht ganz sicher wie die Regelung dann umgesetzt wird...

    "Gegenposition": Ich persönlich sehe hier keine störenden Effekte der Virtualisierung, welche gerade bei den ersten Schritten mit kleineren Konfigurationen kaum zum Tragen kommen können.

    Okay, da war ich vielleicht nicht ganz konkret ;) Mir gings eher um den Punkt, dass sich virtualisiertes vs. physisches Cluster doch recht unterscheiden und ich mit meiner Testphase möglichst nah an eine potentielle spätere Infrastruktur rankommen möchte. Die Raspberry-Geschichte klingt eigentlich auch ziemlich geil - das hab ich bisher verworfen, weil ich dachte dass ARM zu sehr einschränkt. Evtl. war ich da etwas vorschnell - das schau ich mir auf jeden Fall nochmal an! Wobei auf den ersten Blick z.B. Proxmox für arm etwas experimentell zu sein scheint...


    Willst du das ganze eigentlich 24/7 laufen lassen?

    24/7 wäre schon ganz nice - ich würde gern auch versuchen zeitnah reale Anwendungsfälle zu fahren, z.B: eben geteiltes Dateisystem für VMs etc. Ein SBC mit x86 CPU wäre dann natürlich auch noch ne gute Idee - wobei ich dann preislich vermutlich auch fast wieder bei den Mini-PCs bin, oder?

    Moin moin zusammen,


    ich würde mich gern mehr mit Cluster-Technologien auseinandersetzen - z.B. ceph, Docker Swarm / Kubernetes etc pp. Zu Hause im Homelab habe ich aktuell einen DellT320 mit esxi stehen - der würde Kapazitäten bieten um zu basteln. Eigentlich würde ich das aber am liebsten mit echter Hardware machen um näher am eigentlichen Anwendungsgebiet zu sein und evtl. störende effekte der Virtualisierung direkt vermeiden zu können (fängt ja schon beim Speicher an - da machts nen Unterschied ob das komplette Ceph-Cluster auf dem gleichen RAID liegt oder z.B. tatsächlich per Ceph verteilt ist. Insbesondere fände ich auch interessant wie sinnvoll das über eine 1Gbit-Verbindung geht bzw, ob ich da direkt auf 10Gbit wechseln sollte. Jetzt stellt sich mir die Hardware-Frage und ich komm seit geraumer Zeit nicht so richtig weiter. Da das ganze ja erstmal nur zum Testen dienen soll würde ich ungern größere Geldsummen investieren. Praktisch wäre auch, wenn ich die Hardware ggf. nach einigen Monate ohne allzu große Verluste wieder verkaufen könnte. Potentiell würde ich mit 3-4 Nodes anfangen.


    Interessant wäre dadurch z.B. gebrauchte Hardware, z.B. von afb: https://www.afbshop.de/pcs/903…hdd-dvd-rw-win10home?c=31. Da landet man bei 150€ pro Node mit nem älteren i5, 8GB RAM und 500GB Platte. Das würde eigentlich meine Anforderungen abdecken.


    Auf der anderen Seite hab ich gesehen, dass es bei aliexpress, amazon etc. recht günstige Mini-PCs gibt, die ebenfalls interessant wären und evtl. vom Stromverbrauch auch interessanter wären: https://www.amazon.de/Prozesso…44ad6d582a&language=de_DE oder https://www.amazon.de/BMAX-Com…2176ad55f3&language=de_DE Mit 130-150€ preislich etwas günstiger, aber halt auch deutlich weniger Power! Die Intel NUCs wären natürlich gigantisch (z.B. https://www.amazon.de/Intel-NU…c0f5aacf69&language=de_DE) - leider preistechnisch zu hoch. Ich würde am liebsten mit allem drum und dran nicht weit über 500€ landen.


    Habt ihr Erfahrungen in dem Bereich? Wie habt ihr an Cluster-Geschichten experimentiert?

    wo endet in Relation zu Dir der Tunnel?

    ich hab gerade den Speedtest getestet und war beeindruckt,

    wie mit der Kirche ums Kreuz des geht und die Leitung doch zu 100% auslastet :D

    (hab 100 MBit/s down und 10 MBit/s up)

    Hab jetzt erstmal den Endpunkt Frankfurt getestet, Anschluss ist wie oben geschrieben Vodafone in Karlsruhe (also geografisch gesehen und vermutlich auch leitungstechnisch ganz praktisch) ;)

    Ich war mir Todsicher, dass Hurricanes Performance genial ist... und ich sollte recht behalten.

    Was kommt denn bei dir über ipv6 so an? Ich hab nen Vodafone/Unitymedia Cablemax 1000 (Dualstack, aber bis mein Modem da ist kann ich dank fehlendem Bridge Mode nur ipv4 nutzen) und hatte unabhängig von der Tageszeit immer unter 100mbit per ipv6 über HE down. Klar, das ist schon einiges, aber schöpft meine Leitung bei weitem nicht aus, weswegen ich mir jetzt ein docsis 3.1 modem bestellt hab ;)

    Es gibt einige Issues zu dem Problem - hatte selbst auch einige Stunden damit zu tun, bis ich das Problem endlich gefunden habe (war bei uns noch ein komplizierteres Setup mit NAT und Loadbalancer davor). Problem ist, dass die nginx config aus einem Modul und einer Site besteht, die beide Port 443 nutzen wollen. Das Ändern der Seite auf Port 4444 hat bei mir das Problem gelöst, siehe https://github.com/jitsi/jitsi…87#issuecomment-606652846

    Wie wäre es mit autofs?

    Noch ein kleiner Hinweis zur Wahl der Festplatten: natürlich macht es verbrauchstechnisch Sinn wenige Festplatten mit großer Kapazität zu nutzen. Falls du ein RAID 1/5/6/10/... nutzen möchtest hat das aber auch Nachteile: Im Falle eines Defekts führt das zu sehr langen Rebuild-Zeiten. Für 12TB Platten kann das schon schnell mal einige Tage dauern - je nach Ressourcen und sonstiger Last. Habe aus diesem Grund bei mir im Homeserver nur 2TB Platten.

    AMDs neue EPYC Rome (Killermaschinen) oder die zum X. Male und weiterhin alten Skylake basierten Intel Xeons?


    Habe selbst ein neuen AMD Zen2 3900x und dieser reift erst noch, d.h. legt stetig weiter an der schon hervorragenden Performance zu und Zen2 ist nicht mit Spectre, Meltown... betroffen.

    (ein 3700x ist für den Einstieg schon heftig)

    Umfragen machen meiner Meinung nach erst dann Sinn, wenn man die Beteiligten nicht vorab mit seiner eigenen subjektiven Meinung manipuliert. Aus meiner Sicht hat das Ergebnis der Umfrage keinerlei Aussagekraft. Eigentlich schade....

    Gestern waren die restlichen Maschinen dran und es gibt eine neue Erkenntnis: die von netcup angebotene virtio-Treiber-CD scheint nicht mehr mit einem aktuellen Windows Server 2016 kompatibel zu sein - zumindest nicht, wenn man ein bestehendes System auf virtio/scsi migrieren möchte.


    Mit den aktuellsten (latest) Virtio-Treibern ging die Migration dann ganz flott: einfach den Treiber als Legacy-Hardware im Gerätemanager hinzufügen, VM herunterfahren, Treiber im SCP wechseln auf scsi und wieder starten - ganz ohne all das Gefrickel mit dism, Startreparatur usw!


    Mittlerweile laufen alle VMs über den scsi Treiber :)

    Moin zusammen,


    danke H6G und eripek für eure Antworten.


    Das mit dem Safemode hatte ich schon versucht, blieb bei mir aber ohne Erfolg - mit SCSI bootet die Windows-Installation nicht. Zurückgestellt auf IDE bootet er dann in den Safemode....


    Mit viel Probieren und einigen weiteren Links [0] und [1] hab ich es dann endlich geschafft die VM zumindest mit dem VIRTIO-Treiber zu booten. Die Performance (insb. auch beim booten) ist spürbar besser als zuvor. Natürlich liefert der SCSI-Treiber noch einige Vorteile (discard, ...), für mich ist hier aber erstmal Ende. Wenn ich das so bei allen 5 restlichen Maschinen hinbekomme, bin ich erstmal zufrieden ;)



    [0] https://dae.me/blog/2357/how-t…n-windows-system-restore/

    [1] https://christian.hofstaedtler…-dism-to-add-drivers.html

    Moin zusammen,


    kurz die Vorgeschichte:

    einer unserer Kunden hat aktuell vmware esxi als Virtualisierungsplattform im Einsatz. Die Hardware ist mittlerweile gut alt und erfüllt nicht mehr die gestiegenen Anforderungen. Aus diesem Grund ist geplant, einzelne VMs zu netcup auszulagern. Zugriff findet über einen Site-to-Site-VPN-Tunnel und die VLAN-Funktionalität bei netcup statt - die öffentlichen Netzwerkinterfaces sind komplett deaktiviert.


    Nun zum eigentlichen Problem: Wir haben erfolgreich eine bestehende Windows-VM (Windows Server 2016) exportiert und ins qcow2-Format umgewandelt. Diese ließ sich dann auch problemlos importieren, läuft aber (natürlich) nur mit dem IDE-Treiber für die Festplatte. Jegliche Versuche mit SCSI oder VIRTIO zu booten führt zu der Fehlermeldung "INACCESSIBLE_BOOT_DEVICE". Auch der Versuch die Treiber vorab manuell zu installieren (Geräte-Manager, Legacy-Hardware hinzufügen, manuell installieren, virtio-Treiber-CD auswählen, ...) führt nach dem Umstellen zu VIRTIO oder SCSI zum gleichen Fehler.


    Online liest man, dass eine zweite Platte, hinzugefügt als VIRTIO/SCSI zum korrekten Installieren der Treiber führt und nach dem entfernen der Platte auch das Bootlaufwerk umgestellt werden kann - leider ist es aber bei netcup nicht möglich eine zweite HDD hinzuzufügen...


    Hat jemand von euch eine solche Migration erfolgreich hinter sich? Wie bekommt man Windows Server 2016 nachträglich mit dem SCSI-Treiber zum laufen?


    Eine Möglichkeit hätte ich natürlich noch - ich könnte jedes Image erst in mein Proxmox-Cluster einbinden, dort den Treiber installieren und es anschließend wieder exportieren und bei netcup einspielen - aus meiner Sicht zu viel Aufwand...


    Viele Grüße

    Tobi