Posts by Turbokeks

    Ich bekomme da ständig ein:

    Quote

    Die angegebene E-Mail-Adresse ist nicht gültig. Die E-Mail-Adresse muss zur ausgewählten Domain gehören. Nur der Administrator kann in diesem Fall externe E-Mail-Adressen angeben.

    Jemand ne Idee wie ich das hinbekomme? Würde gerne alle mails an example.de an xxx@example.com schicken. (Beide Domains gehören mir)

    Das ist jetzt echt peinlich, aber ich hab endlich rausgefunden was falsch war:

    • Ich hatte lokal einen zweiten router mit eigenem DHCP gehabt, welcher allerdings kein IPv6 gesprochen hat. Zum testen mal rausgenommen
    • Ich hatte zuerst das gesamte ipv6/64 Netz als server-ip und route genommen, das klappt allerdings nicht, weil man dann ja auch als route die server-ip schickt. Also aufteilen auf zwei /65 Netze
    • Leider klappte es dann immer noch nicht, allerdings nach anwerfen des ndppd daemons, klappte auch die IPv6 Verbindung in die Welt


    Vielen Dank für die Hilfe! :thumbup:

    Hey,


    also ich hab die short & dynamic Dinger ausprobiert, plus dann noch ndppd mit folgender Conf aufgesetzt:


    Code
    1. route-ttl 30000
    2. proxy eth0 {
    3. router yes
    4. timeout 500
    5. ttl 30000
    6. rule 2a03:4000:6:b026::/64 {
    7. auto
    8. }
    9. }


    Hat leider alles nicht gefruchtet. Habe auch npd6 ausprobiert. Nope. Weder Ping, noch erkennt wieistmeineip.de die IPv6 Adresse. Irgendwo hängt es da noch, muss ich irgendwas an der Firewall freigeben? Ich bin echt irgendwie nen DAU - zumindest komme ich mir so vor bei IPv6

    Hast recht.

    Code
    1. 22:56:53.075109 IP6 (flowlabel 0x3e0d4, hlim 63, next-header ICMPv6 (58) payload length: 64) XXXX:4000:6:b026::1002 > 2a00:1450:4001:812::200e: [icmp6 sum ok] ICMP6, echo request, seq 9
    2. 22:56:53.257317 IP6 (class 0xc0, hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::1 > ff02::1:ff00:1002: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has XXXX:4000:6:b026::1002
    3. source link-address option (1), length 8 (1): <MAC>
    4. 22:56:53.257472 IP6 (class 0xc0, hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::1 > ff02::1:ff00:0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has XXXX:4000:6:b123::
    5. source link-address option (1), length 8 (1): <MAC>
    6. 22:56:54.075351 IP6 (flowlabel 0x3e0d4, hlim 63, next-header ICMPv6 (58) payload length: 64) XXXX:4000:6:b026::1002 > 2a00:1450:4001:812::200e: [icmp6 sum ok] ICMP6, echo request, seq 10
    7. 22:56:54.257003 IP6 (class 0xc0, hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::1 > ff02::1:ff00:0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has XXXX:4000:6:b123::
    8. source link-address option (1), length 8 (1): <MAC>


    Reicht es bei ndppd ein einfaches: git pull -> make -> make install? Oder muss ich da noch was confen?


    Edith: hab auch folgenden Artikel auf SO gefunden: Routing public ipv6 traffic through openvpn tunnel - Unix & Linux Stack Exchange
    Fehlt eigentlich nur die Route? Die kann ich ja pushen lassen. Bzw. mache ich das ja bereits - liegt da der Fehler?. Abschnitt aus der openvpn server.conf:

    Code
    1. #IPv6
    2. server-ipv6 XXXX:4000:6:b026::/64
    3. tun-ipv6
    4. push tun-ipv6
    5. push "route-ipv6 XXXX:4000:6:b027::/64"

    Lustigerweise klappt das jetzt. Ping auf die Adresse klappt auch. Weird stuff - habe nichts geändert an der Konfiguration.


    Vielleicht kann mir noch wer mit dem weiteren Problemchen helfen: ich habe meinem OpenVPN mein /64 IPv6 Netz zugewiesen und der Teilt auch brav meinen Clients jetzt ne IP mit. Leider komme ich mit der IPv6 allerdings noch nicht ins Internet. Bei IPv4 habe ich ja in der Datei /etc/ufw/before.rules ganz oben folgendes eingefügt:

    Code
    1. *nat
    2. :POSTROUTING ACCEPT [0:0]
    3. #Allow traffic from openvpn to eth0
    4. -A POSTROUTING -s 10.8.0.0/8 -o eth0 -j MASQUERADE
    5. COMMIT


    Und in der /etc/sysctl.conf folgendes gemacht:

    Code
    1. net.ipv4.ip_forward=1
    2. net.ipv6.conf.all.forwarding=1


    Mein Server hat die IPv6 XXXX:XXXX::1/64, der Client XXXX:XXXX::1002/64. Was muss ich jetzt machen, damit der Client ins Netz kommt? Unter IPv6 gibts ja eigentlich kein Nat (SNAT?) und somit müsste ich auch nen network interface für die ::1002 anlegen oder wie?
    Hat wer eine Idee? ?(


    Danke!

    Ich weiß, UFW liefert da ja auch paar Regeln mit in der /etc/ufw/before6.rules


    Code
    1. # ok icmp codes
    2. -A ufw6-before-input -p icmpv6 --icmpv6-type destination-unreachable -j ACCEPT
    3. -A ufw6-before-input -p icmpv6 --icmpv6-type packet-too-big -j ACCEPT
    4. -A ufw6-before-input -p icmpv6 --icmpv6-type time-exceeded -j ACCEPT
    5. -A ufw6-before-input -p icmpv6 --icmpv6-type parameter-problem -j ACCEPT
    6. -A ufw6-before-input -p icmpv6 --icmpv6-type echo-request -j ACCEPT


    ip neigh zeigt:


    Code
    1. fe80::1 dev eth0 lladdr 00:00:5e:00:02:02 router STALE
    2. 2a03:4000:6:b000::1 dev eth0 lladdr 00:00:5e:00:02:02 router STALE
    3. fe80::f21c:2d00:757d:40c0 dev eth0 lladdr f0:1c:2d:7d:40:c0 router STALE
    4. 2a03:4000:6:b000::3 dev eth0 lladdr f0:1c:2d:7d:40:c0 router STALE
    5. 37.120.191.245 dev eth0 lladdr 4a:80:a4:3a:05:1f STALE
    6. 37.120.188.2 dev eth0 lladdr f0:1c:2d:7d:60:c0 STALE
    7. 37.120.188.1 dev eth0 lladdr 00:00:5e:00:01:0a REACHABLE
    8. 37.120.188.3 dev eth0 lladdr f0:1c:2d:7d:40:c0 STALE

    Hey,


    also ich hab mich mal dran gesetzt mein IPv6 einzurichten und auch auf UFW umzustellen. Leider ist nun mein Server nicht mehr pingbar, wenn UFW aktiv ist.


    Muss ich ICMP Pakete explizit erlauben? Warum klappt der Ping vom server auf google.com nicht bei aktiver Firewall?





    Danke!

    Hey,


    ich hab seit kurzem jetzt auch einen Hosting Expert Tarif von Netcup und SSH funktioniert da ganz gut. Leider bekomme ich sehr oft einen Zertifikats fehler, wenn ich was runterladen will:

    Code
    1. --2016-02-26 00:37:13-- https://updates.drupal.org/release-history/drupal/8.x
    2. Resolving updates.drupal.org... 23.235.43.68
    3. Connecting to updates.drupal.org|23.235.43.68|:443... connected.
    4. ERROR: cannot verify updates.drupal.org’s certificate, issued by “/C=BE/O=GlobalSign nv-sa/CN=GlobalSign Organization Validation CA - SHA256 - G2”:
    5. Unable to locally verify the issuer’s authority.
    6. To connect to updates.drupal.org insecurely, use ‘--no-check-certificate’.




    Könnt ihr da von Netcup mal nen Update einspielen, damit das wieder geht? Wenn ich die URL im Browser aufmache, passt da alles einwandfrei.


    Außerdem wäre der Befehl 'which' ganz nett zu haben im Jail


    Danke

    Hey,


    seit Samstag Nacht macht mein Server komische Sachen. Nach einem Reset ging alles wieder gut bis heute Mittag. Der Server wirkt unresponsive, antwortet dann nach ner Zeit doch auf Anfragen.Ram/CPU ist nicht ausgelastet. Ich vermute, dass es irgendein Problem mit der Festplatte ist, liege ich da richtig? Hat wer sonstige Ideen?


    Im Syslog fand ich folgendes:

    Bin für jede Hilfe dankbar!

    killerbees19 : nein sicher kein DNS Caching Problem, wurde schon vor paar Wochen gemacht


    twiddern : das würde sogar Sinn machen. Ich hab halt nur einen Server, imho hab ich angenommen das ich das direkt so machen kann. Ich stells mal um auf server1.xxx.de um und schau ob dies die Situation besser macht. Sollte der MX Record dann auch auf diese Subdomain / Server FQDN zeigen?

    Hey,


    Ich hab heute routine mäßig mal wieder nen mx check gemacht und dieser liefert mir die Warnung, dass mein rDNS Hostname nicht gültig ist. ( http://mxtoolbox.com/domain/wdkk.de/ )


    Hat jemand eine Idee was hier das Problem ist? Ich habe im CCP wdkk.de als rDNS angegeben. Der MX record zeigt auf mail.wdkk.de (was die gleiche IP ist), ist es dieser Unterschied, warum die sagen, dass mein rDNS nicht gültig sei?


    Viele Grüße