Posts by Xtreme

    Hallo Zusammen,


    Ich habe folgendes Problem fuer das ich aktuell die Lösung im Webserver suche ohne die Applikation anpassen zu müssen.

    Ich habe zwei Applikationen jede greift auf das selbe Authentifizierungsmodul zu welches aber fuer jeder Applikation gesondert hinter einer anderen IP hängt.


    Beim Login in die Applikation wird ein Background request gegen das Authmodul gestartet, Problem ist die Background requests sehen bei jeder Applikation gleich aus, kann ich aber nun meine Weiterleitungen so einrichten das beide apps funktionieren?


    Das Beispiel verdeutlicht es vlt.

    location /app1 {
    proxy_pass http://IP1:8000;
    }

    https://seite.de/app1 wenn ich mich einlogge wird ein Background request an folgende url gestartet https://seite.de/auth

    location /auth {
    proxy_pass http://IP1:8001;
    }


    location /app2 {
    proxy_pass http://IP2:8000;
    }

    https://seite.de/app2 wenn ich mich einlogge wird ein Background request an folgende url gestartet https://seite.de/auth

    location /auth {
    proxy_pass http://IP2:8001;
    }

    Problem ist ja ich kann die Location nur einmalig weiterleiten und nicht doppelt, vlt hat ja einer von euch eine Idee wie ich das mit nginx lösen kann ohne die Apps anzupassen.


    Gruß

    Haben auch Probleme

    Code
    1. Host Loss% Snt Last Avg Best Wrst StDev
    2. 1. gw02.netcup.net 0.0% 135 1.8 4.3 0.7 70.4 10.5
    3. 2. ae3-4018.bbr01.anx84.nue.de.anexia-it.net 0.0% 134 2.2 2.2 0.8 22.5 2.7
    4. 3. ae2-0.bbr02.anx25.fra.de.anexia-it.net 0.0% 134 5.2 5.7 4.0 25.1 2.6
    5. 4. dtag-gw.bbr02.anx25.fra.de.anexia-it.net 35.8% 134 110.5 111.2 109.5 125.4 2.1
    6. 5. 91.23.195.245 36.6% 134 117.8 117.5 116.5 127.1 1.1
    7. 6. p5B0B4123.dip0.t-ipconnect.de 40.3% 134 122.9 122.4 121.1 123.6 0.2

    Noch wer Server Probleme? Meiner ist nicht erreichbar,


    Controlpanel meldet unteranderem:


    Ein Serverfehler ist aufgetreten. Sollte der Fehler wiederholt auftreten, setzen Sie sich bitte mit dem Support in Verbindung.


    "An internal error has occurred within the Guacamole server, and the connection has been terminated. If the problem persists, please notify your system administrator, or check your system logs."


    Vor einer knappen STunde lief er noch

    Guck dir das mal an


    ProFTPD: HowTo: Server Config


    Besonders der Abschnitt


    Tuning:


    Quote

    "Abschliessend können noch einige Configure Optionen benutzt werden, um ProFTPD zu optimieren. Es stehen einige ./configure Optionen zur Verfügung, speziell die --enable-tunable-buffer-size und --enable-sendfile sind von Interesse. Die Sendfile Option wird nicht unbedingt den Download Speeed erhöhen, jedoch die Disk I/O reduzieren. "Sendfile" implementiert dabei den "zero-copy" transfer, das bedeutet, dass der Kernel die Daten in den Socket liest (alles im Kernel Space). Normalerweise wird bei read() erst vom Kernel Space in den application Space kopieren (das File lesen), dann zurück in den Kernel space (in den Socket schreiben).
    Durch erhöhung der Buffer Grösse durch die "--enable-buffer-size" Option liest und schreibt ProFTPD die Daten in grösseren Portionen und benötigt so weniger aufwändige Systemaufrufe. Es wurde berichtet, dass die Erhöhung dieses Wertes auf 8092 Byte (8 kb) die Übertragungsgeschwindigkeit dramatisch erhöht hat."

    Moin Moin,


    startest du denn Server mit JVM Argumenten?


    Mit -XX: ParallelGCThreads=2 solltest du z.b. die Last auf die Kerne verteilen können


    Wir haben einen KVM Root Server L alte Generation mit 2 Kernen je 2GHz mit Feed The Beast Monster und das läuft problemlos auf 2 Kernen.