Posts by Rogue

    Hallo Ringelnatz,


    erstmal vielen dank für das Script... Hat sofort ohne Probleme geklappt.

    Jetzt ist Composer auf alle meine Damain verfügbar...


    Danke...


    Gruß

    hi,


    kann ich gut verstehen, dass man das bestimmt nicht machen kann.

    Ich möchte von jeden Verzeichnis wo ich mich gerade befinde, es ausführen kann.

    Composer will ich wegen Drupal installieren, damit das Update von Drupal besser läuft bzw einfacher ist.


    gruß

    Hallo Comunity,


    wollte gerne zu meinen Webhosting 8000 Composer installieren.

    Das Installieren ist nicht das Problem, dass habe ich hinbekommen.


    composer systemweit zu installieren.

    ============================

    Laut Anweisung aus einen Forum:

    Link zum Forum

    1. Wechseln Sie in ein Verzeichnis in Ihrem Pfad wie  cd /usr/local/bin
    2. Holen Sie sich Komponist  curl -sS https://getcomposer.org/installer | php
    3. Mach das Phar ausführbar  chmod a+x composer.phar
    4. Wechseln Sie in ein Projektverzeichnis  cd /path/to/my/project
    5. Verwenden Sie Composer wie gewohnt  composer.phar install
    6. Optional können Sie die Datei umbenennen  composer.phar  zu  composer  zu erleichtern

    Schon bei Punkt 1. komme ich nicht weiter, da ich mit Shell SSH keine berechtigung zum Verzeichnis cd /usr/local/bin habe

    Gibt es eine Alternative, um composer systemweit ausführen zu können ?


    composer kann ich zurzeit nur unter mein verzeichnis html/domain ausführen.

    bash-4.3$ php compose


    Kann mir einer da weiter helfen? damit ich composer systemweit ausführen kann?


    Gruß

    Hallo,


    da gebe ich dir recht...
    sowas ist eine frechheit, ein script rauszubringen, was nur mit einer älteren Version von PHP läuft.
    Ich habe sogar jetzt meine PHP auf auf 5.5 geupdate... und ich lasse es auch so...


    Nur funktioniert mein Froxlor Themen nicht mehr.... aber das ist nicht so will....
    Besser auf Sicherheit zu gehen, als aufs aussehen, grins...


    Muss mir was anderes überlegen, wie ich dass Script zum Laufen bringen kann...


    Gruß
    Rogue

    Danke euch beiden...


    perryflynn,
    deine bedenken sind berechtigt, aber in der Anleitung vom Script wird extrag darauf hingewisen, dass er die php Funktion braucht, was mich persönlich etwas abschreckt.


    Aber solange die Funktion nicht angepasst wirt, kann ich das Script nicht verwenden.
    Aber ob es auf dauer ist, und ob ich noch abhelfe Schafen kann, kann ich jetzt noch nicht sagen...


    Gruß
    Rogue

    Guten Morgen,


    ich habe eine Rootserver, und möchte bestimmt php Funktion einstellen.
    Leider finde ich nicht auf Anhieb die richtig Datei bzw. Ordner


    folgender Hintergrund.
    Ich habe ein Script das folgendes benötigt...



    register_globals=ON
    Ansonsten Fehlermeldungen kein Login und keine Anmeldung möglich (was zurzeit auch passiert)
    - PHP save_mode=OFF
    Ansonsten kein hochladen von Bildern möglich


    Sind schon eingestellt
    ==================
    - GD Support = enabled
    mit GIF und JPG Unterstützung, ansonsten können die Bilder nicht
    angepasst werden
    - BCMath Support = enabled
    Wird im Admin- und Userbereich benötigt



    register_globals=ON,
    PHP save_mode=OFF



    müssen noch umgestellt werden...


    Kann mir einer sagen wo bzw in welchen Verzeichnis ich die Datei finde...
    Denn ich habe schon in anderen Forum gelesen dass es in der <directory> eingetragen werden muss.

    Quote

    Ja, das ist über die optionalen Einstellungen bei der Domain in den <directory> - Einstellungen definierbar.

    Kann mir einer weiter helfen?


    Gruß
    rogue

    1. Lösung...
    Hintergrund:


    Im verzeichnis /var/www/roundcube liegt mein webmail Rouundcube.
    Und auf meinen Server habe ich eine domaine (domaine1.de) ohne kunden zuordnung.


    Wenn ich eine Subdomaine unter Domaine 1 erstellen möchte, geht das nur über VirtualHost:



    <VirtualHost IP-Adresse:80>
    ServerName webmail.domaine1.de
    ServerAlias *.webmail.domain1.de
    DocumentRoot /var/www/roundcube
    <Directory "/var/www/roundcube">
    allow from all
    Options +Indexes
    </Directory>
    </VirtualHost>


    Das Funkzoniert auch....


    Aber wenn ich von meiner Kunden Domaine(domaine2.de) (/var/www/customers/webs/web1) eine subdomaine anlege, und auf das Verzeichnis DocumentRoot (/var/www/roundcube) dann gibt er mir nur die hauptseite... Er lösst also das DocumentRoot nicht aus...



    NameVirtualHost *:80
    <VirtualHost *:80>
    ServerName http://www.dommain2.de
    ServerAlias dommain2.de
    DocumentRoot /var/www/customers/webs/usrweb01
    <Directory "/var/www/customers/webs/web1">
    allow from all
    Options +Indexes
    </Directory>
    </VirtualHost>


    <VirtualHost IP-Adresse:80>
    ServerName webmail.domain2.de
    ServerAlias *.webmail.domain2.de
    DocumentRoot /var/www/roundcube
    <Directory "/var/www/roundcube">
    allow from all
    Options +Indexes
    </Directory>
    </VirtualHost>


    Ich habe da irgend wo ein gedanken fehler...


    Kann mir einer sagen, was ich da falsch gemacht habe?


    Gruß

    Hallo,


    danke das du geantwortet hast.
    Also ich habe einen Privaten Accout als usrweb01 mit domain
    und wollte nun Roundcube als subdomain aufrufen lassen,
    aber leider macht er das nicht so wie er soll.


    Er ruft immer nur die domain auf, und nicht das subdomain = DocumentRoot /var/www/roundcube/
    habe auch schon den apache2 neu gestarten und die VHost datein eingebunden...


    Aber er einfach nicht die subdomain richtig aufmachen...


    Verzeichnis:
    /etc/apache2/sites-available/testdatei.conf



    <VirtualHost *:80>
    ServerName subdomain.domain.de
    ServerAdmin admin@domain
    DocumentRoot /var/www/roundcube/
    <Directory /var/www/roundcube/>
    Options indexes FollowSymLinks MultiViews AllowOverride All
    </Directory>
    </VirtualHost>


    Einbinden mit : a2ensite testdatei,conf



    Apach2 neu starten
    /etc/init.d/apache2 reload


    vielleicht habe ich da ein gedanken fehler..


    Gruß

    Hallo Gemeinde,


    habe mal eine doofe frage...
    Kann man e-Mail Adresse bzw. Konten Anlegen ohne Froxlor(admin Panel) ohne Kunden.
    Also ich möchte eine url als hauptdomaine verwenden (Ohne Kunde), so das man die server ip nicht eingeben braucht um den roundcube aufzurufen.
    Das Funkzoniert auch wunderbar. nur möchte ich zu der domaine auch e-mail adressen einrichten...
    So das man auch über roundcube die mail abrufen kann...


    Kann mir einer da etwas weiter helfen?


    Gruß

    Hallo und einen guten Abend,


    danke für die befehlszeile...


    zur helfte hattest du recht, es lag daran.


    So für alle die das Gleiche problem haben oder hatten.


    Wenn ihr kein ftp zugang (port 21) bekommt, dann kontrolliert ob der cronjob ausgeführt wird.


    Code
    1. /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force




    Sollte danach es noch nicht klappen, so ändert mal das passwort im kundenbaum bei ftp.
    :-)


    Also nachdem ich die Befehszeilen ausgeführt habe und dann anschließen ein neues Passwort vergeben haben,
    konnte ich mich als ftp (port 21) mich einloggen.


    PRIMA


    Besten danke die jungs die mir geholfen haben...


    Gruß
    Rogue

    hi,


    nein, habe das selbe system pw benutzt wie am Anfang...
    Ich kann dir meine log von ftp server local geben, da ist alles 1zu1 zum hauptroot server(online Anbieter)
    aufgebaut.


    Log ftp Server


    Dez 20 08:48:30 debian proftpd[9552] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 20 08:51:50 debian proftpd[9552] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 20 08:51:50 debian proftpd[9552] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 20 08:51:52 debian proftpd[9614] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 20 11:28:02 debian proftpd[9614] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 20 11:28:02 debian proftpd[9614] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dec 28 21:32:50 debian proftpd[2969] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dec 28 22:27:06 debian proftpd[2969] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dec 28 22:27:06 debian proftpd[2969] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 28 22:27:08 debian proftpd[5667] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 28 23:11:13 debian proftpd[5667] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 28 23:11:13 debian proftpd[5667] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dec 29 10:47:31 debian proftpd[3030] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dec 29 11:42:05 debian proftpd[3030] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dec 29 11:42:05 debian proftpd[3030] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 11:42:07 debian proftpd[3546] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 12:11:52 debian proftpd[3546] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 12:11:52 debian proftpd[3546] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 12:11:54 debian proftpd[3842] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 12:13:24 debian proftpd[3842] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 12:13:24 debian proftpd[3842] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 12:13:26 debian proftpd[3898] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 13:26:29 debian proftpd[3898] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 13:26:29 debian proftpd[3898] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 13:26:31 debian proftpd[4332] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 14:27:39 debian proftpd[4332] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 14:27:39 debian proftpd[4332] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 14:27:41 debian proftpd[5301] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 14:29:55 debian proftpd[5301] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 14:29:55 debian proftpd[5301] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 14:30:31 debian proftpd[5423] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 14:31:51 debian proftpd[5423] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 14:31:51 debian proftpd[5423] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 14:31:53 debian proftpd[5483] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 20:35:37 debian proftpd[7510] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 20:35:37 debian proftpd[7510] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): mod_sql/4.3: unrecoverable backend error: (1045) Access denied for user 'froxlor'@'localhost' (using password: YES)
    Dez 29 20:35:37 debian proftpd[7510] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): mod_sql/4.3: check the SQLLogFile for more details
    Dez 29 20:35:37 debian proftpd[7510] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    Dez 29 20:35:42 debian proftpd[7512] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 20:35:42 debian proftpd[7512] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): mod_sql/4.3: unrecoverable backend error: (1045) Access denied for user 'froxlor'@'localhost' (using password: YES)
    Dez 29 20:35:42 debian proftpd[7512] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): mod_sql/4.3: check the SQLLogFile for more details
    Dez 29 20:35:42 debian proftpd[7512] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    Dez 29 21:13:08 debian proftpd[5483] debian.sto-dgi.eu: ProFTPD killed (signal 15)
    Dez 29 21:13:08 debian proftpd[5483] debian.sto-dgi.eu: ProFTPD 1.3.4a standalone mode SHUTDOWN
    Dez 29 21:13:09 debian proftpd[7687] debian.sto-dgi.eu: ProFTPD 1.3.4a (maint) (built Fri Sep 19 2014 15:21:54 UTC) standalone mode STARTUP
    Dez 29 21:13:33 debian proftpd[7705] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 21:13:33 debian proftpd[7705] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): USER usrweb01 (Login failed): Limit access denies login
    Dez 29 21:13:33 debian proftpd[7705] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    Dez 29 21:21:30 debian proftpd[7824] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 21:21:30 debian proftpd[7824] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): USER usrweb02 (Login failed): Limit access denies login
    Dez 29 21:21:30 debian proftpd[7824] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    Dez 29 21:24:03 debian proftpd[7837] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 21:24:03 debian proftpd[7837] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): USER usrweb02 (Login failed): Limit access denies login
    Dez 29 21:24:03 debian proftpd[7837] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    Dez 29 21:26:41 debian proftpd[7861] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 21:26:41 debian proftpd[7861] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): USER usrweb02 (Login failed): Limit access denies login
    Dez 29 21:26:41 debian proftpd[7861] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    Dez 29 21:26:59 debian proftpd[7863] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session opened.
    Dez 29 21:26:59 debian proftpd[7863] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): USER usrweb01 (Login failed): Limit access denies login
    Dez 29 21:26:59 debian proftpd[7863] debian.sto-dgi.eu (Laptop-PavilionDV8.fritz.box[192.168.178.41]): FTP session closed.
    ----


    vielleicht wirt einer daraus schlau...
    Sonst überlege ich mir stark, ein anderes Admin Panel zu verwenden...
    :-(


    Gruß

    hallo fuerni,


    danke für dein ratschlag...


    habe schon versucht per ftp port 21 zu verbinden... Ohne erfolg. da sagt er mir,
    Status: Verbinde mit IP ADRESSE:21...
    Status: Verbindung hergestellt, warte auf Willkommensnachricht...
    Antwort: 220 ProFTPD 1.3.4a Server (debian FTP Server) [IP ADRESSE]
    Befehl: USER usrweb01Antwort: 331 Password required for usrweb01
    Befehl: PASS *********
    Antwort: 530 Login incorrect.
    Fehler: Kritischer Fehler: Herstellen der Verbindung zum Server fehlgeschlagen


    Und habe auch die Debian 7.0 (Wheezy) Service: FTP-Server Daemon: ProFTPd überprüft und nochmals alles neu rein geschrieben. Aber ohne erfolg.


    Naja wie die kunden sich mit dem Server verbinden ist erstmal egal, solange es Sicher ist.
    Ich würde es vorziehen, dass sie sich so verbinden wie es froxlor eingerichtet hat, wenn es Funktioniert...
    Ich hatte auch schon ein anderes admin Panel zu testzwecke benutzt, aber das was ich im Auge hatte, hat das nicht gemacht was es sollte... hm...


    Gruß
    Rogue

    Hallo,


    na da hast du schon recht mit der SFTP, FTP und FTPS, dass ich es noch nicht so gut unter scheinen kann.
    Aber mit dem erstellten user war nur ein Test, und nicht als Huptlösung. Wollte es nur ausprobieren,
    ob die verbindung darüber klappt.


    Aber mir wäre es lieber, wenn die Verbindung über den ftp user den Froxlor erstellt hat.
    Bis jetzt habe ich noch nicht die lösung gefunden.


    danke für deine hilfe..


    Gruß
    Rogue

    Hallo Rayme,


    danke das du geantwortet hast.
    Also ich kann mich weder mit SFTP noch mit FTP mit dem Neuen User den Froxlor oder ich selbst per hand erstellt habe mich einloggen. Den port habe ich noch als Standart 22 (ftp 21) gelassen. Sobalt alles klappt stelle ich es dann auf ein Port meiner Wahl um.


    Ich kann es mir nicht erklären, warum ich keinen user anlegen kann bzw das der sich nicht einloggen kann.


    Habe auch schon in der proftpd.conf einstellungen vorgenommen. Aber bis jetzt hat nix geklappt.

    Code
    1. adduser name


    Gruß
    Rogue


    edit...


    So konnte den fehler eingrenzen.
    Ich kann benutzer anlegen mit adduser name und mich auch einloggen als sftp und ssh.

    Guten Abend,


    habe ein Problem...


    vorgeschichte...


    ich habe ein root server debain 7.7 von netcup. Habe alles neu installiert (Froxlor, proftpd, phpmyadmin, Roundcube) per hand. Und zu meiner zufrieden heit, hat auch sofort alles geklappt und auch die zusatz installation von roundcube hat auch geklappt.


    Nun kommen wir zu mein Problem...


    Ich habe Unter Froxlor einen Kunden, Domain, email Adressen, Datenbank, und auch ftp user erstellt.
    Domain und email Adresse und auch die Datenbank laufen Prima.


    Aber wenn ich mich mit dem ftp user (den Froxlor erstellt hat) auf den ftp server verbinden will, dann stellt er keine Verbindung hat.
    Fehler meldung:


    Status: Verbinde mit [IP Adresse]....
    Antwort: fzSftp started
    Befehl: open "usrweb01@[IP Adresse]." 22
    Befehl: Pass: *********
    Status: Connected to [IP Adresse].
    Fehler: Connection closed by server with exitcode 1
    Fehler: Herstellen der Verbindung zum Server fehlgeschlagen.


    Die verbindung klappt nur mit dem root user...


    Habe alle Konfiguration datein unter Froxlor eingerichtet.
    Froxlor erstellt auch unter Kunden den kundenordner, und auch in der Datenbank erstellt er den ftp user.


    Kann mir vielleicht jemand sagen wo vielleicht der fehler ist...


    gruß
    Rogue

    Hallo,


    danke für eure tipps.


    LiveConfig ist leider Kostenpflichtig, Aber das ist mir nicht all zu wichtig.


    SONDERN
    ---------
    Mit der Subdomain...ist es ein überordner oder unterordner mit pfad angabe...


    gruß
    PS: