Posts by Greiner

    Ich will eine PHP-Anwendung zum Laufen bekommen, für die im sql_mode NO_ZERO_IN_DATE und NO_ZERO_DATE nicht gesetzt sein darf.

    Per default ist das gesetzt, und ich kann es auch von Hand für die aktuelle Verbindung deaktivieren.

    Aber gibt es eine Möglichkeit, das für die PHP-Anwendung zu deaktivieren?


    Guten Abend miteinander,

    ich möchte einmal einen Gedanken/Frage in den Raum werfen.

    Welchen Vorteil haben dedizierte CPU-Kerne eigentlich wirklich?

    Ich könnte mir vorstellen, dass die Nachfrage nach virtuellen Root-Server mit dedizierten CPU-Kernen unter anderem dadurch kommt, dass man bei manchen Anbietern schlechte Erfahrungen mit virtuellen Servern machen konnte, wo einfach zu viele virtuelle Server auf zu schwacher Hardware gehostet wurden/werden.

    Im Grunde ist das doch das eigentliche Problem. Zu viele virtuelle Server auf einem physischen Host => schwache Performance.

    Das mit dedizierten CPU-Kernen zu lösen, gibt zwar die Gewissheit, dass man nicht auf einem völlig überbuchten Host landet. Aber nach meinem Verständnis, wird damit doch eigentlich auch Leistung verschenkt. Denn in Zeiten, in denen der Host wenig belastet ist, habe ich nicht die Möglichkeit, mehr als meine gebuchten dedizierten Kerne zu nutzen, obwohl wahrscheinlich 90% der Kerne ohne was zu tun in der Gegend rumhängen.

    Umgekehrt: Wenn ich auf einem nicht überbuchten Host bin, dann habe ich doch ausreichend Performance, selbst wenn alle anderen virtuellen Hosts maximal aktiv sind.

    In Zahlen ein Beispiel:


    1.) 16 physische Kerne, 2 dedizierte Kerne für meinen Host


    Es können maximal (16 - 1) / 2 = 7 virtuelle Server auf dem System gehostet werden (ich ziehe einen Kern ab für das Hostsystem).

    Meine Maximalperformance ist identisch mit meiner garantierten Performance: 2 * Prozessortakt = (16 - 1) / 7 * Prozessortakt.


    2.) Ebenfalls 16 physische Kerne, aber 4 virtuelle Kerne, maximal (16 - 1) / 2 = 7 virtuelle Server auf dem Host.


    Meine garantierte Performance (wenn alle virtuellen Hosts gleichberechtigt sind) ist dann immer noch (16 - 1) / 7 * Prozessortakt = 2 * Prozessortakt.

    Meine Maximalperformance (es stehen gerade 4 virtuelle Kerne voll zur Verfügung): 4 * Prozessortakt.


    Macht dieser Gedankengang Sinn?

    Letzten Endes denke ich, dass es mehr auf IO-Leistung und das Gesamtpaket ankommt. Aber warum Prozessorleistung ungenutzt brachliegen lassen? Ok, Stromsparen oder konstante Leistung wären Argumente...

    Fröhliche administrative Grüße

    So, der Support hat mir auf Anfrage gemailt, dass mein MX-Eintrag im DNS zwingend auf mail.IHRDOMAINNAME.TLD zeigen muss, und mail.IHRDOMAINNAME.TLD auf 46.38.249.77 (= mxf94d.netcup.net, vermutlich nur in meinem Fall, weil das halt der für mich zuständige E-Mail-Server ist).
    Da ich den DNS-Eintrag mail.IHRDOMAINNAME.TLD gerade noch anderweitig in Verwendung habe, kann ich das im Augenblick noch nicht testen.
    Zumindest unter webmail.IHRDOMAINNAME.TLD wird mir jetzt der Login-Screen der Anwendung angezeigt, die ich im webhostingcontrolpanel in den E-Mail-Einstellungen eingestellt habe. Ich glaube, das war vorher nicht der Fall.

    viel deutet hier darauf hin, dass Sie die DNS-Einstellungen nicht korrekt gesetzt haben. Wenn diese nicht stimmen, kann der Webmailserver nicht den zuständigen Mailserver erreichen. Haben Sie an den DNS-Einstellungen etwas geändert?


    Ja, ich habe einige zusätzliche DNS-Einträge gesetzt.
    Auch wenn ich nicht bewusst etwas verstellt habe, kann es natürlich sein, dass ich versehentlich etwas verstellt habe.
    Welche DNS-Einträge sind denn notwendig?
    Ich habe einen A-Record webmail.aXXXXXs.de 46.38.249.77.


    Entsprechend dieses Forum-Threads hatte ich auch versucht, den A-Record webmail.aXXXXXs.de auf 46.38.249.17 zu setzen und ich hatte versucht, den Eintrag ganz zu löschen.

    erhältst du den HTTP 500 Fehler direkt wenn du Roundcube Webmail :: Welcome to Roundcube Webmail aufrufst, oder erst wenn du versuchst, dich einzuloggen? Ich kann die Seite problemlos aufrufen und das sollte daher auch bei dir klappen.


    Erst wenn ich versuche, mich einzuloggen. Und es dauert relativ lange, dass der Browser versucht, die Seite zu laden (handgezählte ganze 30 Sekunden?) und dann kommt der "500 Internal Server Error".

    Wenn du einen Internal Server Error hast, solltest du einmal die entsprechenden Cookies löschen und schauen, ob du dich dann neu anmelden kannst.


    Es gibt nur einen Cookie: roundcube_sessid. Diesen Cookie zu löschen hilft nicht.


    Ansonsten wäre mir nicht bekannt, dass netcup automatisch webmail.xxx auf deren roundcube aufschaltet. Kann ich mir aber eigentlich nicht vorstellen, da dieses dann eine unverschlüsselte Verbindung wäre. Der A-Record alleine reicht nicht, damit das auch funktioniert.


    Im Wiki ist dokumentiert, dass webmail.IHRDOMAINNAME.TLD funktionieren sollte.


    Du kannst dir aber auch dein eigenes roundcube installieren. Funktioniert analog zu den bekannten CMS.


    Was heißt analog? Kann ich mich da irgendwo einlesen?
    Im Datei-Browser im Webhostingcontrolpanel finde ich gar nicht, wo meine E-Mails liegen.


    Danke für die ersten Hinweise, auch wenn sie konkret mir erstmal nicht weitergeholfen haben.

    Ich komme weder mit webmail.netcupmail.de noch mit webmail.IHRDOMAINNAME.TLD auf meinen Webmailer.


    Im webhostingcontrolpanel war zuerst kein Briefumschlag. Der Briefumschlag ist erschienen, nachdem ich in den E-Mail-Einstellungen einmal durch Horde, AtMail und dann roundcube durchprobiert habe.


    Evtl. könnte das Problem sein, dass ich die DNS-Einträge selbst verwalte.


    Mein Hosting ist auf af949.


    Ich habe einen A-Record webmail.IHRDOMAINNAME.TLD auf 46.38.249.17. Den habe ich gestern versuchsweise einmal rausgenommen. Tut aber auch nicht.


    Roundcube Webmail :: Welcome to Roundcube Webmail sagt nur:



    Leider keine aussagekräftige Fehlermeldung :-)


    Sonst habe ich als Fehler, dass nur eine Plesk-Seite kommt, ohne Webmailer.

    Nach meinem Verständnis steht "Instanz" für die vServer-Instanz.


    - Wenn die Instanz gestartet ist, heißt dass, dass der Server läuft (nicht runtergefahren ist).
    - Wenn das "gestartet" in der Liste der erstellten Snapshots steht, heißt das, dass es sich um einen Online-Snapshot handelt, also der Snapshot gemacht wurde, während der Server lief.


    Nach meinem Verständnis enthält ein Online-Snapshot nicht nur die Festplattendaten, sondern auch den aktuellen RAM-Inhalt.


    Ich bin gerade am Einlesen in das Snapshot-Thema, deshalb schreibe ich mal hier meinen Senf, auch wenn es sich um eine nicht ganz aktuelle Diskussion handelt.