Posts by wieschoo

    dirkd siehe meinen ersten Post. Die rDNS hatte ich bereits geändert und 48h gewartet.

    alhazred configs hatte ich wie beschrieben mittels sendmailconfig neu erstellt.


    Mich wundert es immer noch, dass per "hostname -fqdn" mittlerweile die richtige Domain steht. Was nun die Lösung war, meine Änderungswut in den Configs oder tatsächlich das längere warten weiß ich nicht. Die Configs scheinen zu passen. An der resolve.conf habe ich nicht Hand angelegt.


    E-Mails kommen nun auch mittlerweile bei Google an und landen nicht im Spam Ordner.

    Ich bin mittels


    Code
    1. sudo grep -rnw '/etc/mail' -e 'server.nicesrv.de'


    nur auf


    Code
    1. /etc/mail/local-host-names

    gekommen.


    Den confDomain_NAME hatte ich auch schon probiert. Der ist mittlerweile schon wieder entfernt. Doch auf einmal funktioniert nach einen "sendmailconfig" alles wie gewollt. Ich habe keine Ahnung. Ich habe lediglich die "MASQUERADE_AS" angepasst. Selbst ein "service sendmail restart" behält auf einmal die korrekt HELO.

    Ich versuche sendmail so zu konfigurieren, dass gesendete Emails vom root-server nicht im SPAM ordner von Gmail landen. Folgende Schritte bin ich bereits durchgegangen:


    - Sender Policy Framework (SPF) korrekt konfiguriert


    Code
    1. host -t txt domain.com # schaut gut aus
    2. nslookup -query=any domain.com# schaut gut aus


    - DomainKeys Identified Mail (DKIM) erstellt und konfiguriert (habe mail tester: https://www.mail-tester.com verwendet)


    Beim rDNS Eintrag bin ich ratlos. Im CCP habe ich rDNS umgestellt (vor 48h). mail-test.com gibt mir beim


    Code
    1. IP: xxx.xxx.xxx.xx
    2. HELO: server.nicesrv.de
    3. rDNS: domain.com

    Wie steht dort die Nachricht käme von server.nicesrv.de ? Ein Auszug aus meiner sendmail.mc is


    Wenn ich mir selbst eine Email sende und die nachricht inspiziere, sehe ich


    Der Aufruf zum email senden ist


    Code
    1. echo "My message 2222 body" | mail -s betreff -r example@domain.com receiver@somebody.com


    So langsam fange ich an zuzweifeln. Das Problem ist vermutlich der


    Code
    1. X-Authentication-Warning: server.nicesrv.de: "example" set sender to example@domain.com using -f

    Kennt einer eine Lösung?

    Auch wenn mein Eingangspost wohl etwas harsch formuliert wurde, ist es gut zu wissen, dass es nicht nur mir so geht. Die Verwendung von LiveConfig würde ich sehr begrüßen.


    Abschließend möchte ich bemerken, dass ich mit dem Netcup CCP jedoch höchst zufrienden bin!

    Mit ein paar Minuten Abstand zu dem Negativerlebnis, versuche ich etwas sachlicher die Situation darzulegen.
    Jede beliebige Seite im WCP benötigt 3-5 Sekunden um geladen zu werden. Alleine die Übersichtsseite (Startseite, Dashboard) benötigt gefühlt eine Ewigkeit, bis man diese verwenden kann. Das ist auffallend langersamer als das Laden eienr durchschnittlichen Seite und macht das Arbeiten im WCP nicht angenehm. Ich kenne noch das Confixx-System von vor einigen Jahren. Das war damals gefühlt Lichtjahre schneller und verzichtete auf unwichtige Features, wie Icons hier und da. Diese Icons sind aber offensichtlich nicht das Bottleneck.


    Ich spreche explizit nicht von Seiten, die im Hintergrund Server-Configs schreiben. Ein bisschen Erfahrung habe ich schon. Beim Klick auf den Button zum Ändern des passwortes erwarte ich auch nicht, dass das Ändern von Passwörtern in Echtzeit durchgeführt wird.

    Mir ist es egal, wer es entwickelt hat oder auf welchen Produkt es basiert. Es ist nicht zeitgemäßig, verursacht graue Haare und das laden dauert ewig.
    Im Titel-Tag steht bei mir übrigens "Parallels Panels ..."

    Ich bin wohl vom Terminal (bash) von den Vserver verwöhnt.
    Aber das angebotene WCP als Parallels Panel-Abklatsch ist schlichtweg nicht nutzbar!
    Ich versuchte gerade zum 4. Mal das Passwort für den SSH-Zugang zu ändern: Bad Gateway
    Das Netcup ccp ist wesentlich schlanker, schneller = besser. Ich brauche keine Hochglanz-Icons, wenn die Seite einfach nicht das macht, was die Seite machen soll. Und 5 Sekunden Ladezeit bei einem schnellen Anschluss bekomme ich nicht mal bei einer vollen Datenbank an Werktagen mit meiner ungecachten Rails-Application hin. Beim benutzen vom WCP fühle ich mich ins Zeitalter der Modem zurück versetzt. Bin schon kurz davor die Einwahltöne zu hören. Das ist keine Momentaufnahme. Ich fluche jedes einzelne Mal, wenn ich das WCP benutzen möchte muss. Heute ist das Fass übervoll geworden.


    Hier muss definitiv etwas getan werden. Da sind Sie leider nicht Oberklasse.


    Wenn ich gleich einmal beim meckern bin: Die Vorschaufunktion hier im Forum ist auch kaputt. Manchmal ist weniger mehr!

    Noch für alle, die wie ich Probleme mit dem FTP-Zugang haben. Man kann folgende Regeln ergänzen:

    Code
    1. $IPTABLES -A INPUT -p tcp --dport 21 -j ACCEPT
    2. $IPTABLES -A OUTPUT -p tcp --sport 20 -j ACCEPT

    Wofür benötigst du das mod_proxy, wenn alle Anfragen einfach nur durchgereicht werden. Du leitest ja nicht auf eine andere Domain um.
    Eigentlich sollte in der vHost folgende Zeilene genügen


    Code
    1. RewriteEngine on
    2. RewriteBase /
    3. RewriteRule ^bestimmtes_verzeichnis/datei.php?parameter=(.*)$ sectest.domain.de/test1.html?parameter=$1 [NC,R,L]


    Damit leitest du nur eine Datei um.

    Hast du schon alles mit

    Code
    1. sudo apachectl -S


    getestet?
    Oder manuell einen Test-vHost angelegt?
    Apache2 liest meines Wissen nach auch die "httpd.conf, port.conf, apache2.conf" vor den eigenen vHost ein.
    Ich zum Beispiel kämpfe manchmal mit Froxlor, da es automatisch einen Serveralias anlegt und damit meine eigene vHost "überschreibt".

    Ich komme mit einem normalen FTP-Clienten (TotalCommander) über den passiven und normalen Modus nicht rein.


    Den SSH-Port hatte ich vergessen hier im Beitrag zu maskieren oder zu entfernen. Der steht natürlich bei den offenen Port mit drin im laufenden Betrieb ;-)

    "Ich würde mir ja gerne Deine noch mal ansehen"


    Da ich diese (von raymd) auch verwende ;-)
    Hier ist das (bis auf die Portnummern und das mit w00t) Original von raymd


    Wobei ich mich damit immer noch per FTP aussperre.

    Ich möchte noch anmerken, das

    Code
    1. ProxyRequests Off
    2. ProxyPreserveHost On
    3. ProxyPass / http://127.0.0.1:8080/


    im vhost genügt um gitlab als Subdomain anzulegen, da die Seite sowieso über unicorn läuft. Jetzt nachdem GitLab läuft (dagegen ist eine Redmine-Installation ein Kinderspiel) möchte ich nun verhindern, dass man von außerhalb
    mittels Portangabe in der URL auf der gitlab Seite landet, etwa sollen die folgenden Domains nicht antworten


    "www.meinedomain.com:8080"
    "www.meineanderedomains.com:8080"
    "meine.ip.ad.re.sse:8080"


    Hingegen soll die Domain
    "gitlab.meinedomain.com"
    mit den obigen vhost-Einstellungen schon zugänglich sein. Port per iptable sperren? Per vHost Einstellung aussperren? Ist das möglich? Was wäre besser?

    Hatte dein projekt auch schon gesehen. Super Arbeit. Vielleicht kannst du analog zu "https://code.google.com/p/relay/" noch eine extra Spalte hinzufügen für Bildvorschau etc.

    Ich denke, dass das hier ins Thema passt. Ich bin auch am Neuschreiben vom iptables und bin soeben deinem Link ( RayMD ) zum dem Beispielskript "iptables4" gefolgt.
    Gibt es eine Auflistung aller Ports, die bei

    Code
    1. # TCP & UDP Ports for incoming traffic
    2. INTCPPORTS=""
    3. INUDPPORTS=""
    4. # TCP & UDP Ports for outgoing traffic
    5. OUTTCPPORTS=""
    6. OUTUDPPORTS=""


    eingetragen werden müssen, wenn man das NetCup-Image von Debian Squeeze mit Froxlor verwendet? Ich habe vergeblich versucht mittels Befehl "netstat" die Infos zu erhalten.


    Also bis auf das Deaktivieren von bind9 und dem SSH-Port habe ich beim Neuaufsetzen nichts geändert. Wäre übrigens super, wenn mit dem Angebot der Images auch ein gefülltes iptable-Beispiel angehängt wird. Zumal wenn man das System nicht vollständig alleine aufsetzt, muss man sich das immer mühsam zusammen suchen.


    Anpassungen solcher Skripte kann man das ja immer noch durchführen. Ich habe selbst noch Anpassung, die ich dann einpflegen möchte aber so kleinkariert (wie ich jetzt iptables gerne hätte) habe ich die noch nie eingestellt gehabt.

    Ich kann die Kritik vom Themenersteller nicht nachvollziehen.
    Ich bin relativ neu im Umgang mit Servern, Linux etc. Jedoch stöbere ich öfters im Forum und im Wiki. Und da stolpert man Zwangsweise über das Thema inkl. Begründung und Lösung.
    Wenn ich Kunden hätte, dann würde ich erst Recht hier auf dem Laufenden sein und ein wenig mich im Wiki/Forum einlesen. Darf man das nicht von einer Person erwarten, die ihre Resourcen weiter vermittelt?


    Es ist auch bekannt, dass das Zusammenlegen von Partitionen weit aus weniger problematisch als das nachträgliche aufteilen ist.


    Quote

    Von daher darf man bei solchen Angeboten wirklich nicht voraus setzen, daß der Kunde sowas schon von allein merkt


    Würde ich Kunde bei Ihnen sein, so würde ich erwarten, dass mein Betreiber sich mit den Basic von den Systemen auskenn und Kompetenzen in dem Bereich hat.


    mir unverständlich...