Posts by Nafi

    hast du irgendetwas manuell an den vhost config vom apache geändert?
    schonmal den vserver neu gestartet? Ich denke, da lauscht noch irgend etwas auf port 80.



    Entweder manuell alles anlegen, oder über ein webpanel wie froxlor. Beides verträgt sich nicht so wirklich.

    du musst einfach nur im VCP IPV6 aktivieren und dir dann eine ip aus deinem Adressbereich aussuchen.


    dann in /etc/network/interfaces


    folgendes hinzufügen:


    Code
    1. iface eth0 inet6 static
    2. address xxx:xxx:x:xxxx::1
    3. netmask 64


    xxx natürlich durch deinen Adressbereich ersetzen. Dies wäre dann die erste Ip deines Adressbereichs.


    Danach den vServer durch poweroff + start übers VCP neustarten


    Dann trägst du in Froxlor einfach bei IP's and Ports die Ip ein. Nun noch die Ip Adresse dem Kunden zuweisen, 5 Min warten und es sollte funktionieren.

    der cronjob wird nur ausgeführt, wenn EInstellungen in Froxlor geändert wurden.


    Wenn du Daten in die Froxlor DB extern über ein PHP Skript einfügst( wie in deinem anderen Thread geschrieben) musst du noch folgendes einfügen

    SQL
    1. INSERT INTO `froxlor`.`panel_tasks` (`type`) VALUES ('1');

    in der Mysql Datenbank kannst du dies nachprüfen in der Tabelle panel_settings


    Um dies zu beheben müsste folgendes ausreichen


    User erstellen mit

    Froxlor Wiki wrote:

    addgroup --gid 9999 froxlorlocal
    adduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false --disabled-password --gecos '' froxlorlocal

    Dann per mysql ausführen


    SQL
    1. UPDATE `froxlor`.`panel_settings` SET `value` = '1' WHERE `panel_settings`.`settingid` = 73;
    2. UPDATE `froxlor`.`panel_settings` SET `value` = 'froxlorlocal' WHERE `panel_settings`.`settingid` = 74;
    3. UPDATE `froxlor`.`panel_settings` SET `value` = 'froxlorlocal' WHERE `panel_settings`.`settingid` = 75;



    dann cronjob ausführen


    Code
    1. /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

    aso.


    hast du denn einen froxlorlocal User erstellt und in den Froxlor Einstellungen denn die Option angehakt, dass Froxlor einen eigenen vhost bekommen soll bzw ebenfalls unter eigenem User von fpm aufgeführt werden soll?

    wenn in dem ordner keine Dateien sind, ist entweder der falsche Ordner eingebunden, oder froxlor hat die Dateien noch nicht bzw nicht richtig erstellt.


    im pool Ordner muss für jede Domain eine .conf datei sein.


    Ist der cronjob richtig durchgelaufen?

    Hast du sonst in den Froxlor Einstellungen irgendetwas verändert in richtung fcgid /php-fpm ?



    führe mal folgende Befehle aus:



    chown -R 10000:10000 /var/customers/webs/Kunde
    chown -R root:root /var/customers/logs
    chown -R vmail:vmail /var/customers/mail
    chmod -R 0755 /var/customers/webs/Kunde
    chown root:root /var/customers/
    chown root:root /var/customers/webs
    chown root:root /var/customers/tmp
    chmod 1777 /var/customers/tmp

    ich meine an sich die Dateirechte, nicht den Besitzer. also die Rechte der der html/php Dateien des Kunden.
    Wenn 'andere' Leserechte haben, müsste die Datei auch in Browser angezeigt werden, wenn php von www-data ausgeführt wird.


    Quote

    Kann es sein, dass der User nicht richtig angelegt wird? Mir wird
    nämlich nur die UID "10000" angezeigt, jedoch nicht der entsprechende
    Name "Kunde".

    Das ist an sich ok so. Der ftp User hat keine Rechte den zugehörigen Usernamen auszulesen. Wenn du als root

    Code
    1. ls -la /var/customers/webs/Kunde

    ausführst, müsstest du den Namen sehen können

    Die Domains müssen alle per A Record auf die Ip des vservers zeigen.


    Dann in Froxlor einen oder mehrere Kunden erstellen, und die Domains entsprechend zuweisen. In den Domain Einstellungen kannst du dann auch den Pfrad der Domain einstellen.

    das Zertifikat, welches aktuell genutzt wird, passt nicht zur Domain: