Posts by Nafi

    Hast du mal überprüft ob verschlüsselte Mails nun bei anderen Mail Providern ankommen? einfach mal ne mail schicken und dann original anzeigen lassen und gucken ob da irgendwas mit ssl oder tls steht.


    Schließlich stimmt hostname nun nicht mit domain des zertifikates überein.
    Vielleicht ist das aber auch nur ein fehlgedanke von mir. Habe dies so noch nie getestet.

    ja, das passiert durch die Verwendung von cat mit >>. Du kannst natürlich auch alle Dateien öffnen und per Texteditor in die neue kopieren. Dann hast du direkt die korrekten Zeilenumbrüche. Macht keinen Unterschied.

    hol dir für die mail am besten direkt noch ein startssl zertifikat. Dann halt eben für die email subdomain.


    Wenn dein Server also z.b. den Hostname und RDNS eintrag hat mail.domain.de musst du die mail subdomain bei startssl zertifizieren.


    vom startssl musst du dann runterladen: sub.class1.server.ca.pem, ca.pem, ssl.crt(kann auch anders heißen) und ssl,key(dein private key)
    Speicher diese dateien dann z.b. unter /etc/ssl/mail.domain.de/


    Für Postfix machst du dann:


    Code
    1. cat /etc/ssl/mail.domain.de/ssl.crt /etc/ssl/mail.domain.de/sub.class1.server.ca.pem >> /etc/ssl/mail.domain.de/postfixsmtp.pem


    nun öffne die postfixsmtp.pem mit einem editor und korrigiere die Fehlerhafte Zeile. die zeilen ----Begin certificate---- müssen immer in einer Zeile stehen. Es darf kein ----Begin certificate------------end certificate----------- in einer Zeile stehen


    Postfix main.cf anpassen:




    jetzt sollte smtp zum client funktionieren und die Verbindung zu anderen MTA's sollte verschlüsselt sein. Dies erkennst du am Email Header



    Für courier( der Standard pop/imap Dienst beim netcup image):

    Code
    1. apt-get install courier-imap-ssl


    Code
    1. cat /etc/ssl/mail.domain.de/ssl.key /etc/ssl/mail.domain.de/ssl.crt /etc/ssl/mail.domain.de/sub.class1.server.ca.pem >> /etc/courier/imapd.pem


    Auch hier wieder die Fehlerhaften Zeilen aufteilen wie oben!


    Nun in der /etc/courier/imap-ssl


    überprüfen ob folgender eintrag zufinden ist:

    Code
    1. TLS_CERTFILE=/etc/courier/imapd.pem


    optional, wenn alles funktioniert dieses setzen:

    Code
    1. IMAP_TLS_REQUIRED=1



    Nach dem ändern der Dateien Dienste neustarten nicht vergessen

    Code
    1. /etc/init.d/postfix restart
    2. /etc/init.d/courier-imap restart
    3. /etc/init.d/courier-imap-ssl restart



    Verbindung von Thunderbird per imap dann am besten per mail.domain.de port 143 STARTTLS Passwort normal
    Verbindung von Thunderbird zu SMTP dann am besten per mail.domain.de port 25 STARTTLS Passwort normal




    natürlich musst du den domainnamen anpassen. Achte darauf, dass Dein RDNS Eintrag richtig gesetzt ist, und die main.cf von postfix korrekt konfiguriert ist. Sonst kommen deine Mails am ende zwar Verschlüsselt, aber im spamordner bei Kunden an.

    Code
    1. mydomain = domain.de
    2. # should be different from $mydomain eg. mail.$mydomain
    3. myhostname = mail.domain.de



    Wenn etwas nicht geht, erst in syslog und mail.log schauen und dann wieder melden.

    Quote

    • Wie erstelle ich das Zertifikat korrekt (Ich schätze wie im Wiki eintrag) und wo hat dieses auf meinem Server zu liegen?
    • Wo liegen die Config datein die ich editieren muss für SSL Support bei IMAP und SMTP (ggf auch für POP3)?
    • In Froxlor muss ich entsprechende SSL Domain für https einrichten, gibt es hier noch etwas wieters zu beachten?
    • Ein selbst signiertes Zertifikat ruft warn meldungen hevor bei HTTPS, ist meine Verbindung gennoch geschützt?
    • Ein billiges Zertifikat von Netcup (Ich meien 17€ im Jahr...) würde diese Meldungen benfalls hervorrufen?

    1. Wie du das Zertifikat erstellst, steht im Wiki oder ggf auf anderen Seiten im Internet. Wo die Dateien vom Zertifikat liegen ist total egal. Es muss nur der Webserver leserechte darauf haben
    2. /etc/postfix/main.cf
    3. SSL Ip mit Port 443 erstellen und dann unten die Pfade zum Zertifikat anpassen
    4. Ja, Verbindung ist trotzdem verschlüsselt
    5. ein gekauftes Zertifikat wird in der Regel ohne Warnung akzeptiert. Als kostenlose Alternative gibt es noch startssl.com. Die Zertifikate werden auch von den meisten Browsern akzeptiert





    edit: ahhhh viel zu spät

    du lieferst hier kaum Informationen... wie sollen wir dir da helfen?


    Wie sieht dein /etc/postfix Verzeichnis nun aus?
    Was sagen die Logfiles?


    ggf wäre es einfacher den Server nochmal neu zu installieren. Dann sollte der Mailserver korrekt konfiguriert sein.

    ja, das ist deine Debian Version..
    Dann gehe ich mal davon aus, dass du das debian froxlor image nutzt, welches standardmäßig installiert wird.


    Allerdings frage ich mich, was mit der main.cf passiert ist, denn so sieht diese normalerweise nicht aus.


    guck mal im froxlor Webinterface unter Konfiguration -> Debian wheezy -> Mailserver -> Postfix/Courier
    Dort findest du Konfigurationen, welche du nutzen kannst.

    Was hast du denn überhaupt für ein image installiert?
    Und was hat es mit der Postfix Konfig auf sich? Die sieht für mich relativ unkonfiguriert aus. Da ist ja fast alles auskommentiert.

    hast du irgendetwas manuell an den vhost config vom apache geändert?
    schonmal den vserver neu gestartet? Ich denke, da lauscht noch irgend etwas auf port 80.



    Entweder manuell alles anlegen, oder über ein webpanel wie froxlor. Beides verträgt sich nicht so wirklich.

    du musst einfach nur im VCP IPV6 aktivieren und dir dann eine ip aus deinem Adressbereich aussuchen.


    dann in /etc/network/interfaces


    folgendes hinzufügen:


    Code
    1. iface eth0 inet6 static
    2. address xxx:xxx:x:xxxx::1
    3. netmask 64


    xxx natürlich durch deinen Adressbereich ersetzen. Dies wäre dann die erste Ip deines Adressbereichs.


    Danach den vServer durch poweroff + start übers VCP neustarten


    Dann trägst du in Froxlor einfach bei IP's and Ports die Ip ein. Nun noch die Ip Adresse dem Kunden zuweisen, 5 Min warten und es sollte funktionieren.

    der cronjob wird nur ausgeführt, wenn EInstellungen in Froxlor geändert wurden.


    Wenn du Daten in die Froxlor DB extern über ein PHP Skript einfügst( wie in deinem anderen Thread geschrieben) musst du noch folgendes einfügen

    SQL
    1. INSERT INTO `froxlor`.`panel_tasks` (`type`) VALUES ('1');

    in der Mysql Datenbank kannst du dies nachprüfen in der Tabelle panel_settings


    Um dies zu beheben müsste folgendes ausreichen


    User erstellen mit

    Froxlor Wiki wrote:

    addgroup --gid 9999 froxlorlocal
    adduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false --disabled-password --gecos '' froxlorlocal

    Dann per mysql ausführen


    SQL
    1. UPDATE `froxlor`.`panel_settings` SET `value` = '1' WHERE `panel_settings`.`settingid` = 73;
    2. UPDATE `froxlor`.`panel_settings` SET `value` = 'froxlorlocal' WHERE `panel_settings`.`settingid` = 74;
    3. UPDATE `froxlor`.`panel_settings` SET `value` = 'froxlorlocal' WHERE `panel_settings`.`settingid` = 75;



    dann cronjob ausführen


    Code
    1. /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force