Posts by RHA

    Na gut,


    je mehr ich mich darin einlese, umso mehr möchte ich Abstand davon nehmen. Habe keine Lust nachher eine Spam-Schleuder zu betreiben, und das nur um einem geizigen Bekannten einen Gefallen zu tun. Wenn es keine einfache Möglichkeit gibt ohne viel hin und her, dann muss er sich halt eine Domain registrieren.

    OK,


    wenn ich in den MX-Eintrag den Alias der Domain (also den rDNS) eintrage, dann bekomme ich den Fehler "Relay access denied". Das dürfte ja bedeuten, das schonmal der Server korrekt "angewählt" wird, dieser aber den Zugriff verweigert. Kann man den Zugriff öffnen? Stellt dies ein Sicherheitsrisiko dar? Sorry, habe solch eine Weiterleitung bisher nie gemacht und stehe daher ein wenig auf der Leitung.

    Hi,


    ich habe mal bei .de.vu eine kostenlose Domain registriert und die DNS-Verwaltung aktiviert. Dort habe ich als A-Record und als MX-Record meinen vServer mit IP eingetragen, und auf meinem vServer die Domain mit ispCP erstellt. Nach kurzer Zeit war die Domain dann auch erreichbar (auf meinem vServer), doch EMails kann ich nur senden, aber nicht empfangen. Keine Ahnung wo die landen, aber beim Sender kommt keine Fehlermeldung (nicht erreichbar oder ähnliches), doch auf dem vServer kommt Nichts an.


    Hat schonmal jemand das Gleiche getestet? Empfehlungen?

    Also das Bannen der IP würde (zumindest vorerst) ein wenig helfen. Bei Kabel-Deutschland ist die Wahrscheinlichkeit sehr gross, selbst nach einem Hardwareseitigem Disconnect die gleiche IP wieder zu bekommen. Ich habe z.B. (laut meinem LOG in der FritzBox) seit dem 14.01.2012 immer die gleiche IP, und die Verbindung wurde mehrfach erneuert.


    Ist der Server denn öffentlich?


    Ich betriebe selber (aber für einen kleinen Kreis) einen MC-Server. Wegen der geschilderten Probleme habe ich den von vornherein mit Whitelist betrieben. Wer dazu kommen möchte muss sich halt anmelden, und wird dann freigeschaltet.

    OK, danke für den Link, darüber bin ich HIER gelandet, wo die Funktionen mit Werten aufgelistet sind.


    Demnach müsste die Empfohlene Einstellung den Wert 32757 ergeben.
    Die (auf meinem Server) aktuelle Einstellung entspricht error_reporting = (E_ALL & ~E_DEPRICATED & ~E_STRICT).


    Hmmm, was ist besser? Bzw. was macht Sinn? Evtl. eine ganz andere Einstellung?

    Ich habe ein wenig nach Infos gesucht, und folgendes zusammengetragen :


    disable_functions
    Es sollte möglichst viele (vor allem nicht benötigte) Befehle abgeschaltet (disabled) werden (derzeit show_source, system, shell_exec, passthru, exec, shell, symlink, popen, proc_open, phpinfo)
    Gefundene Empfehlungen : exec, system, passthru, shell_exec, escapeshellcmd, popen, proc_open, proc_nice, ini_restore
    (die fehlenden Empfehlungen nur nachpflegen?)


    register_globals = off
    Ist OFF


    open_basedir
    Auf ROOT-Verzeichnis der Website setzen


    error_reporting = (E_ALL & ~E_NOTICE & ~E_WARNING)
    Steht auf 22527, weiss nicht wie ich das umrechnen kann (werde mal recherchieren)


    display_errors = off
    Ist OFF


    display_startup_errors = off
    Ist OFF


    allow_url_fopen = off
    Ist noch ON


    allow_url_include = off
    Ist OFF


    expose_php = off
    Ist OFF


    enable_dl = off
    Ist OFF


    magic_quotes_gpc = off
    Ist OFF




    Hat jemand weitere Empfehlungen?

    Auch wenn der Beitrag schon ein paar Tage älter ist :


    Hast du denn auch daran gedacht nach Änderung der PHP.ini den Apache neu zu starten?


    Hast du das Problem gelöst?

    Hi Leute,


    ich habe vor einigen Monaten einen vServer Uranus gemietet, und richte diesen ganz sinnig Stück für Stück ein (habe bisher nur in virtuellen Maschinen gearbeitet, mit diesem Server zum ersten Mal "heiss"). Installiert ist bereits Debian 64-Bit, ispCP, ein Minecraft-Server und TS3. Admin darf sich nicht per SSH einloggen, Firewall konfiguriert (nur benötigte Ports offen) und andere Sicherheitseinstellungen sind vorgenommen. Nun würde ich gerne eine Joomla-Seite von einem Webhoster auf meinen vServer ziehen (um die Kosten des Webhosters einzusparen), doch vorher möchte ich eventuell nötige Einstellungen vornehmen.


    Kann mir jemand einen Tipp geben, welchen Einstellungen ich z.B. in der PHP besondere Beachtung schenken sollte? Eventuell noch weitere Tipps?



    Wäre für Hinweise sehr dankbar.