Posts by RHA

    Habe den Server über Nacht ausgeschaltet gelassen, und heute wieder hochgefahren ohne Regeln in der FW (nur beide Standardregeln auf Drop gesetzt), und ich hatte vollen Zugriff auf den Server.


    Das ist wohl ein Fall den Support anzurufen, oder?

    Ich frage da ich Probleme mit meinem Server habe :


    Ich konnte auf Ports auf meinen Server zugreifen, obwohl ich der Meinung war die wären laut FW gesperrt. Habe daraufhin den Server neu gestartet, aber das Problem blieb bestehen. Dann habe ich den Server gestoppt, und ALLE Regeln gelöscht und Standard-Eingangsregel auf Drop gesetzt, danach (nach einer halben Stunde Wartezeit) den Server wieder gestartet, mit dem Ergebnis das ich immer noch auf den Server zugreifen konnte. Ich hatte noch (von vor 1 Jahr) in Erinnerung, das es wohl mal Probleme mit der FW gab, das eine Regel bestehen musste. Also habe ich die Regeln wie im Bild bei runtergefahrenem Server erstellt, den Server wieder gestartet, und .... habe immer noch Zugriff.


    Aus diesem Grund wollte ich mal wissen, ob ich einfach zu blöde bin, oder ob ich wirklich keinen Zugriff mehr haben dürfte.

    Hallo,


    dürfte bei den Einstellungen, wie auf beigefügtem Bild zu sehen, noch irgend Etwas durch die Firewall durchgehen? (die IP in der zweiten Regel ist meine eigene)

    Musste eigentlich Werbung in die App? Wenn der Empfang mal nicht optimal ist, finde ich es schon störend wenn man erstmal warten muss bis die Werbung geladen ist.


    Ansonsten ist es schön mal schnell den Status des Servers abrufen zu können.

    OK, grundsätzlich gebe ich dir Recht. War bisher nur zu faul die Dienste in Betrieb zu nehmen (will dies noch tun).


    Zum Problem : Wieder einmal hat eine Zwangspause (Server für 1 Stunde abgeschaltet) das Problem behoben.

    Ja, was soll ich sagen ..... jetzt habe ich das gleiche Problem wieder X(


    Vorab : Ich habe jetzt den Support kontaktiert.


    Es kann doch nicht sein, das die blöde Firewall immer wieder komplett aufgeht! Gibt es irgendeine Möglichkeit wie der Server (also ich) daran schuld sein kann? Das ist doch eigentlich eine vorgelagerte Firewall innerhalb der Virtualisierung, oder nicht?


    Wir müssen als Admins ja dafür gerade stehen, wenn unsere Server kompromittiert werden. Wie sieht es eigentlich aus wenn dies durch eine nicht ordnungsgemäss funktionierende Firewall erst ermöglicht wurde? Ich halte bewusst Ports geschlossen, da ich zum Teil Dienste nicht weiter konfiguriert habe, und diese in den Grundeinstellungen laufen (z.B. Mail), da ich diese derzeit nicht verwende. Wenn diese Ports aufgehen (was ich zur Zeit nicht unbedingt verhindern kann), dann könnte hier ja eine Angriffsfläche entstehen.


    Über ein paar Gedanken zu dem Thema würde ich mich freuen.



    Gruß
    Ralph

    Sooo, habe den Server gerade (nach 2 Stunden Downtime) wieder gestartet, und siehe da, die Firewall verrichtet scheinbar wieder ihren Dienst. Habe wieder einige Ports als ACCEPT markiert, und die Server sind erreichbar und die Last ist im normalen Bereich.


    Kann das jemand erklären?

    Hallo,


    ich konnte mal wieder beobachten, wie die Last meines Servers Achterbahn fährt (hoch und runter). Nach akribischer Durchforstung der Logs konnte ich nichts besonderes feststellen. Ein Test der Firewall zeigte dann, das diese mal wieder nicht richtig funktioniert.


    Habe den Server mit beigefügten Einstellungen der Eingangsregeln meiner Firewall gestoppt, und erst nach ca. 60 Minuten wieder gestartet. Nach dem Start ist die HP erreichbar und ich kann mich per SSH (Putty) auf den Server einloggen, obwohl die Ports ja eigentlich geschlossen sein sollten.


    Übersehe ich etwas? Oder ist das eine Sache für den Support?


    *** EDIT ***
    Habe den Server erstmal wieder gestoppt.

    Naja, es gibt aber auch genügend Programme mit Funktionen, die man nicht unbedingt nutzt. Wenn ich z.B. einen Game-Server nicht von aussen steuern möchte, dann brauch ich auch nicht den Port dafür freigeben. Wird bspw. auch gerne für Server-Viewer genutzt. Und auch sonst gibt es evtl. Ports hinter denen ein Dienst lauscht, den ich aber (erstmal) nicht nutzen möchte. Bei mir ist z.B. FTP die ganze Zeit zu.

    @RHA-> TS Server kanste da wohl Knicken da es dann direct Server von Netcup wären und dafür dann eine Extra TS-License benötig wäre.

    Man könnte ja den Betrieb ohne Lizenz wählen, der zwar nur mit Umwegen (Unterstützung von Netcup mit einem Mount nötig) genutzt werden kann, aber funktioniert.



    Bei einem CoD4-Server könnte man bspw. mehrere Mods integrieren, die dann per Config aktiviert werden können.

    Die Frage wäre : Wie soll das Ganze denn aussehen?


    Ein reiner Game-Server, mit nur einem Game und sonst nichts? Absicherung des Servers Ja/Nein? Voiceserver mitinstallieren? Fertige Installation, von welcher später ein Image gezogen wird? Welche Games? Gibt es Lizenzrechte zu beachten?



    Nehmen wir mal als Beispiel CoD4 :
    Um einen CoD4-Server aufzusetzen muss die gesamte DVD bzw. eine Installation hochgeladen werden. Diese Daten dürfen meines Wissens eigentlich nicht zur Verfügung gestellt werden (manche Download-Center bieten diese trotzdem als Paket an, damit man die Daten direkt vom Server aus herunterladen kann und somit schneller fertig ist). Ich könnte nun (theoretisch) auf eine Absicherung des Servers verzichten, mit dem Hinweis das in der Firewall nur die Ports für den Game-Server geöffnet werden dürfen (dann kann ich aber auch nicht per SSH Einstellungen vornehmen, also muss eigentlich eine Grundabsicherung erfolgen, z.B. mit DenyHosts). Für Kunden die noch keinen Server besitzen, wäre dann ein Voice-Server natürlich auch noch interessant.



    Wenn die Game-Server für einen schnellen Test bzw. eine schnelle Installation geeignet sein sollen, dann müssten diese bei aktuellen Games ggf. ständig gepflegt werden, da sich die Server-Dateien u.U. noch verändern. Da wäre z.B. gerade TM2-Canyon oder Shootmania anzuführen, die sich noch in der Entwicklung befinden. Wo ich diese beiden Games gerade anführe : Sollte damit ein Server erstellt werden mit oder ohne xAseco bzw. FoxControl?



    Wenn die Rahmenbedingungen gesteckt sind, dann könnte ich mich hinreißen lassen ....

    Und die ts3server.ini wird korrekt als Startparameter übergeben? Ich frage nochmals nach, da dies bereits schon oft irrtümlich geglaubt wurde, aber nicht der Fall war. Hast du mal die LOG-Datei kontrolliert, ob die Einstellung stimmt? Poste sonst mal die LOG-Dateien (die allgemeine LOG und die des virtuellen Servers)

    Wenn du (zu Anfang) eine Eingangsregel definierst, welche alle Verbindungen mit State Established durchlässt, dann sollten wieder alle (oder die meisten) Scripte funktionieren.


    Established bedeutet, das die Verbindung hergestellt (also bekannt) ist (korrigiere mich bitte jemand falls ich es falsch erkläre). Die Scripte "telefonieren" in den meisten Fällen nach draußen auf dem Port, auf welchem auch die Antwort erwartet wird. Die Verbindung wird also von innen (deinen Server) aufgebaut, und ist in dem Moment bekannt, so das die Antwort durchkommt.



    Gruß
    Ralph

    Also ich hatte bisher den Prestashop ins Auge gefasst, aber der ist ganz schön umfangreich. Der hier empfohlene Contao-Shop scheint mir da für einen Anfang besser geeignet. Werde mir den auf alle Fälle mal genauer anschauen.