Posts by schneekettchen

    Inzwischen hab ich das Problem gefunden, falls jemand mal was ähnlich hat.
    Die Einstellungen im DNS waren tatsächlich ok👍, auch nginx war richtig konfiguriert.
    Der Tomcat läuft in einem Dockercontainer und der kann per default kein IPV6, das muss man erst aktivieren, findet man hier
    https://docs.docker.com/config/daemon/ipv6/

    Erschwerend kommt bei mir dazu, dass ich es in einem Swarm laufen lasse, und das scheint aktuell kein IPv6 zu untersstützen.

    Somit hab ich die IPV6 settings nun wieder aus dem DNS entfernt und es läuft am Ende nur noch über IPV4 bis ich dafür eine Lösung gefunden habe.

    Danke für den Support, hat super geholfen.

    Das hat wunderbar geklappt, nach einiger Zeit wurde die Domain culimero.com tatsächlich umgeleitet.

    Wurde!


    Wer hat einen Tipp?
    Ich war übers Wochenende in Österreich und habe in den DNS IPv4 und IPv6 eingetragen, wie in den Screenshots.
    Da hat alles wunderbar funktioniert, konnte die Seite das gesamte Wochenende aufrufen. Gestern abend dann zurück nach D, da ging nix mehr, da kommt dann direkt ein Timeout wenn man auf culimero.com geht. Wenn ich auf https://dnschecker.org/ checke, scheinen alle umgestellt zu sein.

    Die beiden IP's lassen sich auf jeden Fall pingen und auch der Server selbst lässt sich wunderbar under powersrv.de Adresse aufrufen.

    Muss ich auf dem virtuellen Server auch etwas einstellen?
    Die IPV6 auf dem Server im Control Panel zeigt mir eine verkürzte IPv6 2a03:4000:4f:fe7::/64

    Hab dort unter Netzwerk auch noch was gefunden, dort steht als routing "fe80::1", muss dort vielleicht auch die powersrv-adresse rein?

    Wer hat eine Idee?

    Liebe Grüße
    Michael

    pasted-from-clipboard.png



    pasted-from-clipboard.png


    pasted-from-clipboard.png


    pasted-from-clipboard.png

    Guten Morgen,

    Genau der Thread nachdem ich gesucht habe, habe genau das gleiche vor.
    Versuche das gerade auch bei mir einzutragen, scheitere aber am Format der IP6 Adresse.
    Habe folgende aus meinen vServer Settings gefischt 2a03:4000:4f:fe7::/64 aber beim Anlegen des AAAA bekomme ich folgende Fehlermeldung

    Fehler:
    Eintrag ungültig: @ AAAA 0 2a03:4000:4f:fe7:84b1:8fff:fee0:7aa7/64 Keine gültige IPv6-Adresse angegeben.

    Wie muss die genau aussehen?

    Danke & Gruß
    Michael

    Danke für die schnelle Antwort :)

    Klingt alles plausibel! Schon mal gut zu wissen, dass ich mich auf dem Holzweg befinde.

    Für mich ist das Thema Security leider ein Buch mit 7 Siegeln aber bemühe mich da besser zu werden.

    Grundsätzlich ist sowohl auf Frontend als auch Backend SSL aktiviert, sprich die Webseite ist nur über https aufrufbar und auch der backend-call findet über https statt. Beide von LetsEncrypt.



    Der betroffene User verbindet sich über eine VPN der company mit dem Internet, wenn er die Seite aufruft kommt der Cors-Fehler.

    "response to preflight request doesn't pass access control check: "No 'Access-Control-Allow-Origin' header is present on the requested resource"
    Die Verbindung ohne VPN klappt aber wunderbar. Daher war das mein Verdacht, dass da irgendwas in die Richtung wie geschildert passiert.


    Die Seite die ich aufrufe heisst quasi https://workshop.example.com

    Die Response Header die ich zurückbekomme, bei meinem Aufruf der klappt sehen so aus:


    1. Access-Control-Allow-Headers: content-type
    2. Access-Control-Allow-Methods: GET
    3. Access-Control-Allow-Origin: https://workshop.example.com
    4. Access-Control-Max-Age: 1800
    5. Allow: GET, HEAD, POST, PUT, DELETE, TRACE, OPTIONS, PATCH
    6. Cache-Control: no-cache, no-store, max-age=0, must-revalidate
    7. Connection: keep-alive
    8. Content-Length: 0
    9. Date: Wed, 05 May 2021 09:32:47 GMT
    10. Expires: 0
    11. Pragma: no-cache
    12. Server: nginx/1.19.10
    13. Strict-Transport-Security: max-age=31536000 ; includeSubDomains
    14. Vary: Origin
    15. Vary: Access-Control-Request-Method
    16. Vary: Access-Control-Request-Headers
    17. X-Content-Type-Options: nosniff
    18. X-Frame-Options: DENY
    19. X-XSS-Protection: 1; mode=block

    Ich habe eine Frage,


    ich nutze ein Webhostingpaket bei netcup, http://www.example.com, das also Frontend dient, dort läuft eine Angular-Anwendung.

    Zusätzlich hab ich einen VServer v123456.powerserv.de auf dem Spring Boot läuft. Meine Restcalls aus dem Frontend werden an den vServer gepostet und das funktioniert auch so weit.


    Probleme gibt es, wenn der Anwender eine VPN nutzt, dort kommt es zu einem CORS Fehler.

    Wie es aussieht, werden die HTTP-Header durch den VPM Provider entfernt, vermutlich weil die Adresse v12345.powerserv.de nicht akzeptiert wird. (my guess)


    Jetzt ist meine Idee meine Restcalls auf einer SUBDOMAIN auf backend.example.com abzufeuern, das dann ja die gleiche Domain ist und diese dann serverseitig weiterzuleiten, quasi als Proxy,

    aber ich weiss nicht wie das geht? Geht das überhaupt mit einem Webhostingpaket oder brauch ich da für was anderes?

    In den NGINX Einstellungen des Webhostungpakets kann man irgendwie nicht wirklich viel einstellen.


    Oder lässt sich das über einen NodeJS Server lösen?


    Oder ist mein Vorhaben ohnehin totaler NONSENSE? :P

    Danke

    Michael