Posts by michaelvo

    Bei diesem Problem am Besten immer die Dev-Console des Browsers mit offen haben und das mit deaktiviertem Cache testen. Die Browser merken sich insbesondere 404 Antworten, Weiterleitungen usw. gern und setzen nicht auf die neue Konfiguration auf.


    Liegt die Vue App direkt im Document Root? Ansonsten muss das Unterverzeichnis in der RewriteBase angegeben werden.

    Jo, liegt in der root. Ich habe nun ein Test Subdomain aufgesetzt. Mit den besagten Konfigurationen.

    https://test.software-and-testing.de test


    Ich nutze immer einen neuen inkognito-tab, daher mit leerem Cache.


    Hast du noch eine Idee?

    Naja jetzt ist es ein Error 500, zumindest bei /gallery- hingegen bei /gallery/, man beachte den letzten Slash funktioniert es.

    Deutet für mich darauf hin, dass es in der htaccess klemmt.


    Das kann an dem Regex liegen (der Punkt führt zu mehreren Matchens), oder an dem fehlenden NE Flag liegen RewriteRule . /index.html [NE,L] - dafür sind meine mod rewrite Kenntnisse aber nicht ausreichend.

    Hast noch eine Idee wer helfen könnte? Das Problem muss Leuten, mit eine Vue App bei Netcup, aufgefallen sein.

    Ich würde tatsächlich noch etwas warten, bis die Einstellungen vom Webhosting übernommen wurden.

    Bei mir funktioniert es bereits. Ich werde auf /#/gallery weitergeleitet.

    Ich habe wieder den Stand mit diesem Workaround (redirect von gallery auf #/gallery). Die URL muss wirklich https://software-and-testing.com/gallery heißen. Auf einer Docker Apache Instanz funktioniert es tatsächlich ohne Probleme. Ich werde es noch mal deployen und mehr Zeit abwarten. Überschreiben die globalen Setting, die von der Domain?


    Sollte so passen, oder?


    pasted-from-clipboard.png



    Ich bekomme nun den apache 404 Error:


    pasted-from-clipboard.png

    Trotz dieser Einstellungen:

    pasted-from-clipboard.png


    Kommt zu es zu einem nginx-404-fehler.


    pasted-from-clipboard.png


    Unter der URL software-and-testing.com/gallery.


    In der .htaccess ist dies inkludiert:

    Strange.

    Hast du noch eine Idee?


    Gruß


    Michael

    I will give it a try. Thanks.

    Moin,


    ich habe diverse Einstellung auf der CCP Seite versucht, damit ich meine App zum laufen bringe. Mein Setting in der htaccess sind:


    Code
    1. <IfModule mod_rewrite.c>
    2. RewriteEngine On
    3. RewriteBase /
    4. RewriteRule ^index\.html$ - [L]
    5. RewriteCond %{REQUEST_FILENAME} !-f
    6. RewriteCond %{REQUEST_FILENAME} !-d
    7. RewriteRule . /index.html [L]
    8. </IfModule>

    Wie auf der Vue Seite empflohlen, allerdings werden Unterseiten nicht gerendert und enden mit einem 404 Error. Hat jemand eine Idee?