Posts by 5kyy

    Morgen,


    mein Server ist seit ca. 7 Uhr auch ganz extrem zähl. Ich bin schon am rotieren und suchen, kann aber nichts finden, was dies verursacht?

    Denk bei sowas immer gleich an einen Hack...


    Gut wenn auch andere ähnliche Probleme haben, evtl. liegts doch nicht an mir oder meinem Server?

    Hallo,


    ein Joomla von mir möchte ich gezielt aus dem Root in den Administrator leiten lassen, da ich das Frontend nicht benötige.

    Code
    1. Redirect /index.php /administrator/index.php


    Das klappt auch wie gewünscht.


    Nun will ich jedoch von einer bestimmten IP Adresse NICHT in den Administrator geleitet werden sondern im Root bleiben.

    Code
    1. RewriteCond %{REMOTE_ADDR} !^1.2.3.4$
    2. RewriteRule .* https://%{SERVER_NAME}/index.php [R,L]


    Das ist leider noch nicht ganz die Lösung.


    Weiß jemand was ich genau falsch mache?


    LG

    Morgen,


    ich wollte mal fragen, ob und wie ich bei Netcup ein Zertifikat für mehrere Domains anfordern kann.
    Bei einigen Anbietern ist von Multidomain die Rede, bei anderen von SAN-Option Subject Alternative Name)


    Thawte und Geo Trust sollten eigentlich solche Zertifikate im Angebot haben oder?


    LG

    Hallo,


    ich habe heute morgen auch auf den Defragmentieren Knopf gedrückt, da ich kein Backup machen konnte. Gegen 7 Uhr. War ein großer Fehler.
    Es wird nun 11 Uhr und der Server ist immer noch offline.


    Kann man das evtl. unterbrechen und Abends wieder weiter machen???


    LG

    Hey,


    ich beginne langsam an mir selbst zu zweifeln.


    Ich bin nicht mal mehr in der Lage, den Hostnamen meines Servers zu ändern.


    PHP
    1. hostname -f


    zeigte mir zu Beginn den voreingestellten Hostnamen von Netcup.


    In die /etc/hostname habe ich dann

    PHP
    1. myserver


    und in die /etc/hosts

    PHP
    1. MEINEIP myserver.mydomain.tld myserver


    PHP
    1. /etc/init.d/hostname.sh


    Nach einem Neustart passt es "grundsätzlich".

    PHP
    1. hostname -f


    zeigt den korrekten Namen.


    Wenn ich den Server jedoch anpinge. erscheint wieder der vorherige Hostname.


    Wenn ich E-Mails vom System versende, erscheint beim Empfängerserver in der mail.log auch immer:
    "connect from ALTERHOSTNAME"


    Bei einem System schreibt er mir sogar noch:
    "Sender address rejected: Domain not found;"


    Ich kapiers grad überhaupt nicht. Kann mir bitte jemand erzählen, was ich falsch mache?


    Die /etc/resolv.conf wird mir übrigens ständig nach einem Neustart überschrieben...


    LG
    5ky

    Morgen,
    wollte heute nun dies machen, hab zuvor einige male den Server einfach neu gestartet und sämtliche dieser Fehler sind nun weg? Ohne dass ich genannte Zeile auskommentiert habe.
    Werde die Sache beobachten.
    Danke
    LG
    5ky

    Morgen,


    seit einingen Monaten habe ich bei den Shutdown Logs Fehlermeldungen folgender Art:


    Sie erscheint immer wenn ich ein Backup machen möchte.
    Heute war die Liste mal kurz, beim letzten mal war sie deutlich länger.


    Woran könnte sowas denn liegen???


    LG
    5ky

    Morgen,


    ich erhalte seit einigen Monaten jedesmal wenn ich im VCP den Server Neu starte folgende Meldung:


    Auf meinem Server läuft momentan EasySCP. Weiterhin habe ich wie in der letzten Zeile ersichtlich zusätzlich ein älteres PHP installiert.


    Außerdem hatte ich die Meldung, dass im letzten Monat mindestens 1x der RAM ausgeschöpft war.


    Ich kontrolliere eigentlich monatlich meine Server und aktualisier sie. Der genannte hat eigentlich jedesmal vor dem Backup 4GB von 4GB Ramauslastung. Heute war sie erstaunlicherweise gerade mal bei 1,73GB.


    Habt ihr eine Idee woran das liegen könnte?


    PS. Gerade fällt mir in der Shutdown Liste folgende Zeile auf:

    Code
    1. Using makefile-style concurrent boot in runlevel 6.


    Sollte ich mir Sorgen machen?

    Morgen,
    ich habe gestern von Lenny auf Squeezy aktualisiert und musste soeben feststellen, dass manche meiner Seiten nicht mehr so funktionieren wie zuvor. Als CP hab ich IspCP 1.0.7.
    Manche Seiten haben gar keine Navigation mehr (Joomla 1.5), andere keinen Inhalt (Joomla 1.0).
    Bei einem Shop erhalte ich:

    Code
    1. Deprecated: Function eregi() is deprecated in


    Fehler. Das Error-Reporting wollte ich hier schon runterschrauben ohne Erfolg.


    Die Fehler haben höchstwahrscheinlich was mit den veralteten Seiten bzw. den neuen PHP bzw. MySQL zu tun oder?
    Sind euch solche Sachen bekannt bzw. wie kann ich schnell Abhilfe schaffen? Ein aktualisieren der Seiten kam von den Kunden nicht in Frage, folglich will ich natürlich auch nicht zuviel Zeit investieren. Schließlich sind Joomla Migrationen keine Sache von 1 - 2 h.


    LG
    5ky

    Morgen,
    wie funktioniert eigentlich genau das Rettungssystem? Ist das System sinnvoll, wenn ich meine regelmäßigen Wartungsarbeiten mach?
    Kann ich per SSH im Rettungsmodus meinen Server genauso handeln wie im normalen Modus? Dienste aktualisieren? Per Browser bzw. Mail Client deren Funktion prüfen? Oder ist für die Öffentlichkeit der Server im Rettungsmodus gar nicht erreichbar?
    Ich erstelle im OpenVCP jedes Monat ein vollständiges Backup. Ich hab ja 3 zur Verfügung. Dies dauert jedesmal min. 1h. Hat das Sinn und sollte ich das so weiterhin machen oder ist das Übertrieben?
    Nachdem ich jedes Monat mein Backup gemacht hab, starte ich den Server wieder ganz normal, geh per SSH drauf und aktualisier meine Dienst und kontrolliere Logfiles. Nach dem höchstens nochmal ein Neustart und das wars eigentlich. Wenn ich nun feststell, dass etwas nicht funktioniert, hätte ich quasi ein Backup. Allerdings wenn in der Zwischenzeit Mails auf irgendwelchen Konten eingetroffen sind und ich stell es wieder her, sind diese natürlich verloren?
    Wie macht Ihr das?
    LG
    5ky

    Hey,
    gibt es eigentlich eine Möglichkeit, einen kompletten Server zu klonen? z.B. über deine SSH Verbindung? Könnte ich mir so z.b. meinen realen Netcup Server 1:1 in eine VirtualBox Maschine legen und hier z.B. Updates etc ausprobieren, bevor ichs am richtigen System mach?
    Wie währ die Vorgehensweise bzw. der Befehl?
    LG
    5ky

    Hey und danke für den Hinweis.


    Benötige ich denn überhaupt die Änderungen? Sämtliche meiner Domains laufen über Nameserver meines Registrars?
    Oder betrifft das u.a. meine Host Domain vXXXXXXX.yourvserver.net?


    Was müsste ich überall ändern, wenn ich hier eine Subdomain eines Accounts haben möchte?


    LG
    5ky

    Hey,


    danke für eure Antworten.
    Mein SVN benutze ich ebenfalls über https.


    Wie sieht es eigentlich mit den Ausgehenden Regeln aus. Da hab ich jetzt noch gar nichts gemacht. Kann ich hier alle mal auf Blockieren stellen? Oder eben auch die vom Eingang freigeben?


    Du schreibst, dass ich wegen Postfix und Apache aufpassen muss, da diese auf z.B. MySQL über localhost zugreifen. Scheint ohne Änderungen zu klappen alles. Meine CMS-basierten Webseiten laufen alle und mein PhpMyAdmin läuft auch. Somit sollte alles passen oder wie bemerk ich sonst, dass über Postgrey oder Amavis kein Zugriff stattfindet?


    LG
    5ky

    Guten Morgen,


    ich hätte 2 Fragen bezüglich meines vServers.


    Heute habe ich mich mit der Netcup Firewall beschäftigt. Die eingehenden Pakete habe ich alle auf verweigern gestellt und meine wichtigsten Ports freigegeben.
    SSH, HTTP, HTTPS, POP3, POP3S, IMAP, IMAPS, SMTP, SMTPS, FTP, SVN und den Ping. Ähnlich wie in dem Beispiel im Netcup Wiki.


    In meinem IspCP hab ich aber in der Port-Liste noch weitere z.B. Amavis, MySQL, DNS, Postgrey und und und
    Was soll ich denn mit diesen Ports machen?


    Wie sollte ich meine ausgehenden Pakete am besten konfigurieren? Ebenfalls standard auf verweigern und entsprechend freigeben, welche es benötigen? Da stellt sich dann auch die Frage, welche Dienste ich überhaupt dort eintragen soll? Die gleichen wie bei den eingehenden Paketen?


    Ich habe abgesehen Subversions nichts sonderliches auf dem Server laufen. Lediglich IspCP mit ein paar Webseiten und E-Mail.


    Zum Anderen habe ich mir seit ich den Server habe einmal im Monat ein bis zwei Stunden Wartung vorgenommen und zieh das auch brav durch. Da aktualisiere ich dann die Dienste und versuche mich in den Log-Files durchzusehen, ob irgendetwas merkwürdig ist.
    Wie sollte ich da am geschicktesten Vorgehen. Je länger die Log-Files werden, umso schwerer wird es für mich, zumal mir viele Zeilen davon nicht allzuviel sagen und ich nur selten Angriffe von einfachen fehlgeschlagenen Logins eines Users unterscheiden kann. Einzig in der Auth-Log find ich mich halbwegs zurecht. In den E-Mail Logs stehen z.B. zig Zeilen, dass für POP3 das Maximum Connection Limit erreicht wurde?
    Sollte ich einfach sämtliche Logfiles im Log Ordner herunterladen, den Ordner auf dem Server dann löschen, sodass er die Files wieder dann von vorne beginnt und alles wieder sauber ist? Wie werte ich die Logfiles am besten aus? Gibts da Tools dafür, wo ich die Dateien einlesen kann?


    Ich arbeite komplett unter Kubuntu Linux.


    Eine weitere Frage stellt sich, was wäre wenn der Server dann doch mal ernsthaft kompromittiert ist und ich den Server neu aufsetzten muss? Ich erweitere jedes Monat mein Backup des Servers über OpenVCP. Zusätzlich sicher ich meine Homepage Daten und Datenbank.
    Aber sollte ich da überhaupt ein älteres Server-Backup zurückspielen? Sollte ich überhaupt ältere Homepage-Daten zurückspielen? Auch diese könnten doch theoretisch befallen sein? Und vor allem wie bekomm ich meine ganzen IspCP Einstellungen wieder oder müsste ich jeden Kunden, jeden Reseller neu anlegen? Da wär ich ja zig Stunden beschäftigt?
    Wie macht ihr das?
    Ich komm mir trotz allem, was ich mir die letzten Jahre angeeignet habe und bis heute auch sauber läuft wie es soll, etwas hilflos vor. Ein solches Szenario sollte ich einfach mal in einer Virtuellen Umgebung am heimischen PC durchspielen das weiß ich aber bis heute nahm ich mir LEIDER noch nicht die Zeit dazu.


    Ich freu mich über eure Ratschläge.


    Lg
    5ky


    PS. In der Regelliste währ noch ein Bezeichnungs- bzw. Kommentarfeld super, damit man der Regel gleich eine Bezeichnung geben kann. Port 80 ist ja eigentlich jedem Bekannt aber z.b. 3690?

    Hey,
    leider muss ich meinen Hostnamen meines Servers ändern, da ich die Domain abgeben will.
    Sobald ich einen neuen Namen parat habe, würde ich gerne wieder ein:
    admin.neuedomain.de als Hostnamen für meinen Server verwenden, sowie ich es jetzt auch schon mache.
    Wie würdet Ihr mir Raten vor zu gehen? Was muss ich beachten? Was ist alles umzustellen? In welchen Configs?
    Ich habe meinen Server aktuell lediglich als normalen Webserver laufen, auf welchem ein paar Webseiten liegen, E-Mails etc. Zum Verwalten der Kunden habe ich IspCP.
    MfG
    5ky