Posts by not-a-robot

    nicht wirklich; wie in meinem Beispiel ja gezeigt, hast Du im E-mail-From die Office-Adresse, und dessen SMTP-Passwort im ganzen Unternehmen weiterzugeben

    ist weder praktikabel und oft auch nicht gewollt;

    darum sagte ich ja, wenn dieses Feature möglich sein soll, muss man auch mit Absenderadressen absenden dürfen, welche nicht de, SMTP-User zugeordnet sind;

    und ein Denkfehler Deinerseits bei 1) Postfachadressen können keine Alias-E-mailadressen bei anderen Postfächern sein;


    Ehrlich gesagt sehe ich nicht das Problem.

    Für das Bespiel würde man im WCP folgendes Eintragen:


    für den Account mitarbeiter1@company.tld die send-on-behalf Adresse office@company.tld und vielleicht noch weitere Alias Adressen

    für den Account mitarbeiter2@company.tld die send-on-behalf Adresse office@company.tld, und vielleicht noch vertrieb@company.tld


    Wenn nun mitarbeiter2 eine Mail verschickt, wird erst 1) geprüft ob eine Alias Adresse matched, dann 2) ob eine send-on-behalf Adresse matched, und wenn weder 1) noch 2) ok ist, dann darf die Mail nicht rausgehen.


    Dh. es gibt hier keinen Überlapp von Alias Adressen zwischen Accounts. Logischer Weise gibt es einen Überlapp bei den send-on-behalf Adressen (was ja auch sonst kein Sinn ergeben würde).


    Aktuell, so wie es bei Netcup konfiguriert ist, kann der Mitarbeiter praktikant@company.tld einfach mit seinem SMTP Postfach eine Mail verschicken im Namen von vertrieb@company.tld, und von extern kann man das nicht feststellen (außer es gibt zusätzliche client-basierte Sicherheiten wie PGP/MIME, ...).


    Das Feature "Send on Behalf" kann man auch bei meinem Vorschlag einfach unterstützen.

    Man braucht für den SMTP Server lediglich eine Überprüfung bei ausgehenden Mails, ob 1) einer der Alias-Adressen des Accounts zum Absender passt, oder 2) einer der eingetragenen "Send on Behalf Adressen" übereinstimmt. Dh im WCP würde man Alias-Adressen sowie "Send on Behalf Adressen" für einen Account eintragen können.


    Je nachdem welche SMTP Software eingesetzt wird gibt es dazu i.d.R. auch die entsprechende Möglichkeit zur Konfiguration mittels SASL/APD usw.

    Vielen Dank für die ausführliche Antwort.

    Leider finde ich diese Einstellung jedoch trotzdem fragwürdig und falsch.


    Da jeder SMTP Server ja nicht nur für einen Kunden zuständig ist, und ein Kunde i.d.R. mehr als einen SMTP Account hat, kommt es zwangsweise dazu dass verschiedene SMTP Accounts sich den Server teilen. Da (fast) keine Überprüfung stattfindet, kann also jeder mit einem Account Mails im Namen aller anderen senden. Das kann ja nicht gewollt sein!

    Entgegen der Darstellung in 1) kann der Empfänger das auch nicht mittels der Techniken wie SPF, DKIM und DMARC prüfen - im Gegenteil sogar - schlimmer noch, der Empfänger muss glauben dass es eine echte Mail ist, da sie ja sogar vom richtigen Server kommt...


    Als Beispiel: Wenn ein Kunde domain.org und domain2.org besitzt und diese vom gleichen Server bedient werden (was ja bei einem Produkt immer der Fall ist), kann ein SMTP Account für domain.org auch Mails im Namen von domain2.org absenden (mit beliebigen Absenderadressen).

    Ich möchte gar nicht wissen ob das auch über die Grenzen über mehrere CCP Accounts machbar ist wenn die sich den Server teilen...


    Davon abgesehen, was hält Netcup davon ab die Konfiguration "richtig" zu machen, und per SMTP nur die Absender zuzulassen, die auch entsprechend für diesen SMTP Account eingetragen sind? Solch eine Konfiguration würde ja nur zusätzlich Gewissheit bieten, und für weniger Verdruss der Kunden sorgen.

    Ping - nochmal der Versuch eine Antwort zu bekommen - werde sonst heute Abend ein Supportticket erstellen.

    Hallo zusammen,


    bei meinem Webhosting Paket (8k) wundere ich mich, wie die Unterstützung von Python gemeint ist.


    • per SSH kann kein Python verwenden
    • im WCP kann ich zu Python nur sehr wenig einstellen - sieht mir nach einer alten Django Konfiguration aus falls ich mich nicht irre. Die Pfade sind auf jeden Fall nicht zu ändern.
    • im Verlinkten Wiki konnte ich auch fast keine Info dazu finden (Wiki Suche nach Python) ... ich finde 3 Einträge in der Wiki, aber nichts was mir hier weiterhilft.

    Ich dachte eigentlich an Python Unterstützung für z.B. Flask .. dieses per uWSGI / Twisted / (Fast)CGI / .. laufen zu lassen.

    Würde mich über ein paar Antworten dazu freuen - auch weil ich nur noch wenige Tage meinen Vertrag stornieren kann.


    • Python 3.6 oder neuer?
    • welche Deployment Möglichkeiten? CGI, FastCGI, uWSGI, Twisted, mod_wsgi, ...
    • pip?



    pasted-from-clipboard.png

    War die Standarddomain schon aktiv, bevor du den cronjob erstellt hast, oder hast du sie danach aktiviert?

    Da bin ich mir nicht mehr sicher.. aber habe es sicherheitshalber nochmal getestet und siehe da... es funktioniert nun mit neu erstellten Cron-jobs.

    Nur um ganz sicher zu gehen: es steht auch "<?php" in der aller ersten Zeile des test-script an aller erster Stelle?

    Ja :)


    Danke für die Tips!


    netcup .. kann man im WCP nicht einfach ein paar Überprüfungen einbauen, dass falls die Standarddomain deaktiviert ist, bei den Cron jobs eine Warnung erscheint?

    Mein Test-Skript sieht wie folgt aus - per Mail taucht nichts auf, in die bla.txt schreibt er bei der Test-Ausführung erfolgreich rein und zeigt mir auch den Fehler in der Ausgabe. Automatisiert passiert nichts.

    Code
    1. $f = realpath(dirname(__FILE__)) . '/bla.txt';
    2. echo $f;
    3. $fp = fopen($f, 'a');
    4. fwrite($fp, date("h:i:sa"));
    5. fwrite($fp, $f);
    6. fclose($fp);
    7. ini_set('display_errors', 1); throw new Exception();


    err1.jpgerr2.jpg

    Schönen Abend zusammen,


    mit meinem neuen Webhosting Paket (Oster8k) habe ich leider das nächste Problem :( wie bekommt man den Cron Job zum Laufen?

    Folgendes Problem tritt bei mir auf: Ich kann geplante Aufgaben anlegen und diese auch Testweise ausführen, allerdings funktioniert die automatische Ausführung nicht. Getestet habe ich PHP Ausführung, sowie Script. Bei Fehler/Ausgabe Benachrichtigung per Mail aktiv, aber nichts passiert.

    Zeiteinstellung schon mit Cron Syntax probiert sowie die "Stündliche Ausführung zu Minute x".


    Bisher habe ich die Ausführung von einem sehr einfachen Php Script getestet, welches einfach die aktuelle Zeit in eine Datei schreibt.


    Ich habe auch die Standarddomain aktiv (auch wenn ich sie nicht nutze), nachdem ich hier im Forum gelesen habe dass geplante Aufgaben sonst überhaupt nicht laufen.


    Ich bin für jeden Hinweis dankbar :)

    Hallo zusammen,


    ist für die Webhosting 8000 (oder andere Pakete) ein Update der verfügbaren Python Version geplant?

    Laut WCP steht Python auf 3.5.3, welches Jan. 17, 2017 released wurde. Davon abgesehen dass der Support im September für 3.5 ausläuft, gibt es mittlerweile auch 3.5.9.


    Bitte nicht falsch verstehen, ich frage nicht nach 3.5.9, sondern eher nach neueren Versionen. Allerdings würde ich auch gerne wissen, wie NetCup zu Patches auf den Webhosting Paketen steht. Ehrlich gesagt macht es mir etwas Sorgen zu sehen wie veraltet die verfügbare Software (zum Teil ist) - zumal dies ja nur der "sichtbare Bereich" der Server ist.


    Danke und viele Grüße

    Hallo Zusammen,


    kann man bei einem Webhosting Paket (8000) die Pfade anpassen, die PHP Skripte als CWD bekommen wenn man sie per CLI bzw per Webserver abruft?

    Wenn man folgenden PHP Code auf per CLI ausführt, bekommt man sowas in der Art: /my-path/subdir Die gleiche Datei im Webbrowser gibt: /var/www/vhosts/hostingxyxyxyxyyx.netcup.net/my-path/subdir


    PHP
    1. <?php
    2. echo getcwd();


    Wieso stört das? Viele Anwendungen (z.B. Nextcloud) bekommen durch dieses Pfadverhalten Probleme.

    Deshalb die Frage - kann man die ENV Pfade für CLI Zugriffe ändern?

    Bei mir hat sich etwas getan.. gestern ging noch nichts bezüglich LE SSL, seit heute (von mir um ca 11 Uhr bemerkt) klappt es - wie aus dem nichts.

    Vom Support kam vor 10 Minuten erst eine "knappe" Mail, kurz mit dem Inhalt "... Das kann ich nicht (mehr) nachvollziehen. ...".

    Laut der Access logs waren auf jeden Fall noch weitere Kisten zwischen gestern Abend und heute 11 Uhr auf der Domain unterwegs..


    Also nach der kurzen Erfahrung kann ich sagen, dass ich etwas enttäuscht bin was den Support angeht:

    1. ich finde es schade, dass man im CCP seine aktiven Support Anfragen nicht einsehen kann

    2. der Support mir keinerlei Aufschluss gibt, a) was die Ursache gewesen sein könnte, b) noch wieso ich die genannten Warnings in der Log bitte "ignorieren solle".


    Die Tatsache dass hier mehrere das Problem hatten (haben?), scheint ja dafür zu sprechen, dass es ein Problem gab.

    Morgen,


    damit scheinst du nicht alleine zu sein (-> Das längste Thema). Probier mal direkt unter dem Menüpunkt "Let's Encrypt" die Option "Für die Domain und jeden ausgewählten Alias die "www"-Subdomain einschließen" zu aktivieren. Ansonsten würde ich mich an den Support wenden.


    P.S. Du könntest noch zusätzlich die Option "Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS " in den Hosting Einstellungen aktivieren.

    In der Tat klingt das nach dem gleichen Problem. Leider habe ich schon verschiedene Optionen durchprobiert.. immer mit 5 Minuten warten (also noch ein Kaffee 8|).


    Dh. ich muss warten bis der Support den Webserver neu startet oder findet sich irgendwo CCP/WCP eine Option der Kiste einen reset zu verpassen?