Posts by bebbo

    vmk;34639 wrote:

    Aus Erfahrung: Funktioniert, aber nur bei gleicher/ähnlicher mySQL-Version sowie einige kritische Konfigurationsparameter müssen genauso wie bei der Backupversion sein.


    Auf meinen Servern funktioniert das "dumme" kopieren seit mysql 3.irgendwas bis 5.5. Allerdings stets mit MyISAM und 32 bit.


    Wenn es nicht funktioniert: mit mysqldump exportieren und das wieder importieren.


    Viel Spaß


    Bebbo

    niklasR;34097 wrote:

    Hallo,
    Gibt es eine Möglichkeit, iftop, oder etwas vergleichbares, auf den vServern auszuführen?


    Nachdem munin etwas Vergleichbares (auch für den netcup vServer) anzeigt siehe Attachment geht es im Prinzip.


    Bebbo

    steht dahinter LISTEN, wie in

    Code
    1. tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN

    dann ist das bedenklich


    oder nicht, wie in

    Code
    1. tcp 1 0 127.0.0.1:34101 1.2.3.4:42 CLOSE_WAIT

    dann ist es ok, denn es ist nur eine Client-Verbindung.


    Bebbo

    christian;30021 wrote:


    Das eigentliche Sicherheitsproblem ist aber das eine Grafische Oberfläche mehr oder weniger viele Dienste vorraussetzt und anbietet.


    IMHO sind die Dienste alle voneinander getrennt. Sicher wird oft vieles dazukonfiguriert, aber man muss das nicht so machen.


    Dies sollte genügen um X ans laufen zu bekommen:

    Code
    1. yum install xterm xorg-x11-xauth libgnome liberation-fonts


    Und eine erste X Anwendung wäre dann yumex. (Oder synaptic).

    Code
    1. yum install yumex


    Das nutze ich schon ewig.


    Bebbo

    Und den guten alten XServer nicht vergessen.


    1. Unter Windows z.B. den cygwin oder XMing XServer starten, in Linux läuft der meist schon.
    2. Mit putty verbinden und dabei unter Connection->SSH->X11 "enable forwarding" auswähen
    3. Auf dem Server xterm, yumex etc starten und das Fenster öffnet sich im lokalen XServer.


    Bebbo

    Da das Host System 64 Bit ist, solltest Du UNBEDINGT ebenfalls ein 64 Bit System verwenden!


    Bei OpenVCP gibt es sonst immer wieder Probleme, da z.B. uname auf einem 32 Bit System folgendes meldet:


    Code
    1. [bebbo@server ~]$ uname -a
    2. Linux server 2.6.35.8-vs2.3.0.36.33-netcup #1 SMP Fri Nov 5 12:09:34 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
    3. [bebbo@server ~]$

    Korrekt wäre:

    Code
    1. [bebbo@server ~]$ uname -a
    2. Linux server 2.6.32.26-175.fc12.i686.PAE #1 SMP Wed Dec 1 21:45:50 UTC 2010 i686 i686 i386 GNU/Linux
    3. [bebbo@server ~]$

    Dass x86_64 statt i686 gemeldet wird, macht immer wieder Ärger.


    Bebbo

    Pionier;29721 wrote:


    Wie kann das sein, denn die Firewall sollte doch alle Verbindungen von dieser IP verhindern :confused:


    Du meinst alle Verbindungen an die im Filter genannte IP Adresse.


    Du hast vermutlich alle Verbindungen für die IPv4 Adresse gesperrt, und nicht auch für die IPv6 Adresse!?


    Oder ist in dem geschwärzten Bereich auch die IPv6 Adresse?


    Was steht denn im Log, wenn jemand per IPv6 darauf zugreift?


    Greifen die Firewall-Regeln, wenn IPv6 verwendet wird?


    Bebbo


    Kleiner Tipp (leider zu spät...):


    Für das Herumspielen am sshd startet man am Besten eine separate Instanz auf einem anderen Port, Firewall freischalten nicht vergessen.


    Wenn dort alles so geht, wie gewünscht, kann man die Configuration übernehmen.


    Bebbo

    Du solltest in das Skript

    Code
    1. apachectl graceful


    einbauen, dann läuft das zeitnaher.


    ... oder nimm einen Server, der das von Haus aus (also ohne cron-job) beherrscht.


    Bebbo

    ... ich verzichte auf mysqldump und verwende im Prinzip
    (Mein Backup Skript ist insgesamt noch etwas aufwändiger, aber es sichert alle angegebenen Verzeichnisse in einem Rutsch.):


    Code
    1. service mysql stop
    2. backupdb.sh
    3. service mysql start

    Mein Erfahrung mit den myisam Dateien von mysql:


    Die Daten-Dateien haben bisher jeden mysql Wechsel von 3.0 bis 5.5 mitgemacht!


    Falls das mal nicht klappen sollte, kann ich immer noch mysqldump verwenden.


    Bebbo

    zu 3.
    Es hängt vom Mail-Client ab, ob er das meldet. Thunderbird und Outlook melden das durchaus.


    zu 4.
    IMHO geht das nicht. Evtl. gibt es Wege über Export/Import...


    zu 5.
    Wenn es Dein Addressbuch ist, wohl nicht. Ein Firmen Addressbuch ist evtl. per LDAP zu erreichen


    zu 6.
    Geht prima. Auch auf Handy.
    Durch das Nutzen verschiedener Geräte, kommt der Vorteil von IMAP erst richtig zur Geltung: Mail als gelesen markiert -> der Status wird von jedem Client übernommen, usw.



    Wenn das System Exchange basiert ist, würde ich allerdings bei Outlook bleiben. Macht weniger arbeit.


    Bebbo

    Auch ich habe schon bemerkt, dass der vServer immer wieder mal lagt. Ich hatte aber weder Lust noch Zeit, da Ursachenforschung zu betreiben, und fand mich bisher damit ab: "mehr kann man von einem billigen vServer nicht erwarten".


    Nun habe ich hier etwas mitgelesen und gebe nun auch meinen Kommentar:


    - von den Messungen her, tritt der Effekt in bestimmten Intervallen auf.
    - logrotate wird es nicht sein: Eine Datei umzubennen macht keine Load.


    Meine Vermutung:


    Eines (oder alle?) dieser schönen Überwachungstools, die auf einem (mehreren/allen?) vServer läuft, fragt regelmäßig etwas ab, was dann den Lag verursacht.


    Der Hauptkandidat ist dabei etwas in /proc.


    Lustig und traurig zugleich wäre es, wenn das Problem z.B. durch


    Code
    1. [B]cat /proc/loadavg[/B]


    verursacht würde...


    ... ist nur mal laut gedacht.


    Bebbo

    Scaleo;24687 wrote:

    Ich möchte meinen Netcup Server mittels Hacmachi oder OpenVPN in ein Netzwerk integrieren. Mein erster Gedankenschritt war, gut ich brauch das TUN/TAP Device. Das wäre nicht das Problem. Der nächste Schritt war ins Forum zu gucken. Hier finde ich nun Informationen das openVPN nicht wirklich funktioniert.


    Das was ich gelesen habe, fasse ich mal zusammen:


    Man kann OpenVPN durchaus ans Laufen bekommen, allerdings nur um den Server selbst über VPN einzubinden.


    Ein Zugriff aufs Internet über VPN und den Server ist nicht möglich.


    Deswegen betreibe ich stattdessen einen Proxy der über https erreichbar ist, was für meine Zwecke ausreicht.


    Bebbo

    1. - 3. sieht ok aus.



    Default läuft Tomcat auf port 8080. Das muss in der Firewall offen sein.


    Beim Aufruf von www.MeineDomain.de:8080 muss dann was kommen, sonst stimmt was mit der Grundinstallation nicht.


    Die Dateien (auch JSPs) sind alle im webapps Verzeichnis zu finden/anzulegen. Eines der Verzeichnisse ist für den root Context (also nur den Server Namen). Zum Spielen legst Du Dir dort ein Verzeichnis (= Context) an und da kannst Du deine testjsp Seite erstellen.


    Code
    1. mkdir webapps/test
    2. vi webapps/test/test.jsp


    mit www.MeineDomain.de:8080/test/test.jsp kannst Du die Seite dann aufrufen.


    Mehr findest Du in der tomcat doku.


    Viel Erfolg



    Bebbo


    http://bejy.net