Posts by Mauric3TV

    Ja wie gesagt, mit einem User Agent hab ich es schon probiert. Das macht keinen Unterschiedd. Habe auch schon versucht einen Referer anzugeben, was auch kein Unterschied gemacht hat.


    Ich denke Cloudflare macht es mir schwer, allerdings weiß ich, dass es machbar ist.

    Danke für den Link von stackoverflow! Hab es so probiert und tatsächlich kam der Statuscode "403" als Antwort raus. Das gleiche hatte ich mit der file_get_contents() Funktion. Jetzt muss ich wohl rausbekommen, wie ich diesen umgehen kann.


    Bei der file_get_contents() Funktion konnte ich es bei einer anderen Website mit einem User-Agent Header umgehen. Ich weiß, dass es bei meiner Zielwebsite geht, allerdings wird das wohl ziemlich knifflig :)


    Aber ich weiß zumindest wo das Problem ist :) Danke dir <3

    Verstehe was du meinst, aber du solltest deine Informationen wenigstens überprüfen. :)


    Habe am Freitag 16.04 um 19:53, also knapp 4 Stunden vor deinem Post im von dir verlinkten Forum geschrieben:

    "Ok kann tatsächlich geschlossen werden. Wurde mit preg_replace gelöst. War wirklich dumm xD".


    Somit habe ich darauf hingewiesen, dass ich A) keine Hilfe benötige und B) habe ich auch geschrieben wie es gelöst wurde.


    So viel zu Respekt. Lies bitte den ganzen Post bevor du irgendwelche Anschuldigungen von dir lässt.

    Hallo @all :),


    ich verzweifle gerade etwas an JSON. Ich möchte Daten per API abfragen und möchte dies mit einem cURL Request erledigen. Allerdings bekomme ich unerklärlicherweise die Fehlermeldung "Notice: Trying to access array offset on value of type null in C:\xampp\htdocs\test.php on line 317"


    Ich habe in diesem Script bereits mehrere APIs angesprochen und hatte kein Problem damit, die JSON Daten in PHP zu verarbeiten. Bei der 3. API hapert es jetzt irgendwie. Wahrscheinlich wieder eine extrem einfache Lösung und ich komme einfach nicht drauf.


    JSON:


    PHP Code:

    Ich bedanke mich wie immer für eure Hilfe :)
    LG
    Maurice

    Hallo @all [Blocked Image: https://www.php.de/core/images/smilies/smile.png]pasted-from-clipboard.gif,


    ich habe aus einer anderen Website Quelltext in einer Variable gespeichert. Ich möchte aus diesem Quelltext eine bestimmte Zeile entfernen. Diese Zeile gibt Ländercodes an und sieht so aus: <span class="table-cell-item language">LÄNDERCODE</span>. Jetzt gibt es natürlich für jedes Land der Welt einen Ländercode und da kommen wir natürlich auf eine gewisse Zahl. Es kann sein, dass in dem Quellcode nur ein Ländercode vorkommt, es kann aber auch sein, dass ca. 50 Codes darin vorkommen.

    Da ist jetzt mein Problem. Wie überprüfe ich das, ohne tausende if/else Bedingungen zu schreiben? Wahrscheinlich gibt es dafür eine sehr einfache Lösung, die mir einfach nicht einfällt. Mein Code ist folgender.



    Das Problem ist natürlich jetzt, dass mit implode() alle Arrays auf einmal ausgegeben werden. Habt Ihr eine Lösung?

    LG

    Mauric

    So Thema können wir gleich dicht machen. Ich fühl mich gerade mega blöde.

    Ich habe meine beiden Domains (über die ich auch die beiden Mail Adressen habe) auf meinen Blog, welcher auf blogger.com gehostet wird umgeleitet. Das hab ich natürlich streng nach Anleitung von Google gemacht.


    Jetzt hab ich dort natürlich aber auch den Mail Server abgeändert (stand in der Anleitung so...). ICH VOLLIDIOT. Na dann kann es auch nicht funktionieren. Kann ich im DNS Record einfach den Mailserver wieder auf Netcup umstellen oder funktioniert die Umleitung nicht mehr korrekt? Dann müsste ich mit meinem Blog komplett wieder hierher umziehen.


    LG
    Maurice

    Ja gut aber ich muss ganz ehrlich sagen, wer da Test einträgt...


    Interessanterweise habe ich jetzt mal einen E-Mail Account genommen, den ich eigtl. nicht verwalten wollte, dort läd er zumindest in Thunderbird ALLE bisherigen E-Mails korrekt runter, allerdings kann ich keine Mails verschicken? Und der PC ist neu, also liegts nicht daran das der Account schonmal auf dem Rechner verifiziert war Oo.


    // EDIT:


    Habe gerade mal die automatische Mail Weiterleitung getestet, welche man direkt im Panel einstellen kann. Auch die funktioniert nicht.

    Hallo liebes Forum,


    ich hoffe Ihr könnt mir helfen. Ich habe Probleme mit den Mail Adressen von Netcup.

    Ich bekomme diese partout nicht auf Thunderbird oder Mailbird installiert und kann mich nicht mal mit meinen Zugangsdaten in der Webmail anmelden, obwohl diese zugewiesen sind.


    Habe mich bei beiden Sachen an die Anleitungen gehalten und es will einfach nicht funktionieren. Habt Ihr Ideen was mein Fehler sein könnte? Was braucht Ihr um mir zu helfen :/


    LG
    Maurice

    Da brauchst du nicht groß googlen, sondern einfach nur kurz in das Handbuch gucken und die gewünschte Funktion aufrufen (btw: PHP bietet eines der besten Manuals wie ich finde).


    https://www.php.net/manual/de/function.password-hash.php


    Da kurz die erforderlichen Parameter (oder einfach die Beispiele) angucken und fertsch. :)

    Ich hab mich da belesen. Allerdings ist es dort so angegeben:


    Code
    1. echo password_hash("rasmuslerdorf", PASSWORD_DEFAULT);

    Allerdings wenn ich dort eine Variable zum Übermitteln verwende, dann müssen die ja weg?!


    Code
    1. $passwort_hash = password_hash($passwort, PASSWORT_DEFAULT);

    Es wird davon abgeraten, in übermüdetem Zustand Maschinen zu bedienen ;-)

    Hahaha passt perfekt :D.


    "Warning: password_hash() expects parameter 2 to be int, string given in C:\Webserver\htdocs\tickerme.de\admin\moderator_add.php on line 88" - hab diese Fehlermeldung gegooglet, leider nichts gefunden. Was ist denn bitte an meinem Code falsch?

    LG

    Hallo Community,


    habt Ihr eine eine Idee warum die password_hast Funktion nicht funktionert?


    Code
    1. $passwort_hash = passwort_hash($passwort, PASSWORT_DEFAULT);

    Als Error bekomme ich folgende Ausgabe:


    Fatal error: Uncaught Error: Call to undefined function passwort_hash() in C:\Webserver\htdocs\tickerme.de\admin\moderator_add.php:88
    Stack trace:
    #0 {main} thrown in C:\Webserver\htdocs\tickerme.de\admin\moderator_add.php on line 88


    Die Line 88 ist besagte Codezeile von oben. Hab leider kein Plan, was daran falsch sein soll :/


    LG
    Maurice