Posts by SLINIcraftet204

    root@v****************:~# ls -l /etc/apache2/sites-enabled

    total 28

    -rw-r--r-- 1 root root 1531 May 7 12:19 002-default.conf

    -rw-r--r-- 1 root root 1536 Feb 22 12:24 default-le-ssl.conf

    _old

    -rw-r--r-- 1 root root 6437 Sep 29 2019 default-ssl.conf_ol

    d

    -rw-r--r-- 1 root root 1464 Oct 10 2019 dis-default.conf

    -rw-r--r-- 1 root root 1519 Apr 2 20:39 gitlab.domain.

    de.conf

    -rw-r--r-- 1 root root 1738 May 7 12:21 gitlab.domain.

    de.ssl.conf

    lrwxrwxrwx 1 root root 33 Mar 23 15:56 nextcloud.conf -> .

    ./sites-available/nextcloud.conf

    Hi, nur eine Kurze frage: Ich möchte gerne mit meinem Server auf einen anderen Server umziehen im Sinne von ich habe aktuell den VServer VPS 2000 G8 und möchte gerne zu VServer VPS 4000 G9. Kann ich da bedenkenlos mit offline Snapshot umziehen oder könnte es da zu Problemen kommen

    Viele Grüße Nils:)

    Und wie sehen die zugehörigen vHosts in der httpd.conf aus? DirectoryIndex hat nur indirekt damit zu tun. Damit wird nur festgelegt, welche Datei ausgeliefert wird, wenn auf ein Verzeichnis zugegriffen wird. Ist keine dieser Dateien enthalten, dann wird eben entweder ein Listing zurückgegeben oder ein Fehler, je nachdem ob Options +Indexes oder Option -Indexes eingestellt ist. Das steht bei dir offenbar auf Options +Indexes, sonst würde das Listing nicht angezeigt. Zudem gibt es ja keine index.html in dem gelisteten Verzeichnis, weshalb dann eben das Listing ausgegeben wird. Vermutlich solltest du beim DirectorIndex eher index.php setzen statt index.html - oder beides. Bist du sicher, dass du einen Apache-Server richtig und sicher konfigurieren kannst? Ich kann es vermutlich nicht, aber das oben geschriebene ist mir jedenfalls klar.


    Und nein, eine .htaccess gilt auch für alle Unterverzeichnisse. Unter anderem deswegen ist der Apache ja so viel langsamer als nginx. Er muss bei jedem Pfad prüfen, ob im Verzeichnis oder irgendwo darüber im Pfad eine .htaccess steht und diese dann auch bearbeiten. Bei jedem einzelnen Request.

    Ich schicke es nochmal rein

    Ich habe oben erwähnt das ich nicht über unsere Domain im browser war. Wir haben ein SSL Zertifikat bei Cloudflare und eine automatisierte http zu https einstellung bei Cloudflare eingestellt.

    Dein Fehler sind für mich danach aus das PHP-Module nicht vorhanden oder aktiviert ist, dann wird natürlich auch die index.php Datei nicht geladen.


    Ich würde für deine Vorhaben wie @mfnalex es geschrieben hat mit vhost Datei Arbeiten.

    Dort kannst du Festlegen, auf welches Verzeichnis der Apache2 Server zugreifen soll und mit diese Methode wirst du auch deine Cloud wieder zum Laufen bekommen.

    Wie meinst du das mit php modul ? Denn wenn ich meinedomain.de/phpmyadmin aufrufe geht alles. Liegt nicht im html verzeichnis. Und wie ist das mit der vhost methode gemeint... Ehrlich gesagt ich bin ein bisschen doof was Apache angeht.(ich weiß nicht welche datei ich da bearbeiten soll/muss etc.) deswegen benötige ich ein bisschen Hilfe und erklärung:(

    tut mir leid

    hi, ich habe jetzt mal geschaut und habe das hie in dem Pfad /etc/apache2/mods-enabled eine Verknüpfung gefunden mit dem namen dir.conf und dir.load. Die Verknüpfungen führen zu dem Pfad /etc/apache2/mods-available und dort finde ich die original Dateien. In dem Modul dir.conf steht das hier:

    <IfModule mod_dir.c>

    DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm

    </IfModule>


    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet


    Also wir halten fest das modul ist aktiviert, scheint richtig konfiguriert zu sein aber es geht auch nach disable und wieder enable und neustart nicht. Hier ein Bild. Ich habe die Webseite über die *.supersrv.de seite aufgerufen. Haben aber auch eine eigene Domain damit verbunden, die Domain läuft aber auch auf dem Port 443


    serverindex.PNG

    Also eine .htaccess gilt ja grundsätzlich nur für das Verzeichnis, in dem sie liegt.


    Erstell doch einfach unter /var/www/html/baninterface folgende .htaccess, bzw. füg folgendes innerhalb eines <Directory ...>-Blocks im Vhost ein:


    Code
    1. Options -Indexes

    In dem Fall kriegst du beim Aufruf eines Ordners innerhalb des Verzeichnisses entweder das index-File, oder - falls nicht vorhanden - 403 Forbidden

    ich nutze die .htaccess mit dem Script hier :

    <Files ~ "^\.(htaccess|htpasswd)$">

    deny from all

    </Files>

    DirectoryIndex index.html

    order deny,allow

    Hallo liebe Netcup Community,

    ich habe jetzt kein ähnliches Thema gefunden, aber ich habe ein Problem mit meinem Apache2.4 Webserver. Das Problem ist, wenn ich eine Webseite auf dem Webserver aufrufen möchte (liegt in dem Verzeichnis /var/www/html/baninterface ) zeigt er mir das gesamte Verzeichnis, mit allen .php Dateien und den Unterordnern an. Wenn ich aber eine .htaccess erstelle, in der steht das er standardmäßig auf die index.php oder auf dem Hauptverzeichnis (/var/www/html) eine index.html zugreifen soll, geht das. Ich habe aber auch eine Cloud auf meinem VServer installiert und nutze diese Für meine Arbeiten und für Projekte die ich mit Personen mache, durch diesen Fehler ist meine Cloud gecrashed. Wie dem auch sei, kann ich einen Befehl eingeben oder Dateien bearbeiten, dass der Apache2.4 automatisch erkennt ob eine index.php oder index.html in dem Verzeichnis, was man über den Browser aufruft prüft und direkt ansteuert.

    Danke im Voraus


    Viele Grüße Nils


    PS. Sorry für so viel Text:(

    Aber um auch Nochmal darauf zu reagieren

    bezogen auf dpkg --print-architecture ich habe amd64 da stehen

    i3860 klingt schräg. Habe das aber schon mal irgendwo gelesen.


    Lösung war dort.:

    Code
    1. dpkg --remove-architecture i3860
    2. dpkg --add-architecture i386
    3. apt update

    also ich habe diese Befehle probiert und das jetzt der Output:

    Code
    1. Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
    2. Ign:2 http://ftp.de.debian.org/debian stretch InRelease
    3. Hit:3 http://ftp.de.debian.org/debian stretch Release
    4. Get:4 http://security.debian.org/debian-security stretch/updates/main i386 Packages [517 kB]
    5. Hit:5 https://packages.microsoft.com/debian/9/prod stretch InRelease
    6. Get:7 http://ftp.de.debian.org/debian stretch/main i386 Packages [7,066 kB]
    7. Fetched 7,583 kB in 1s (4,203 kB/s)
    8. Reading package lists... Done

    Also hat jetzt geklappt.

    Ich bedanke mich trotzdem für eure Hilfe und Bemühungen :):)

    Hey Ho, ich habe mal eine Frage, diese handelt sich um Debian 9.11. Wenn ich im Konsolen Fenster apt-get update eingebe dann kommt dieser Output: Hit:1 http://security.debian.org/debian-security stretch/updates InRelease 

    Ign:2 http://ftp.de.debian.org/debian stretch InRelease 

    Hit:3 http://ftp.de.debian.org/debian stretch Release 

    Hit:4 https://packages.microsoft.com/debian/9/prod stretch InRelease 

    Reading package lists... Done 

    N: Skipping acquire of configured file 'main/binary-i3860/Packages' as repository 'http://security.debian.org/debian-security stretch/updates InRelease' doesn't support architecture 'i3860' 

    N: Skipping acquire of configured file 'main/binary-i3860/Packages' as repository 'http://ftp.de.debian.org/debian stretch InRelease' doesn't support architectu re 'i3860'

    Weiß jemand was da jetzt genau das Problem ist und wie ich es beheben kann, ich habe auf der Offiziellen Debian Seite gesucht aber leider nichts Hilfreiches gefunden :(. Ich denke mal das ein Server Neustart nicht unbedingt was bringen wird. Sollte ich mich mit dem Support in Verbindung setzen, da es vielleicht mit der CPU Architektur zusammen hängen könnte... Ich weiß auf jeden Fall nicht was ich machen soll. Ich danke für jede Hilfe im Vorraus.?(

    Hallo ich bein neu und habe vor 2 Monaten zu Netcup gewechselt. Ich wollte mal apt-get update eingeben um das System zu Updaten aber wenn ich apt-get update eingebe kommt nur diese Meldung

    Code
    1. W: GPG error: http://froxlormirror.netcup.net jessie Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F6B4A8704F9E9BBC
    2. W: Failed to fetch http://debian.froxlor.org/dists/jessie/main/source/Sources  HttpError404
    3. W: Failed to fetch http://debian.froxlor.org/dists/jessie/main/binary-amd64/Packages  HttpError404
    4. E: Some index files failed to download. They have been ignored, or old ones used instead.

    Ich habe schon das Forum auf den Kopf gestellt aber nichts gefunden was mir helfen könnte
    kann mir jemand helfen und erklären wie man das fixen kann