Posts by samci

    Ich hatte kürzlich den Fall, dass ein online veröffentlichtes Skript zum Kopieren von Emailpostfächern nur mit Netcup-Subdomains für den Mailserver funktionierte, aber Roundcube die zum Postfach gehörende Domain in einer mail.- Subdomain akzeptierte.


    Es scheint als ob Netcup hier sehr inkonsequent konfiguriert, und nicht immer kommt man mit den Angaben weiter, die in der Postfach-Info stehen, sondern muss auf DNS-Einträge zurückgreifen. So wird das Betreiben von Webseiten und Postfächern zur Tamagotchi-Pflege!

    Ich habe in den letzten Tagen wegen solchen und anderen Inkonsistenzen zig Stunden verloren, die ich dringend für andere Dinge gebraucht hätte. Unter anderem darum reduziere ich meine NC-Webhostingpakete nun, um den entstandenen Schaden in den nächsten Jahren wieder auszugleichen.

    Ich hatte schon öfter den Fall, dass ich NC irgendwas gemeldet habe, die Antwort bekam "Liegt nicht an uns, da können wir nichts machen", und kurz darauf war der Fehler behoben. Und das waren m.W. recht spezifische Sachen, also nicht immer etwas von allgemeinem Interesse. Von daher bin ich vorsichtig, was die Glaubwürdigkeit solcher NC-Rückmeldungen angeht.


    Ich kann nur hoffen, dass es diesmal wieder genau so läuft. Habe jetzt über eine Stunde in das Wiederfinden eines Email-Umzugs-Skripts gesteckt, das ich schonmal für Emails auf NC-Webspace benutzt hatte. Das war das einzige, was damals bei längerem Suchen überhaupt brauchbar war, ohne mehr als den normalen Webspace und mittelmässige PHP-Kenntnisse zu benötigen.

    Bei mir ist das unter Roundcube auch mit einer eigenen Domain passiert, die allerdings auf einem anderen Hostingpaket liegt als die Postfächer, in denen die Mails landen und über die gesendet wird.


    Jetzt bleibt mir wohl nur noch die Wahl:

    1. Domain aus dem Paket lösen, in dem sie bislang inklusiv ist, und dem Paket mit den Ziel-Postfächern zuordnen, von denen aus ich bislang unter der Domain senden konnte, oder

    2. unter der Domain Postfächer anlegen und fast 5 GB Emails umziehen auf das Paket mit der Domain.


    Und Netcup erzählt mir nur, man habe nichts verändert und könne daher nichts machen.

    Mal im Userforum der verwendeten Mailersoftware nachzufragen und sich nach möglicherweise kommenden Patches zu erkundigen, wäre also offenbar zuviel verlangt gewesen?


    Denn die Fehlermeldung zeigt ja ziemlich klar, dass das bisherige Senden unter einer externen Domain nicht bewusst unterbunden werden soll (da ja ansonsten eine klare Meldung dazu ausgegeben würde), sondern dass das ungewollt passiert. Von daher ist mit sehr hoher Wahrscheinlichkeit davon auszugehen, dass der Softwarehersteller durchaus erfreut über eine Info wäre und ein Interesse daran hat, den Fehler zu beheben.


    Es nervt extrem, wenn man seine ganze Email-Infrastruktur auf funktionierenden Lösungen aufbaut, die plötzlich nicht mehr funktionieren!

    Hallo Virinum,


    eine sehr einfache Lösung ist Deine aber nicht unbedingt ;-)
    Zugegeben, bei mehreren realen Benutzern trotzdem vermutlich eine der einfachstmöglichen, abgesehen von zwei komplett eigenständigen Installationen, wenn man diese keinesfalls will.


    Was ich beschrieben habe, war mein eigener Webmailer, also einer, den niemand ausser mir nutzt. Der von Dir genannte Nachteil ist also in meiner Anwendung irrelevant, aber war mir natürlich von vornherein bewusst.


    Wenn mehrere Benutzer vorhanden wären, würde ich der Einfachheit halber getrennte Installationen wählen, um dem Benutzer damit auch gleich die Serverauswahl (3. Zeile des Login-Fensters) zu ersparen.


    Die Idee mit den Subdomains ist generell nicht dumm, darauf wäre ich im Traum nicht gekommen. Aber einfach im geplanten Sinn ist sie halt nicht vor dem Hintergrund meiner reduzierten Anforderungen. Und funktioniert ja auch nur bei Mailservern, auf die ich selbst Zugriff habe. Käme noch ein weiterer Freemaildienst dazu, wäre die Lösung vielleicht schon hinfällig.


    Ich verstehe einfach nicht, warum in Roundcube nicht auch ein SMTP-Server- Array vorgesehen wurde. Der intellektuelle Mehraufwand wäre ja wohl gleich Null gewesen...


    Grüsse

    Samci

    Hallo allerseits,


    vielleicht verwenden ja auch andere hier eine eigene Roundcube-Installation, um ihre Emails zu verwalten, und vielleicht sollen damit ja auch andere Postfächer, als nur die auf dem eigenen Webspace, bedient werden.

    Da Netcup in letzter Zeit die PHP-Mailfunktion zunehmend deaktviert, ist man nun auch in Roundcube darauf angewiesen, neben dem Posteingangsserver auch jeweils einen Postausgangsserver festzulegen, und dies ist in Roundcube bislang wohl nur für einen einzigen je Installation vorgesehen - es sei denn, die Postausgangsserver (SMTP) entsprechen exakt den Posteingangsservern (IMAP).


    Da ich im WWW nichts unkompliziert Anwendbares finden konnte und auch keine Umgehung über Emailumleitungen und mehrere Identitägen in Roundcube wählen wollte (bzw. konnte, da z.B. Emails von Web.de auf vielen Serveren genau auf ihre Herkunft geprüft werden), habe ich mir eine eigene einfache Umgehung überlegt. Vielleicht hilft es ja dem einen oder anderen, der nicht so tief in PHP drin steckt und daher sowas nicht einfach selbst aus dem Ärmel schütteln kann.


    Die bei mir betroffene Roundcube-Version ist 1.3.8 . Einige darin enthaltene SMTP-Konfigurationsparameter habe ich in einer früheren Version nicht in der entsprechenden config.inc.php finden können, keine Ahnung warum. Ich kann mir nicht vorstellen, dass kurz zuvor noch kein SMTP-Mailversand in Roundcube möglich war, daher sollten diese Parameter evtl. auch in älteren Versionen funktionieren, aber das muss jeder selbst prüfen.


    Voraussetzungen der betroffenen Umsetzung:


    Roundcube selbst liegt im Unterverzeichnis mit dem Verzeichnisnamen "@", der Aufruf von Roundcube erfolgt nach Einstellen des gewählten Postausgangsservers mittels Klick auf den zugehörigen Link auf der neuen Auswahlseite im "Hauptverzeichnis".

    (Bei anderen Konstellationen kann jeder sicher leicht die entsprechenden Anpassungen in den folgenden Dateien selbst vornehmen.)


    In der Roundcube-Config im config- Verzeichnis von Roundcube wird lediglich die Einstellung des Postausgangsservers (SMTP) umgestellt und damit ein Auslesen des Postausgangsserver-Namens aus einer neu zu erstellenden Datei (siehe weiter unten) bewirkt:

    PHP: config.inc.php
    1. <?php
    2. // ... weitere Parameter
    3. $config['smtp_server'] = @file_get_contents('../server.conf');
    4. // ... weitere Parameter
    5. ?>


    Die neu zu erstellende Datei "server.conf" im Hauptverzeichnis kann leer sein oder einen beliebigen Inhalt haben. Sie wird dann überschrieben.


    Im "Hauptverzeichnis" (siehe oben) liegt weiterhin die neu hinzugefügte Konfigurationsdatei "serverconfig.inc.php", die die Namen aller zulässigen Postausgangsserver enthält:

    PHP: serverconfig.inc.php
    1. <?php
    2. $serverconfig = array( // Anpassen!
    3. 'NC' => 'mx????.netcup.net',
    4. 'Web' => 'tls://smtp.web.de:587'
    5. );
    6. ?>

    Und dort liegt auch die Index-Datei mit dem eigentlichen Skript:

    Dieses Skript erzeugt ein Auswahlmenü mit den zulässigen Postausgangsservers und schreibt den gewählten dann in die Datei "server.conf", wo er dann von der Roundcube-Config ausgelesen wird.


    Durch dieses Vorgehen ist der Eingriff in die eigentliche Roundcube-Installation nur minimal und kann nach einem Update ganz leicht erneuert werden. Dies war mir sehr wichtig. Natürlich wird jemand mit viel PHP-Erfahrung auch eine Erweiterung analog zur Verwendung der IMAP-Server direkt in Roundcube einprogrammieren können, ohne meine Umgehungslösung zu benötigen. Aber mir schien das mit meinen Kenntnissen nicht aussichtsreich genug - und sehr unangenehm bei späteren Updates.


    Grüsse und viel Erfolg beim Übernehmen!

    Samci

    Na dann eben eine behördliche Strafe... oder interessiert in Österreich eine fehlende Datenschutzerklärung nicht mal die Behörden?

    Dass die Seite kommerziell ist, ist ja nicht mehr zu übersehen!


    Ein neues Profil anlegen, damit man nicht von Netcup als Kunde kritisiert wird, dann NC-Gutscheine generieren und auf seiner eigenen Seite zum "Generieren" anbieten, und dann einfach für jeden Trottel absahnen, der keine bessere Quelle für einen kleinen Rabatt hat...

    Ich meine mal gelesen zu haben, dass tatsächlich nur die Zahlungen des Kunden als Grundlage der Provision dienen.


    Wenn er zu erfolgreich wirbt und Geld verdient, bekommst Du also 10% davon abgezogen bzw. berechnet.

    ;-) ;-) ;-)

    Aber im Ernst: Das Gegenteil des Letzteren habe ich tatsächlich noch nirgends gelesen. Dürfte sich aber aus dem Begriff "Provision" ergeben, denke ich.

    Meine Empfehlung wäre, alle mit Inhalt belegten Domains keinesfalls auf das standardmäßige Verzeichnis "httpdocs" zu leiten, da jede neu hinzugefügte Domain ebenfalls darauf verweist. Dort würde ich nur eine Platzhalter-Indexdatei ablegen oder die vorhandene belassen.

    Ich selbst habe einen weiteren Ordner für die letztlichen Domains im Stammverzeichnis (neben httpdocs) angelegt und unter den Domainnamen-Ordnern darin nochmal Unterordner für die Hauptdomain und jede Subdomain.


    Wenn man dann noch die Möglichkeit offenhalten möchte, bei jeder Subdomain auch solche Dateien abzulegen, die nicht direkt über HTTP zugänglich sind (wie Downloads per Skript), dann kann noch eine weiter Ebene sinnvoll sein mit dem eigentlichen per HTTP zugänglichen Verzeichnis und daneben einem Dateien-Verzeichnis oder sonstigen.


    Wenn man anfangs nur eine einzige Domain nutzt, ist es natürlich verlockend, diese Struktur eher nicht aufzubauen, aber mit der Zeit hat man dann nur noch die Wahl zwischen Kuddelmuddel und Umstellung. Wenn dann noch paßwortgeschützte Verzeichnisse vorkommen, ist das nicht mehr unbedingt in wenigen Minuten erledigt.


    Mit einer sauberen Struktur, vollständig wie beschrieben, kann man dann z.B. auch den gesamten über HTTP zugänglichen Bereich direkt daneben als ZIP-Sicherungskopie ablegen, ohne sich mit anderen Subdomains etc. in die Quere zu kommen, d.h. man kann Sicherungen erstellen, ohne sie danach nochmal verschieben zu müssen.


    Seit ich dieses System anwende, habe ich keinen weiteren Änderungsbedarf mehr erkennen können.


    Für Einsteiger noch wichtig zu wissen: Wenn eine Doman aus dem Webspace-Paket entfernt wird, wird der per HTTP zugängliche mit dieser Domain verbundene Ordner ebenfalls gelöscht, ebenso die per HTTP zugänglichen Ordner aller Subdomains. Ich bin mir nicht sicher, ob das auch bei Ordnern zutrifft, auf die andere Domains oder Subdomains verweisen, ich hoffe mal nicht.

    Wenn man jedenfalls "neben" dem so gelöschten Ordner zuvor eine (möglichst aktuelle) ZIP-Sicherungskiopie davon abgelegt hat, ist wenigstens das meiste nicht verloren, wenn man nach Jahren mal nicht daran denkt und eine Domain löscht.

    Habs gefunden... ganz schön verzwickt!


    Ich habe die Webmailer-Adresse mit Passwortschutz versehen. Und im (Firefox-) Browser ein Lesezeichen mit der URL einschliesslich Benutzername und Passwort abgelegt. Dadurch werden dann alle seiteninternen URLs ebenfalls mit diesen Zugangsdaten erweitert. Und das hat anscheinend dazu geführt, dass bei den Operationen rund um Kontakte was schief gelaufen ist. (Warum genau dort und nicht auch woanders, weiss ich aber nicht.)


    Ohne Zugangsdaten in den URLs funktioniert alles. Und da ich für meinen früheren Webmailer immer ein weiteres Lesezeichen ohne Zugangsdaten nach dem Seitenlogin aufrufe, waren dort natürlich keine Schwierigkeiten beim Erstellen von Kontakten aufgetreten.

    Ich hänge mich mal hier dran.


    Auf einem kleinen aktuellen NC-Webspace aus dem Adventskalender (1 GB, 1 Datenbank) habe ich unter einer Subdomain Roundcube 1.3.8 installiert. Sowohl ohne sämtliche aktivierten Plugins als auch mit den Standard-PHP-Einstellungen als auch mit PHP 7.2 und 7.3 sowie ohne jegliche verbotene PHP-Befehle kommt immer der selbe Effekt: Wenn ich einen Kontakt neu erstellen will oder eine erweiterte Einstellung unter Kontakte vornehmen will, erscheint ein flackerndes komplettes Email-Postfach-Fenster (wie unter dem Register "Email") über die Eingabemaske gelegt.


    In einer anderen Installation (RC 1.3.6) auf einem anderen Webspace mit überwiegend ähnlichen aktivierten Plugins passiert das nicht.


    ?????


    Grüsse

    Bei einer anderen Domainbestellung musste ich einiges mehr klicken, also habe ich vermutlich wirklich zu früh abgebrochen. War mir allerdings nicht bewusst, und ich hatte auch keinen Hinweis darauf wahrgenommen.


    Danke für die Rückmeldungen.

    Gestern habe ich versucht, im Zuge der Adventskalender-Rabattaktion eine DE-Domain im CCP zu bestellen.

    Auf meine spätere Nachfrage, als keine Bestätigungsmail kam und sich auch sonst nichts tat, wurde mir gesagt, laut Logfiles wäre meine Bestellung abgebrochen worden. Mir ist aber nicht bekannt, daß ich die Bestellung abgebrochen hätte, sondern meines Wissens hatte ich auf irgendwas mit "kostenpflichtig bestellen" geklickt.


    Ist vielleicht jemand anderem hier das Gleiche passiert, oder kann jemand von einer erfolgreichen Bestellung zum Aktionspreis _gestern_ berichten?

    Nebenbei: Eine .htaccess im Stammverzeichnis (auf Ebene des HTTP-Zugriffs über die Projekt-Subdomain) hat nichts gebracht. Inhalt war:

    AddDefaultCharset ISO-8859-1

    Getestet hatte ich auch

    AddDefaultCharset UTF-8

    (nur mal so auf Verdacht).


    Wenn ich im Firefox Unter "Ansicht -> Textcodierung" "Westlich" einstelle, ist alles OK.


    Mit CGI habe ich nichts am Hut, damit kann ich nicht dienen.


    Wenn ich im Plesk Onyx in der Dateiverwaltung bei einer Datei auf "Im Texteditor bearbeiten" klicke, zeigt mir dieser als Codierung ISO-8859-1 an.

    Eine Datei hatte ich mal direkt hochgeladen, die wird im Texteditor dort genauso als ISO-8859-1 codiert angezeigt wir die auf dem Server entzippten Dateien. Am Entzippen liegt es also anscheinend nicht.


    Anscheinend liefert der Server also die Dateien mit einem UTF-8 Header aus, obwohl sie ISO-8859-1 codiert sind?

    Muß ich jetzt alle Dateien umcodieren und die HTML-Kopfzeilen im <HEAD> Bereich ebenfalls auf UTF-8 ändern? Das wäre ein schöner Schlamassel!

    Hallo,


    wegen des bevorstehenden Einschläferns der Confixx-Pakete habe ich ein Projekt (heruntergeladene Sicherungskopie auf dem Windows-Rechner) gezippt und auf den neuen Webspace (Ples Onyx) hochgeladen und dort über das Verwaltungspanel auspacken lassen.

    Die Dateien sind unter Windows erstellt, mein Editor zeigt mir betreffend Zeichencodierung "ANSI DOS" an.

    Nach dem Entpacken auf dem neuen Webspace erscheinen alle Umlaute als Symbole.


    Liegt das nun am Webspace, oder an der Einstellung beim Entpacken? Gibt es eine Einstellung, die ich ändern kann, damit alles so angezeigt wird wie bisher auf dem alten Webspace? Ich habe dazu nichts gefunden.


    Grüße und vielen Dank für Eure Hilfe

    samci