Posts by pgloor

    Es hat sich erledigt. Heute sehen die Geschwindigkeiten für mich normal aus.


    An meinem PC habe ich in der Regel unter günstigen Verhältnissen bis zu 54 Mbps up- oder download. Gestern ging aber der Upload meiner Files auf den neuen Windows Server nicht schneller als mit konstant maximal rund 32 Mbps. Der Engpass lag eindeutig auf der Seite des Servers bei netcup.


    Ich habe jetzt nicht mehr im Detail getestet, aber soeben habe ich auf dem Server bei einem Download mehr als 200 Mbps gesehen. Es scheint alles normal zu sein.


    Da ich keine Erfahrung mit Windows Servern auf VPS Systemen bei netcup habe, war ich mir einfach nicht sicher, ob ich evtl. etwas falsch gemacht habe.

    Ich habe heute für ein Testprojekt auf einem VPS 1000 G8 einen Windows 2016 Server eingerichtet. Als ich von meinem lokalen PC ein Zip-File mit den zu installierenden Applikationen hochgeladen habe ist mir aufgefallen, dass die Netzwerkgeschwindigkeit bei ziemlich genau 32 Mbps/s stehen geblieben ist.


    Von meinem PC gehen normalerweise problemlos bis zu 54 Mbps über die Leitung. Während des Uploads lief am Server parallel auch noch ein Download von einer anderen Quelle, so dass ich eigentlich an der serverseitigen Netzwerkschnittstelle einen viel höheren Durchsatz erwartet hätte.


    Da ich bisher mit meinen bei netcup gehosteten Linux Servern in ähnlichen Konstellationen immer einen viel besseren Durchsatz hatte, frage ich mich ob es beim Windows-Server etwas spezielles zu beachten gibt.


    Bei den Netzwerkeinstellungen im SCP habe ich Treiber auf virtio gesetzt. Unter Einstellungen habe ich Optimierungen für Betriebssystem auf Windows gesetzt. Unter Medien ist der Treiber für die Festplatte auf SCSI gesetzt.


    Es ist jetzt nicht so, dass ich unbedingt mehr Durchsatz brauche, ich möchte nur sicher sein, dass ich nichts falsch gemacht habe. Vielleicht sieht ja morgen wieder alles ganz anders aus :/.

    Ich hatte es an anderer Stelle schon geschrieben, für mich wäre auch ein RS 2000 / RS 4000 mit Optane von Interesse gewesen.

    Dass die VPS-Hostsysteme aber nicht überbucht werden, würde ich übrigens so nicht stehen lassen, da man dann ja bei VPS dedizierte Cores hätte und die Root Server dementsprechend alle Beschiss wären. Ich glaube schon, dass da überbucht wird. Aber in einem humanen Rahmen, der völlig akzeptabel und auch sinnvoll ist.

    Ich habe meinen VPS Eierpower 1 Ostern 2019 nie als überbucht empfunden. Trotzdem habe ich meinen RS 2000 SSD G8 nie als Beschiss empfunden, weil es mir wichtig ist die Leistung garantiert zu haben und dafür auch gerne mehr bezahle.

    Das ist bei mir auch so. Der Driver für SQLite wird bei mir bei PDO auch nicht aufgelistet.


    In der Doku steht:


    "The PDO_SQLITE PDO driver is enabled by default. To disable, --without-pdo-sqlite[=DIR] may be used, where the optional [=DIR] is the sqlite base install directory. As of PHP 7.4.0 » libsqlite ≥ 3.5.0 is required. Formerly, the bundled libsqlite could have been used instead, and was the default, if [=DIR] has been omitted"


    Deshalb habe ich es einfach mal ausprobiert.

    Ja das ist so, das hat mich auch erstaunt. Weil ich vorwiegend nur noch mit Ubuntu 18.04 arbeite, habe ich auch erst kürzlich bemerkt, dass unter Debian 9.8 noch PHP 7.0 läuft. Debian war im Vergleich zu Ubuntu schon immer etwas konservativer, aber ich könnte jetzt nicht sagen, dass Ubuntu weniger stabil ist.

    Weiß zufällig jemand warum die PDO Unterstürzung für SQLlite mit der 7er PHP Version raus geworfen wurde?

    Wie kommst du darauf? Ich hab unter meinem Webhosting 1000 SE a1 (a2fc1) mit PHP 7.2 einen kleinen Test mit SQLite und PDO gemacht und das hat funktioniert.


    Angefangen mit: $file_db = new PDO('sqlite:messaging.sqlite3');

    Dann Errormode auf Exception gesetzt, eine Tabelle erstellt, Daten eingefügt, geändert und abgefragt, am Schluss die Tabelle gelöscht. Das hat alles funktioniert.

    Hallo,


    erstmal das Kostenlose Cloud Vlan bestellen und dann im SCP unter Netzwerk ein weiteres Interface hinzufügen.


    Eckhard

    Man hat nie ausgelernt ;) Ich dachte immer das Cloud VLAN sei a) kostenpflichtig und b) nur für die Kommunikation zwischen Root-Servern, vServern und Storage-Servern. Jetzt, wo ich weiss, dass VLANs mit 100 Mbit/s kostenlos sind hab ich mir natürlich gleich eines bestellt.


    FreddyG : Grundsätzlich unterstützt Netplan die Verwendung von Hook Scripts (in den Netplan FAQ zur Mitte runter scrollen), die für Spezialfälle an bestimmten Stellen des Ablaufs (z.B. pre-up etc) ausgeführt werden. Auf diese Weise habe ich eine Bridge eingerichtet, die dann problemlos verwendet werden konnte

    Das Codewort, um sicherzustellen, dass ein Host nicht versehentlich eine der Adressen als Absender nutzt, die er nicht nutzen soll, lautet Deprecated Address. (ip -6 a a [...] preferred_lft 0)

    Gut, dass du das erwähnt hast. Vergess ich auch immer wieder.

    1. Wie viele IPv6 Adressen kann ich auf eth0 packen?

    Keine Ahnung, wieviel brauchst du denn? 1999 sind kein Problem. Hab ich unter Ubuntu 19.04 soeben getestet.


    2. Pro IPv6 ein eigenes virtuelles Interface erstellen, also eth0:1, eth0:2, usw.. ?

    Das würde ich nicht empfehlen, wenn es nicht unbedingt nötig ist. Ich habe das vor zwei oder drei Jahren zum letzten Mal unter Debian gemacht und hatte mir später im Zusammenhang mit Virtualisierungen nur Stress eingefangen.


    3. Wie kann ich die Netzwerk Konfiguration neu laden, ohne den Server neu starten zu müssen ? (systemctl restart networking schlägt fehl)

    Auch dazu kann ich jetzt im Detail nicht viel sagen. Ich hatte das Problem (meistens) auch. Solange die zugewiesenen Adressen nicht wieder gelöscht werden (z.B. down ip -6 addr del ...) können sie auch nicht wieder hinzugefügt werden.


    Ich arbeite seit Ubuntu 18.04 nur noch mit Netplan. Da Netplan nicht alles unterstützt was ich benötigte, war die Lernkrurve zwar steil, aber es hat sich gelohnt. Im Allgemeinen sind meine Konfiguration jetzt viel einfacher geworden und besser zu verstehen.

    Aber wie kommt es dann, das ich dieses Jahr zu netcup gewechselt bin und PHP 5.6 habe?

    Warum netcup vorgabemässig noch PHP 5.6 konfiguriert, verstehe ich auch nicht. Es war bei meinem Web Hosting 1000 (bestellt im März 2019) auch so.


    Aktuell werden PHP 5.6 (EOL 31.12.2018) und 7.0 (EOL 10.1.2019) nicht mehr unterstützt und 7.1 bekommt seit dem 1.12.2018 nur noch Sicherheits-Updates (bis 31.12.2019).


    Ich denke mal, dass alle gängigen und von netcup angebotenen Web Applikationen mit PHP 7.2 problemlos laufen. Falls nicht, dann sollten Anwendungen, die nicht mehr laufen meines Erachtens auch nicht mehr angeboten werden.

    Ich hatte auf meinem "VPS Eierpower 1 Ostern 2019" den ich erst vor 2 Tagen eingerichtet habe extrem Lag mit konstant 20 - 70% Paket Loss in beide Richtungen auf meiner direkten SSH Verbindung. Indirekt über meine anderen Server oder externe Hoster lief es problemlos. Nachdem sich das Problem aus welchen Gründen auch immer nicht so schnell lösen liess, hat mir der Support angeboten mein VPS auf einen anderen Host umzuziehen. Ich hab natürlich das ok gegeben und schon war das Problem behoben.


    Herzlichen Dank an den Support! Echt tolle Leistung. Damit ist netcup in meiner Bewertung definitiv auf das Level meines bisherigen Hosters #1 gestiegen! :thumbup::thumbup::thumbup:

    Hat noch jemand Netzwerkprobleme?


    Ich habe z.Zt. von zu Hause aus eine extrem schlechte SSH Verbindung zu meinem "VPS Eierpower 1 Ostern 2019".

    Befehlseingaben, Editieren etc. sind praktisch unmöglich. WinMTR weist am VPS über 50% Packet Loss aus.


    Log ich mich über SSH an meinem "Root Server Spring 2019" ein läuft dort alles normal. Verbinde ich mich von dort weiter auf den oben erwähnten Server, dann läuft auch alles normal. Auch bei Umwegen über andere Provider funktioniert alles normal.


    Na ja, mal abwarten, in der Hoffnung, dass morgen wieder alles normal läuft.

    Ich kann mich dank Root-Server 2000 G8 für 10,99 EUR/Monat auch zurückhalten, wobei ich die vier Kerne eigentlich gar nicht wirklich brauche :D

    Ich hab ihn mal bestellt, da ich beim RS 2000 mit den 60 GB SSD am Anschlag bin und 4 GB mehr RAM auch nicht uninteressant sind. Andererseits kann ich auf die 4 Kerne auch nicht verzichten. Es wird Zeit über die Bücher zu gehen und mal aufzuräumen, denn jetzt hab ich insgesamt (netcup und noch 3 weitere Provider) reichlich Überkapazität.

    So langsam kommt für mich auch wieder die Zeit in der Rad fahren angesagt ist. Ich benutze dazu vor allem die Zeit ab Mitte April bis Anfangs Juli und Mitte August bis Mitte Oktober. Im Winter ist es mir zu kalt und Hochsommer nebst der Ozonbelastung einfach zu heiss.


    Ich gehöre zu den eher gemütlichen Radlern mit einem normalen Tourenrad. Wenn es nicht gerade regnet, dann fahre ich einmal in der Woche ca. 50 - 60 km und je nach Zeit, die mir zur Verfügung steht, mehr oder weniger täglich eine Runde von ca. 15 - 25 km. Ich habe das Glück in einer wunderbaren Gegend zu wohnen, wo es gut ausgebaute Radwege und viele Strassen abseits vom Verkehr gibt.


    Etwas nervig finde ich manchmal die Massen von E-Bike-Fahrern die, vor allem Wochenende dem Bodensee entlang, die Radwege unsicher machen. Vielleicht bin ich aber auch nur neidisch ;)


    Zum Sigma Pure GPS: ich sag jetzt besser nicht, was mich die Teile für meinen Fahrradcomputer, den ich mit einem Raspberry Pi basteln wollte, gekostet haben. *lol*


    ...öhm... da er immer noch nicht fertig ist, wir es vielleicht doch noch ein Sigma Pure ;)

    Ich denke ich habe dich schon richtig verstanden. Wenn du aber aus dem Container alle Snapshots löscht bevor du das Image erstellst, sollte diese Abhängigkeit auf Host B doch auch nicht mehr gegeben sein. Sonst wäre das meiner Ansicht nach ein Bug.

    Hinweis: Snapshots und Images sind verschiedene Dinge. Außerdem eine Einschränkung bei ZFS: Restores sind immer nur vom letzten Snapshot möglich. Um von einem älteren Snapshot wiederherzustellen, müssen alle neueren gelöscht werden. So zumindest laut LXD Doku.

    Ja, das ist so und ich muss zugeben, dass ich nicht wusste, dass diese Einschränkung nur für ZFS gilt.

    Benutzt hier jemand restic als Backup-Software?


    Bzw. was bevorzugt ihr?
    Borg, rsync, rclone, eigene Skripts, ..

    Früher: Acronis.

    Später: Eigene Scripte und rsync.

    Heute: Borg in Verbindung mit eigenen Scripten (z.B. für mysqldump).


    Mit Borg habe ich erst angefangen, es scheint aber ganz gut zu meinen Backup-, Restore & Recovery-Strategien zu passen.

    Zumindest früher gab es bei LXD + ZFS die Einschränkung, dass ein Snapshot/Image solange weiter existieren muss. wie ein Container daraus erstellt wurde.

    Den Fall, wie du ihn mit dem exportierten Image beschreibst, müsste ich zuerst mal nachvollziehen. Das wäre natürlich lästig. Kopiere ich aber z.B. einen Container, der ein Snapshot enthält, dann ist dieser Snapshot auch in der Kopie enthalten und kann nicht gelöscht werden, bevor er aus allen Kopien gelöscht wurde, bzw. diese nicht mehr vorhanden sind. Dies kann etwas lästig werden, weil man nicht ohne weiteres erkennen kann, wo überall ein bestimmter Snapshot enthalten ist.


    In deinem Fall würde ich wahrscheinlich so vorgehen, dass ich die Snapshots des Containers zuerst lösche bevor ich ihn exportiere, oder aus dem Container zuerst eine Kopie erstelle aus der ich die Snapshots lösche und dann diese bereinigte Kopie des Containers exportiere.