Posts by v.homic

    Hallo Community 8o,

    Ich will meine Domain, die ich über netcup bestellt habe, meiner Zone auf AWS Route 53 zuweisen. Dazu, so die Dokumentation für AWS Route 53, soll ich die folgenden Nameserver bei meiner Domain eintragen:

    Code
    1. ns-849.awsdns-42.net
    2. ns-1109.awsdns-10.org
    3. ns-1951.awsdns-51.co.uk
    4. ns-38.awsdns-04.com

    Nun bin ich für meine Domain im DNS-Zone-Editor auf "eigenen Nameserver" navigiert und soll nicht nur einen Hostname für den Nameserver, sondern auch noch IPv4 und v6-Adressen angeben?

    Muss man das machen, oder ist das Wahlweise? Oder habe ich da etwas grundsätzlich falsch verstanden mit den drei Spalten im "eigener Nameserver"-Menü? ?(

    Hier ein Screenshot meiner derzeitigen Konfiguration, die aber nicht funktioniert (habe schon einen Tag gewartet): ;(

    nameserver.PNG

    Ich freue mich über Hilfe, ^^

    v.homic :saint:

    Gibt es einen Weg, wie ich von einer Route 53 DNS-Zone (siehe AWS), welche ich frei editieren kann, die IMAP / POP3 Ports an einen SOGo Groupware Account weiterleiten kann? (E.g. kann ich für das SOGo Groupware-Produkt externe Domains verwenden?) Ich würde gerne mit der Domain, die über AWS betrieben wird, einen Mailserver betreiben, und nicht eine neue Domain kaufen, um das SOGo Groupware Angebot zu nutzen. Geht das? :/

    Ich freue mich auf Rückmeldungen :)

    v.homic

    Hallo Community,

    Ich habe mir ja vor kurzem einen Root-Server zugelegt und meine zwei VPS-Server gekündigt. Mein neuer Server hat natürlich eine neue IP. Jetzt bin ich ein wenig neugierig und wollte fragen, ob es eine Option gibt (auch gegen Gebühr / monatliche Zahlung), die IP des neuen Servers durch die meines alten VPS zu ersetzen, da ich die leichter zu merken fand. ^^
    Danke im Voraus,

    - v.homic 8o


    (EDIT: ipv4, nicht v6)

    Der einzige Nachteil, den ich bei dem EiWoMiSau-Paket sehe ist, dass hier keine garantierten Ressourcen (RAM) zur Verfügung stehen

    Danke für die Rückmeldung!

    Bei dem Paket steht unten "Zufriedenheitsgarantie: Ja". Was bedeutet das?

    Vielen Dank,

    - v.homic

    Die Domains müssen bei Bestellung nicht sofort angegeben werden. Kann man nach und nach später nachholen.

    Danke!

    Kann einer aus Erfahrung sagen, ob sich das EiWoMiSau-Paket lohnt oder ob ich eher einen besseren Root-Server nehmen sollte?

    - v.homic :P

    Danke für alle Antworten! 8o

    Ich habe jetzt vor, meine zwei VPS 200 (G8) zu kündigen und einen Root-Server (RS 1000) zu nehmen.

    Außerdem werde ich wahrscheinlich Webhosting bei einem anderen Anbieter kündigen und hier das Webhosting EiWoMiSau-Paket nehmen ;)

    Ich bin echt zufrieden mit den Produkten, der Preis-Leistung und dem aktiven Forum hier.

    Zu meinen Entscheidungen habe ich noch zwei Fragen:

    Da ich ja vorhabe die Produkt-Linie von VPS auf Root-Server zu wechseln, ist ein reibungsloses Upgrade durch den Support per E-Mail nicht möglich, oder?

    Zweitens, Muss man bei Bestellung alle 20 .de-Domains des EiWoMiSau-Paketes angeben oder kann man sich welche für später "freihalten"?

    Vielen Dank schon mal im Voraus ^^,

    - v.homic

    Okay, ich glaube das hat sich erledigt ^^

    Würde ein Root-Server in dem Preissegment (5-8€ / Monat) mehr Sinn als ein VPS machen? (Vergleich: RS 1000 vs VPS 500)

    Danke für die ganzen Antworten,

    - v.homic

    Hallo Community,

    Ich habe gemerkt dass ich an die Grenzen meines VPS 200 (G8) stoße ^^ weshalb ich im CCP von netcup nach einer Upgrade-Option gesucht habe, fand aber leider nix. Gibt es überhaupt so etwas wie ein Upgrade ohne Modifizierung bestehender Dateien oder muss ich meinen Vertrag kündigen, davor alles auf einem Snapshot sichern und auf das neue Produkt überspielen?

    Mein Mailcow docker container braucht im Moment schon die Hälfte meines Arbeitsspeichers (1 GB) im Leerlauf, ohne dass SOLR läuft (wegen low-memory deaktiviert).

    Sollte ich auf ein besseres VPS (wahrscheinlich VPS 500) upgraden oder lohnt sich in diesem Preissegment schon ein Root-Server (RS 1000), meine Seite ist öfters etwas langsamer am laden (und ich schiebe mal die Schuld auf die anderen... 8o)

    Vielen Dank,

    - v.homic


    P.S.: Sorry netcup, aber bei 7€ im Monat für einen Root-Server habe ich mir auch über die Heranschaffung eines eigenen Servers Gedanken gemacht. Die Kosten sind zwar zuerst recht hoch (2x 6 Kerne + 32 GB RAM für 300€), aber die Leistung ist natürlich auch weitaus höher als was ich gewohnt bin. Ich kann jedoch keinen preiswerten Rack-Mount für den Server (in diesem Fall der HP BL460c G7 gebraucht auf ebay) finden, den billigsten Rack von HP den ich finden konnte kostet genauso viel wie der Server selbst (ebay). Kennt da jemand günstigere Racks? Bin natürlich immer noch am Upgrade meines VPS interessiert...

    Hast du dich in der ersten Zeile des Quellcodes vertippt (Sonderzeichen sind nicht erlaubt) ^^ ?

    Die Subdomain webmail soll eine ganz normale Subdomain wie m sein, warum besteht ein Unterschied im Typ (A / CNAME)?

    Angenommen die erste Zeile des Quellcodes ist ohne das ; gemeint: Würde die Domain dann nicht immer noch alle Subdomains an die IP leiten?

    Ich will, das nur die genannten Subdomains (m, www und ohne Subdomain) zur IP gelangen, alle anderen (zufälligen) Subdomains sollen durch DNS abgewiesen werden. Die Subdomains imap und smtp sind hingegen nur zum E-Mail-Empfangen bzw Senden gedacht (Mailserver). Sollte nicht für smtp wie bei imap auch ein CNAME record angelegt werden oder verstehe ich da was falsch ^^ ?

    Vielen Dank trotzdem für die Antwort,

    - v.homic

    Hey Community,

    Angenommen meine IP wäre 1.1.1.1 und meine Domain example.com .

    So sähe meine DNS Konfiguration aus:

    Code
    1. HOST TYPE MX DESTINATION
    2. * A - 1.1.1.1
    3. @ A - 1.1.1.1
    4. @ MX 10 mail.example.com
    5. ftp A - 1.1.1.1
    6. mail A - 1.1.1.1
    7. www CNAME - @

    Wie müsste ich die ersten beiden Wildcard-Records (zu meiner IP) abändern, sodass nur folgende Subdomains aufgenommen werden:

    imap.example.com , smtp.example.com , webmail.example.com , m.example.com , http://www.example.com , example.com (ohne Subdomain)

    Zusätzlich frage ich mich, für was der (vorinstallierte) MX-Record zuständig ist. Ich habe keine Subdomain names mail.example.com, müsste ich diese Zeile für einen funktionsfähigen Mailserver vtl auf imap.example.com oder smtp.example.com umstellen?

    Vielen Dank schon mal im Voraus 8o,

    - v.homic

    Beim Ausstellen eines SSL-Zertifikates und den damit verbundenen Problemem, die ich hatte (beim Aufruf wurde konstant ein 302 Error gezeigt, obwohl das Zertifikat laut ssllabs.com einwandfrei sei),

    fiel mir eben auf, das beim pingen von meiner Domain eine komplett andere (***.bestsrv.com) als eigentliche Adresse zum Vorschein kam.

    Bei Registration meines SSL-Zertifikates auf dieser Adresse anstelle von meiner normalen Domain kann ich die Seite jetzt zwar in Firefox aufrufen, erhalte aber ein "Diese Verbindung ist nicht sicher"-Warnmeldung da die Zertifikatkonfiguration Firefox als unsicher empfindet.

    Für was soll ich nun das Zertifikat ausstellen ohne dass ich einen 302 Error kriege?

    LG v.homic

    Das würde ich Mal gutes Feedback nennen :).

    Beim Webserver geht es mir weniger um die Resourcen (nur eines der Argumente), sondern mehr um die Kontrolle. Ich kann meinen Apache so wie ich es will jederzeit erweitern oder umkonfigurieren. Diese Freiheit bietet mir kein Webhosting Vertrag.

    Das Problem mit der Sicherheit und der damit in Hand gehenden Verantwortung haben mich jetzt dazu gebracht mich erstmal ein wenig zuruckzulehnen und alles in Ruhe zu konfigurieren.

    Danke für alle Hilfe bisher, Community,

    - v.homic

    All diese Dinge die du hier fragst lassen sich doch ganz einfach durch ein wenig Google und ausprobieren lösen.


    Wenn ich schon lese was deine Argumentation bzgl. SSH-Pubkey ist, verdrehts mir den Magen.


    Wäre es nicht sinnvoller ein Webhosting Paket zu buchen?

    Gottseidank treffe ich nicht auf solchen Schwachsinn in stackoverflow.

    Sollte der Apache nicht hochkommen, so stimmt etwas mit der Config nicht.

    Mit https://mozilla.github.io/serv…tls/ssl-config-generator/ kannst du dir eine passende vHost Config erstellen lassen.

    Dann brauchst du noch einen vHost der auf Port 80 lauscht und alles auf https umleitet.


    Code
    1. <VirtualHost *:80>
    2. ServerName meinedomain.io
    3. Redirect / https://meinedomain.io/
    4. </VirtualHost>

    Danke für die Antwort :thumbup:

    Habe das Problem aber anders gelöst, anscheinend war nur ein einfacher apt-get remove --purge apache2 notwendig, da ich auch noch andere Konfigurationsdateien gelöscht habe.

    Inzwischen ist der Server also up-and-running, das einzige was jetzt noch eingerichtet werden muss ist ein Wildcard-Zertifikat von Lets Encrypt.

    Du kannst den Parameter -d auch mehrfach aufrufen. certbot certonly --standalone -d meinedomain.io -d http://www.mainedomain.io erstellt dir ein Zertifikat, welches beide Domains abdeckt.

    Ja, das wusste ich schon (ausnahmsweise ;)), aber wie schon erwähnt habe ich das probiert und beim Aufruf von meinedomain.io ohne Subdomain in Firefox wurde trotzdem kein SSL-Zertifikat dafür angezeigt (noch eine automatische Weiterleitung auf https://).

    Mal sehen wie das ganze Enden wird,

    - v.homic

    Hallo Community,

    habe heute wieder ein Paar Erfolge, aber auch Probleme bei der Entwicklung meines vServers zu melden. Zuerst einmal was ich eingerichtet habe:

    1) ssh schon auf public key authentification umgestellt

    Wollte ich sogar fast machen, ich verwende aber PuTTY unter Windows zum Verbinden mit dem Server, und während der ein Programm namens "puttygen" zur Generierung von Public/Private Keys besitzt, lasse ich mir lieber die Freiheit, von unterscheidlichen PCs aus auf den vServer via SSH zu gelangen (ohne vorkonfiguration).

    root-Access für ssh verweigert

    Jo!


    mit fail2ban beschäftigt

    Habe ich, ist jetzt für SSH (sshd) eingerichtet.


    Port 443 geöffnet

    Sieht so aus.

    Lets Encrypt auf der Webseite installiert

    So, da bin ich grad.

    Habe mit certbot zuerst ein Zertifikat für http://www.meinedomain.io erstellt, stellte dann aber fest, das wenn mal als URL einfach nur meinedomain.io eingibt, man nicht automatisch (wie geplant) zur SSL-Zertifikat-Seite umgeleitet wird, geschweige denn das solch ein Zertifikat überhaupt dafür existieren würde. Die Antwort war ziemlich klar: ein Wildcard-Zertifikat muss her (davor habe ich auch probiert, ein Zertifikat einfach nur für meinedomain.io ausstellen zu lassen, änderte aber nix). Durch die vergleichsweise neuen acme-v02-Zertifikate von Lets Encrypt kann man, sofern man dies angibt, auch Wildcard-Zertifikate kostenlos sich ausstellen lassen. Also habe ich mehrere Tutorials durchgelesen und durchgeführt, um bloß festzustellen, das nun kein einziges SSL-Zertifikat für die Seite mehr hinterlegt ist, obwohl Certbot auf Nachfrage *.meinedomain.io als Zertifikat anzeigt. Der leicht übersehbare Grund: Ich habe, nachdem ich das Zertifikat für www.meinedomain.io und meinedomain.io gelöscht habe (mit dem revoke command), auch in /etc/apache2/sites-enabled/ alle Dateien gelöscht (in dem Glauben, ich müsste dies auch noch "zur absoluten Reinigung" vornehmen). Jetzt wird keines meiner SSL-Zertifikate von Certbot mehr durch den apache anerkannt. Wie kann ich die default-Dateien aus dem Verzeichnis "regenerieren"?

    Danke schonmal im Voraus für alle Antworten,

    ich hoffe ich habe dieses Mal eine ausreichende Basis und ein Ziel definiert,

    - v.homic

    Warum nicht Debian 9?

    Habe ich dann auch genommen ^^


    Schade, das du so über meine Kenntnisse denkst X/

    Ich recherchiere, bevor ich Fragen stelle und habe mir selbstverständlicherweise auch Linux-Vergleiche angesehen. Das du es nicht unterstützt, beim Einrichten eines neuen Webservers nach den Erfahrungen von professionelleren Nutzern zu fragen, ist meiner Meinung nach Schade. Hoffentlich hast du viel Spaß mit deinem Beruf und verschwendest in Zukunft nicht deine kostbare Zeit damit, Forennutzern zu helfen :thumbup:.

    Gruß,

    - v.homic

    Okay, nach langem Testen bin ich bei Fedora anscheinend ziemlich schlecht aufgehoben, da der Server mit dem Standardsetup eigentlich eine Willkommensseite anzeigen sollte, die fehlt (andere Seiten werden auch nur begrenzt angezeigt, obwohl inzwischen die Konfiguration abgeschlossen ist). Ich gehe wieder zu Debian 8 zurück und bin glücklich... (hoffentlich)