Posts by nosferata

    Ahhh...das könnte gut sein. Ich hatte nämlich zuerst mittels selbsterstellter .htacess die Zugriffe begrenzt, dann bemerkt, dass es ja anscheinend in diesem wordpress-toolkit auch so eine Schalter-Option gibt und die genommen, womöglich ist dabei dann etwas durcheinander geraten.

    Danke für den Link. :)

    ArtCore7

    Juchuuu! Nach dem Umschalten der Permalinks funktioniert es nun wieder...hab vielen, vielen Dank!!! :) !

    Ich konnte sogar wieder auf meine alten Einstellungen zurückschalten und es geht immer noch :-))


    Im Protokoll wird jetzt auch kein Fehler mehr angezeigt, obwohl die Pfade zu den Seiten immer noch wie oben beschrieben aussehen....sollte mir das zu Denken geben? Ich meine, deutet das auf ein Konfigurationsproblem hin , sprich muss ich bei künftigen Updates damit rechnen dass immer wieder so ein Fehler auftritt?

    Was mich auch einigermaßen verwirrt...bei einer anderen Site bekam ich beim Updaten eben dieses Plugins (FooGallery) auch die Fehlermeldung, dass es nicht möglich wäre ("Die ausgewählten Elemente konnten nicht aktualisiert werden.There is no appropriate version to update WordPress instance #448) ", upgedatet wurde aber anscheinend trotzdem :S....und bisher konnte ich *hier* auch noch keine Probleme feststellen (Gallery ließ sich hier weiterhin aufrufen.):wacko:


    vmk

    Vielen Dank für Deinen Tip. Wo/wie mache ich das?

    Hallo liebes Forum,

    ich habe folgendes Problem mit meiner Wordpress-Site, von dem ich leider nicht wirklich weiß wie es zustandekam/kommt und v.a. wie ich es lösen kann. :-/


    Das Problem:

    Bei Aufruf von Unterseiten meiner Website, bekomme ich den Fehler 404. Wenn ich im "Protokoll" nachschaue, sehe ich, dass die Seiten mit GET/ seite/HTTP/1.0 aufgerufen wurden (Fehler 404) während korrekt ausgelieferte Seiten aber dort z.B. mit GET/wp-content/uploads/...HTTP/2.0 aufgeführt sind. (Im Web-Browser hingegen steht unten in der Statuszeile beim Aufruf einer Unterseite ganz normal "website/unterseite".)


    Das Problem trat zuerst auf als ich ein Update für ein Plugin (FooGallery) einspielen wollte. Da bekam ich die Fehlermeldung dieses könne nicht eingespielt werden. (Wurde es dann aber wohl doch, zumindest wenn man die Versionsnr. des Plugins betrachtet) Danach ging die Galerie-Seite nicht mehr.


    Da ich vermutete, dass es sich evtl. um ein Rechteproblem handeln könnte, habe ich den zeitweilig aktivierten Passwortschutz der Seite einfach mal ausgeschaltet. Danach musste ich feststellen, dass jetzt auch die anderen Unterseiten nicht mehr funktionierten.=O


    Hat jemand eine Idee, woran das liegen könnte...? bzw. wie ich den Fehler beheben könnte?


    Schon mal vielen Dank für's Lesen und lg

    Bin gerade unterwegs... Aber du musst das WordPress Toolkit im WCP benutzen um die Seite zu klonen. Dieses legt auch eine neue Datenbank an und passt deine Datenbank und die CONFIG Datei an. Und man kann auch einfach zurück migrieren.


    Wenn es dazu Fragen gibt hau sie raus. Werde aber erst später antworten können.

    Oh...mir war nicht klar, dass "Website kopieren" in der Plesk-Ansicht(?) was anderes ist als "Website klonen" im WCP. Über den von Dir beschriebenen Web hat es sofort geklappt und ich konnte die Instanzen nun in den von mir gewünschten Zustand bringen. :thumbup:


    Hab vielen, vielen Dank!!...das hat mir eine Menge Ärger und Verwirrung erspart.:)

    Hallo liebes Forum,


    um nicht alle Änderungen immer gleich auf der Produktiv-Website (auf der Wordpress installiert ist) vornehmen zu müssen, habe ich meine Website (Produktiv-Website) mittels der Schaltfläche "Website kopieren" auf eine meiner anderen Domaines (Test-Website) kopiert. Nun ist es aber so, dass, immer wenn ich mich bei der Test-Website in Wordpress anmelden möchte, ich auf meine Produktiv-Website umgeleitet werde. :wacko: Auch sind alle Änderungen, die ich auf der Produktiv-Website vornehme automatisch auch auf der Test-Website gültig. Eigentlich wollte ich aber, dass die Test-Website nach der anfänglichen Datenübernahme aus der Produktiv-Website erstmal davon unabhängig ist, damit ich dort risikolos neue Dinge ausprobieren kann bevor ich diese dann auf die Produktiv-Website übernehme.


    Was habe ich falsch gemacht, bzw. wie bekomme ich das hin?


    Schon mal vielen Dank und liebe Grüße

    Super! Das funktioniert ja ganz wunderbar. :) (nur musste ich "checksums" statt "checksum" eingeben)...und ich habe auf jeden Fall wieder was gelernt. Vielen lieben Dank!

    Genau so soll es sein. Der vorgeschaltete Basic Auth schützt zusätzlich deinen Administrationsbreich vor eventuellen Sicherheitslücken in Wordpress selbst. Beim Basic Auth sollte zudem unbedingt ein zufälliger Benutzer+Passwort vergeben werden.


    https://www.netcup-wiki.de/wiki/Websites#SSH-Zugang

    Vielen Dank für den Tipp, konnte mich nun auch entsprechend über SSH einloggen :), allerdings steht der Befehl "wp core verify-checksum" in meiner Bash standardmäßig anscheinend nicht zur Verfügung ("bash: wp: Kommando nicht gefunden"), kann ich bzw. wie kann ich das Programm dort installieren?

    Plugins nur die wirklich benötigten installieren. Auch schauen, wie aktiv diese gepflegt und weiter entwickelt werden.

    Die Wordpress Core Installation kannst du mittels "wp core verify-checksum" überprüfen.

    Danke für den Tipp. :)

    Noch eine Dummy-Frage..."wp core verify-checksum" ist ein Kommandozeilenprogramm, oder? Wie kann ich das denn bzw. ein Terminal bei netcup aufrufen?

    Vielen Dank für Deine Antwort. :)


    D.h. Du würdest die Datei "wp-login.php" mittels .htaccess (und entsprechender .htpasswd) schützen? Habe das gerade mal ausprobiert...das hat dann aber zur Folge, dass ich mich unter wp-admin jetzt quasi zweimal einloggen muss...oder habe ich da was falsch gemacht/verstanden?

    Liebes Forum,


    ...eine Frage die ich mir immer wieder im Hinblick auf meine Wordpress-Instanz (bisher nur zum Testen) stelle, worauf muss ich achten, um diese möglichst "sicher" zu gestalten? Ich weiss, das ist ziemlich pauschal gefragt, aber reicht es zB aus, wenn ich Wordpress nebst allen installierten Plugins möglichst aktuell halte und die von netcup empfohlenen Sicherheitseinstellungen (im Menü unter "Wordpress-Sicherheit überprüfen") aktiviere oder sollte ich zusätzlich in Wordpress noch ein SicherheitsPlugin (welches?) benutzen?


    Und- woran würde ich denn eigentlich ggf. erkennen können, wenn meine Instanz gehackt worden wäre? Gibt es z.B. einen Parameter auf den man immer achten sollte?


    Evtl. gibt es dazu womöglich eine FAQ, die ich übersehen habe...?


    Auf jeden Fall schon mal vielen lieben Dank fürs Lesen. :)

    Nachtrag:

    Ich habe jetzt nochmal alles neu installiert und es scheint tatsächlich so zu sein, dass dieses sodium_compat einfach zu WP dazugehört (vermutlich um den Update-Mechanismus abzusichern), insofern eigentlich alles ordnungsgemäß :)...das Einzigste, was mich nun noch etwas verwundert ist, weshalb der Pfad zu dieser Software extra unter "Anwendungen" aufgeführt wurde (wird er jetzt nicht mehr), aber damit kann ich leben...;)

    Oh, danke...dann ist es wohl zumindest etwas eher *Gutes* :)...trotzdem setze ich meine Instanz am besten einfach nochmal neu auf, schon um nochmal nachzuvollziehen, wie genau die Bib reinkam (evtl. hat es ja auch gar nichts Ursächliches mit dem von mir beobachteten bzw oben beschriebenen Verhalten zu tun, sondern traf nur zufällig zusammen...? :|)


    Jedenfalls vielen Dank für den Hinweis. :)

    Hallo,


    nachdem mir unter "Wordpress" angezeigt wurde, dass meine (zum Glück nur Test)Installation "fehlerhaft" ist bzw. der Pfad dorthin nicht mehr gefunden werden konnte ("keiner"), habe ich auf "Aktualisieren" (oder war's "Update"? ?() geklickt, woraufhin alles wieder richtig erkannt wurde. Nun wird mir aber neuerdings unter "Anwendungen" neben meiner Testinstallation noch "paragonie/sodium_compat" angezeigt...bei dem es sich wohl um ein wp-include handelt. Kann mir jemand sagen, wofür das gut ist? (Da es sich wie gesagt nur um eine Testinstallation handelt, ist es nicht so schlimm, will heissen ggf. kann ich alles nochmal neu aufsetzen...bevor ich das tue, würde ich aber doch ganz gern verstehen, was da eigentlich genau passiert ist..?()


    Sorry, ob der gewiss sehr anfängermäßigen Frage und schon mal vielen Dank für's Lesen :)

    LG

    Hallo, ich denke das kommt auf die Zahl der Besucher an und welchen Webhostingtarif du nutzt. Bei hunderten gleichzeitigen Downloads des Videos auf einer EiWoMiSau wird‘s wohl arg eng. Probier es einfach mal aus :)

    Dankesehr...hab ich jetzt mal. :) Bisher läuft's eigentlich ganz gut...nur auf dem iPad/Safari (zumindest auf meinem) scheint der Vollbildmodus irgendwie nicht ganz richtig zu funktionieren, scheint mir aber eher ein browserspezifisches denn ein Hosting-Problem...jedenfalls mit Chrome o. Firefox konnte ich bisher keine Probleme feststellen.

    Dankeschön :-), ich habe das Problem jetzt so gelöst, dass ich in der php-Datei des Plugins, welche die awesome fonts aufruft, einfach die url auf mein lokales Verzeichnis angepasst habe. Funktioniert auch soweit, ist aber natürlich insofern fehleranfällig, als dass es beim nächsten Plugin-Update vermutlich wieder überschrieben werden wird.

    Liebe Web-Experten,

    nachdem ich in meine WordPress-Seite eine Gallerie mit dem Plugin "NextGen" eingebunden habe, wird fontawesome.com aufgerufen.Ich würde die Fonts aber aus Datenschutzgründen lieber lokal hosten. Wie mache ich das am besten?

    Folgendes habe ich bisher dazu versucht:

    Ich habe mir im root-Verzeichnis meiner Wordpress-Installation einen Ordner "fonts" angelegt und dorthinein die von fontawesome.com heruntergeladene Datei "all.js" kopiert. Außerdem habe ich die Datei "header.php" meines Themes in mein Child-Theme kopiert und dort in dem Bereich "head" mittels <script> die Datei all.js eingebunden, allerdings hat das keinen Effekt, will heissen die Fonts werden immer noch extern aufgerufen. Woran könnte das liegen? Muss ich das noch irgendwo umstellen oder evtl. auch ganz anders vorgehen?


    Schon mal vielen Dank und liebe Grüße