Posts by felix.kretschmer

    Hallo zusammen,


    ich habe seit 1-2 Tagen Probleme mit meinen IMAP Foldern in meinem Webhosting Paket.

    Das Ganze tritt bei zwei unterschiedlichen Postfächern auf iOS sowie auf macOS Geräten auf.


    In beiden Fällen werden die onboard MUAs - also die Mail.app verwendet.

    Auf dem macOS sind plötzlich alle Ordner (außer die Inbox) verschwunden. Ein Neustart hat auch nicht geholfen. Nach dem löschen und hinzufügen des Kontos waren die Ordner wieder da und kurze Zeit später wieder weg.


    Auf iOS Geräten sind zwar die Ordner noch vorhanden, allerdings lassen sie sich nicht synchronisieren. Das System meldet dann einen Accountfehler: "E-Mails können nicht empfangen werden"


    Im Roundcube ist alles wie gehabt, weshalb ich jetzt auch zunächst mal nicht den Support belästigen will, da es auch ein Apple-seitiges Problem sein kann.

    Tritt das bei noch jemandem auf oder kennt ihr eine Lösung?


    Viele Grüße,

    Felix

    Ja, das ist auch mein Plan und "trivial zu lösen".

    Ich dachte ggf. an elegantere Lösungen ala die Fritzbox meldet die v6 Adressen der existierenden Hosts, aber da müsste AVM aktiv werden.


    Aber wird wohl auf die Lösung laufen. Ich muss mal mein Skript dazu anpassen wenn ich ein paar Minuten Zeit habe.

    Danke für die Antwort.

    Spannende Diskussion. Bin gerade darauf gestolpert, weil ich mir Gedanken zu IPv4 und IPv6 in einer DynDNS-Umgebung mache.

    Das DynDNS ist selbst gehostet bei netcup und greift in die DNS API. Wenn ich nun mein NAS hinter meiner Fritzbox über IPv6 erreichbar haben möchte, ist das nicht ganz so trivial, da der A record fürs NAS die IP der Fritzbox brauchen und der AAAA record aber der v6 Eintrag vom NAS ist.


    Mein erster Gedanke wäre einen CNAME zu missbrauchen und für den gleichen host einen AAAA record aufzumachen. Das ist aber leider nicht valide.

    Ein ALIAS Eintrag, müsste das Problem ja lösen, oder?


    D.h.

    fritzbox.example.com A -> 1.2.3.4

    fritzbox.example.com AAAA -> 2b13::23:4:ac:41

    nas.example.com ALIAS -> fritzbox.example.com

    nas.example.com AAAA -> 2b13::23:4:ac:42


    Habe das ganze auch mal bei dem DynDNS Skript als issue formuliert, da ich mir noch nicht sicher bin, ob ich einen Knoten im Kopf habe und es doch eine elegantere Lösung gibt: https://github.com/fernwerker/ownDynDNS/issues/4


    Viele Grüße,

    Felix

    MyFritz nutzt dann die DHCP-Hostnames aus der Fritzbox für die Geräte im Netz?


    Hier wäre vielleicht AVM gefragt, um die Fritzbox als DNS-Server nach extern auf zu machen. Dann könnte man einen NS Record aktualisieren und der Rest läuft über die Fritzbox.

    Oder geht das heute schon?

    Vermutlich kann man die Firewall für UDP und TCP auf Port 53 auf machen, aber ob der DNS-Server in der Fritzbox "welt-tauglich" ist, wage ich zu bezweifeln.

    Mehrere Host-Records mit der gleichen IP?

    Das würde ich nicht über so ein Update-Script machen, sondern die anderen Host-Records als CNAMEs definieren.


    Issues ansonsten gerne direkt ins github und gerne auch selbst Hand anlegen. Ich nehme gerne Pull Requests. :)

    Hallo zusammen,

    war jetzt mal ein bisschen tätig und habe es auch bereits so bei mir zum Laufen gebracht.

    Die Lösung von ocin4 ist natürlich auch möglich, macht aber nicht so viel Spaß. :) Hatte einfach Lust und Motivation da selbst ein bisschen aktiv zu werden.


    Die Lösung findet man open source hier: https://github.com/fernwerker/ownDynDNS


    Man könnte da jetzt noch einiges drum herum bauen. Auch aus Sicht der Security ist da sicherlich noch Nachbesserungsbedarf.


    Viele Grüße,

    Felix

    Die Antwort von [netcup]Felix ist mir auch nicht ganz nachvollziehbar.


    Da die Funktionalität ja über andere Mailclients (Thunderbird, Apple Mail) auch über den netcup SMTP nutzbar ist, ist es lediglich über Roundcube abgeschaltet. Anders geht es ja.


    Ich möchte ja auch nicht jede x-beliebige Absenderadresse nutzen können, sondern auch nur im CCP hinterlegte Aliases bzw. Weiterleitungen anderer netcup-gehosteter Domains.

    In meinem Fall:

    Postfach: fk@domain.de

    Alias: felix.kretschmer@domain.de -> fk@domain.de


    von fk kann ich via Roundcube und Thunderbird versenden

    von felix.kretschmer kann ich das nur via Thunderbird.


    Viele Grüße,

    Felix Kretschmer


    PS: Erachte die Funktionalität in 2018 eigentlich auch als selbstverständlich.

    Hallo zusammen,

    genau das war der Plan:
    Fritzbox überliefert IP, Domain (+User, Password damit es nicht jeder machen kann) an ein PHP Skript auf meinem Webspace.


    Dieses schreibt die IP separat raus, damit (analog zu voja), ich sie sehe, wenn mal was nicht klappt.

    Gleichzeitig nutze ich in dem PHP Skript die DNS API und schreibe die neue IP auf ne Subdomain.

    Ich muss nur die TTL entsprechend niedrig setzen. Weiß jemand, ob netcup hier Vorgaben für einen Mindestwert macht? Ansonsten würde ich ne 5min TTL oder so setzen.


    Sollte so funktionieren oder habe ich irgendwo n Denkfehler?


    Viele Grüße,

    Felix

    Hallo zusammen,


    seit Ankündigung der DNS-API (https://www.netcup-news.de/201…te-funktionen-netcup-dns/) müsste es ja möglich sein einen eigenen DynDNS Dienst zu hosten.


    Ich würde das gerne mit meiner Fritzbox angehen und wollte fragen, ob hier schon jemand eine ähnliche Idee hatte und eine Lösung bereits verfügbar hat.

    Ansonsten werde ich in den nächsten Tagen wohl mal auf Basis von dieser Entwicklung etwas bauen: https://github.com/mattes/php-dynamic-dns-server


    Viele Grüße,

    Felix

    Hallo zusammen,


    ich habe in meinem Paket 1 Postfach mit mehreren Aliases und Weiterleitungen anderer Domains auf dieses eingerichtet.

    Ich würde gerne diese Adressen ebenfalls als Absender (sog. Identitäten) nutzen können.

    Im Thunderbird kein Problem. Aber weiß jemand, warum man das im Webmailer (Roundcube unterstützt dieses Feature) nicht nutzen kann?


    Viele Grüße,

    Felix

    Die "native" Domain ist ja nur der Wechsel des zuständigen Nameservers. Also wenn Du meinedomain.tld schon auf dem Webhost anlegst und dann die Domain per Umzug hierher verfrachtest, läuft der Webhost (und die Mails) sofort, wenn die DNS-Server synchronisiert sind und Du musst nichts mehr ändern.

    Hatte exakt den Fall, weil ich das Postfach natürlich vorher getestet habe. Ja, es bleibt erhalten, was schon drin ist.


    Und das verarbeitet das Plesk auch nicht anders? Der löst dann die virtuelle Instanz aus der Verwaltungsoberfläche automatisch auf?

    Hat das schon jemand ausprobiert? Dass es technisch so funktionieren sollte, denke ich mir. :)

    Hallo zusammen,

    super. Danke für die umfangreichen Antworten.

    Über imapsync bin ich auch gestoßen, allerdings auf Einträge die meinten, dass das nicht via SSL möglich sei. Werde es ausprobieren.


    Frage zur virtuellen Domain: Was passiert mit dem Postfach, wenn ich die virtuelle Domain dann mit Domaintransfer in eine native wandel? Muss ich erst die virtuelle löschen? Bleibt mein Postfach dabei erhalten?


    Viele Grüße,

    Felix

    Hallo zusammen,


    kennt jemand eine einfach und schnelle Möglichkeit Mails von einem Provider zu netcup umzuziehen?

    In beiden Fällen existiert ein IMAP-Server.

    Allerdings kann ich bei netcup auch das Postfach für die gleiche Mailadresse noch gar nicht anlegen, bevor die Domain umgezogen ist.

    Angeblich bleibt das alte Postfach noch einen Moment bestehen. Es sollte also recht fix gehen.


    Viele Grüße,

    Felix

    Es scheint dann wohl gelöst.


    Der korrekte Webmailer für die neuen Verträge ist webmail01.netcup.net.


    Nach dem Anlegen eines neuen Postfachs dauert es allerdings 10-15 Minuten bis dieses via Webmailer erreichbar ist. Einbindung in den MUA funktioniert allerdings sofort.


    Im Webmail gibts dann auch Filter. :)

    Danke für die Antwort.


    Sehr interessant, denn ich habe mich bisher immer unter: https://webmail.netcupmail.de/ angemeldet.

    Hier habe ich definitiv keine Filter.


    Unter https://webmail01.netcup.net/ kann ich mich nicht anmelden -> Verbindung zum Speicherserver fehlgeschlagen.


    Wenn ich mich übers CCP an den E-Mail-Einstellungen im WCP anmelde, sehe ich dass ich hier Webmail für meine Domains auswählen kann. (Ohne oder Webmailserver01) Bisher war es auf "Ohne". Eine Änderung in Webmailserver01 hat aber auch keine Veränderung gebracht.