Posts by punckt

    Vielen Dank an Netcup für die Performance-Optimierung! :thumbup:


    Sowohl die Antwort- als auch die Ladezeit sind jetzt deutlich besser und auch der I/O-Test spielt in einer ganz anderen Liga:

    Code
    1. Laufzeit gesamt: 1862ms pro Zyklus(Schnitt): 0.124133ms

    Du brauchst für jede Wordpressseite je ein eigenes Stammverzeichnis und eine eigene Datenbank.

    Grundsätzlich können sich auch mehrere Wordpress-Installationen eine einzige Datenbank teilen. Wenn allerdings ausreichend Datenbanken zur Verfügung stehen, dann würde ich alleine schon aus Gründen der Übersichtlichkeit auch pro Wordpress eine DB nutzen.


    Je nach Einsatzgebiet wäre auch eine einzige Wordpress-Installation denkbar: https://www.webkinder.ch/was-ist-wordpress-multisite/

    Würde dir aber als "Anfänger" eher nicht dazu raten ...

    plugin hier, plugin da, ... da wundern sich die Leute, warum ihr Blog so lahmt 😂

    Naja, in dem Fall sind die genannten Plugins ohnehin nur einmal nötig und können bzw. sollten danach auch wieder entfernt werden. Sollte also in den fünf Minuten nicht allzu sehr die Performance drücken. ;)

    Und auch um das ca. 5,5-fache langsamer als bei meinem bisherigen Anbieter, bei dem ich echt nicht das tollste Paket hatte ...


    Aber man merkt alleine schon beim Laufen lassen des Scripts und beim Warten auf das Ergebnis, wie zäh es geht.

    Ich würde mal alle Plugins deaktivieren und schrittweise aktivieren und sehen, wo das liegt. Greifst Du auf irgendetwas externes zu? Evtl. ist ja irgendwo noch eine alte url drin und deshalb ist es so langsam.


    Verwendest Du zufällig jetpack?

    Danke für den Tipp, das hätte ich als Nächstes vorgehabt. Hatte aber zwischenzeitlich schon mal die meisten Plugins deaktiviert und das hat nicht spürbar was geändert. Jetpack hab ich nicht im Einsatz.



    […] wir freuen uns über das gute Abschneiden in den Benchmarkergebnissen. Trotzdem wundern wir uns auch über die initiale Ladezeit der Website.


    Wenn wir Sie bei der weiteren Analyse unterstützen dürfen, freuen wir uns über eine Kontaktaufnahme via E-Mail mit Verweis auf diesen Forenbeitrag und der bitte, dass unsere Systemadministration direkt die Anfrage bearbeiten soll. […]

    Vielen Dank! Mail hierzu geht in Kürze raus!

    Hecke29 Danke für das I/O-Test-Script.


    Hier die Resultate:


    netcup Webspace 8000 mit PHP 7.2.1:

    Code
    1. Laufzeit gesamt: 40653ms pro Zyklus(Schnitt): 2.710200ms


    bisheriger Anbieter mit PHP 7.0.17:

    Code
    1. Laufzeit gesamt: 7493ms pro Zyklus(Schnitt): 0.499533ms



    Die Werte von netcup gefallen mir in dem Fall gar nicht ... =O

    Anbei der Vergleich mit einer wirklich simplen HTML bzw. PHP-Seite.

    Auch hier ist eigentlich netcup flotter.


    An den Wordpress-Einstellungen kann es aber eigentlich auch schwer liegen, denn die sind eigentlich bis auf die URL ident.

    Caching oder so ist derzeit von meiner Seite aus auch keines aktiv.

    Mal einen MTR zur neuen und zur alten Seite verglichen? Evtl. bleibt die Zeit ja auf dem Netzwerk liegen...

    Danke für den Tipp. Ohne zu sehr ins Detail zu gehen schneidet hier netcup auch (teilweise deutlich) besser ab als mein bisheriger Anbieter.


    […] wir haben Ihren Interpreter einmal von FPM auf fastcgi geschwenkt. Jetzt sollte Ihr Benchmark besser ausfallen.


    Hintergrund: FPM startet einen PHP-Interpreter nach Bedarf. Existiert noch keiner, wird er erst geladen. Das dauert einige Millisekunden die sich in einem Benchmark auswirken können. […]

    Danke für den Versuch. Leider kann ich jedoch keine Besserung feststellen – eher das Gegenteil ist der Fall:

    • Lt. PageSpeed: Antwortzeit des Servers nun zwischen 3 und 3,5 Sekunden
    • Lt. Pingdom: Antwortzeit zwischen 2,75 und 4,07 Sekunden und die gesamte Ladezeit der Seite ist nun zwischen 4,94 und 6,52 Sekunden. ;(

    Hier die Ausgaben von bench.php


    netcup:


    bisheriger Anbieter:


    In allen Kategorien schneidet hier seltsamerweise der netcup-Server deutlich besser ab ... ?(

    ThomasChr Danke, hab das Plugin mal auf beiden Seiten installiert. Ehrlich gesagt werde ich aus den Werten aber nicht ganz schlau bzw. erschlägt einen das Plugin fast etwas mit den Details. =O


    Anbei mal die Zusammenfassung im Vergleich: Wenn ich es richtig interpretiere braucht der netcup-Server bei der Erstellung der Seite fast doppelt so lange, obwohl die Datenbank-Queries in einem Bruchteil der Zeit erledigt sind. :/

    Guten Morgen,


    danke für die rasche Antwort.


    Richtig, Plugins, Grafiken etc. haben natürlich einen großen Einfluss auf die Ladezeit der Seite. Allerdings habe ich mich hier nicht auf die gesamte Ladezeit bezogen, sondern nur auf die Antwortzeit des Servers, die hier im Bereich zwischen 1,5 bis fast 3 Sekunden liegt. Bei meinem bisherigen Anbieter liegt diese zum Vergleich zwischen 0,2 und 1,3 Sekunden


    Die gesamte Ladezeit der Seite bei netcup ist in meinen Tests bei ca. 4,5 bis 5,5 Sekunden.

    Die gleiche Seite (mit identischen Einstellungen, Plugins, Grafiken etc.) lädt bei meinem bisherigen Hoster in 3 bis 3,5 Sekunden.


    Dadurch, dass es sich hierbei um eine identische Wordpress-Installation handelt, erklärt sich die unterschiedliche Ladezeit für mich alleine schon durch die unterschiedliche Antwortzeit des Servers.

    Oder anders gesagt: Anscheinend braucht der Server hier deutlich länger, bis er die Startseite selbst (also ohne Bilder, CSS- und JS-Dateien etc.) "ausspuckt".


    Und genau das wundert mich so, denn eigentlich ist das Paket hier deutlich performanter als mein kleines Paket bei meinem bisherigen Anbieter. :/


    Hier der Link zur Testseite selbst: http://hosting107789.a2f2d.netcup.net/

    Dass auf der Seite selbst noch Optimierungen möglich sind (Bilder etc.) ist mir selbstverständlich klar – allerdings würde dies auf beide Webserver gleichermaßen zutreffen.


    Anbei noch ein Vergleich der Werte, die der Pingdom-Speedtest für die Startseite ermittelt.

    Hallo,


    ich habe seit gestern das Paket Webhosting 8000 und bin gerade dabei, die ersten Seiten aufzuspielen und mal mit einer Subdomain zu Testen, bevor ich meine Domains umziehe.


    Dabei ist mir aufgefallen, dass für eine Wordpress-Seite bei Tests über Pingdom und Google PageSpeed Insights die Antwortzeit des Servers immer bei 1,5 bis fast 3 Sekunden liegt, was ich doch als relativ hoch empfinde – vor allem, weil die meisten Werte deutlich über 2 Sekunden liegen.


    Da das Paket Webhosting 8000 lt. Beschreibung doch recht performant ausgelegt ist, bin ich nun etwas verwundert. Zuvor war ich bei einem anderen Anbieter, bei dem ich ein eigentlich deutlich schwächeres Paket gebucht hatte und dort kam ich immer auf Antwortzeiten zwischen 0,2 und 1,3 Sekunden.


    Deshalb wollte ich mal nachfragen, ob dies auch bei anderen in ähnlicher Form auftritt oder ob nur bei meinem Account irgendetwas nicht stimmt ...


    Kann natürlich auch sein, dass ich noch nicht die richtigen Server-Einstellungen gefunden habe: Die Server hier bieten wesentlich mehr Optionen als mein alter Account ... ;)