Import funktioniert nicht

  • Hallo, ich versuche gerade mit meiner Wordpress Seite zu Netcup umzuziehen und komme bei der Datenbank nicht weiter.

    Wenn ich versuche diese zu Importieren bekomme ich immer folgende Fehlermeldung:

    #1044 - Benutzer 'xxx'@'%' hat keine Zugriffsberechtigung für Datenbank 'yyyyy'


    Wie kann ich denn dem Benutzer zugriff erlauben?

  • Go to Best Answer
  • Erstelle eine Sicherung deiner SQL, öffne diese dann und lösche alle CREATE-Befehle - aufpassen das du nicht zu viel (aber auch nicht zu wenig) löscht. Lass mich wissen ob dir das weitergeholfen hat.

    2x Webhosting 8000 SE BF22 & 2x Webhosting 1000 SE BF22 & 1x Webhosting Spezial 100

    Edited once, last by Bud ().

  • bzw. beim Export über phpmyadmin alle entsprechenden Option abwählen

    das habe ich gemacht, jetzt bekomme ich 2 Meldungen:

    1. Der Import wurde erfolgreich abgeschlossen, 43 Abfragen wurden ausgeführt. (localhost-4.sql)

    2. #1044 - Benutzer 'XXX'@'%' hat keine Zugriffsberechtigung für Datenbank 'YYYY'


    Datenbank ist immer noch leer.

    Irgendwie stimmt da was mit den Benutzerrechten nicht. Hab dem Benutzer beim erstellen aber alle Rechte gegeben

  • Also ich habe das eben mal probiert.

    DB auf Server mit phpmyadmin exportiert ohne irgendwas an den Standardeinstellungen zu ändern. (Also mit Exportmethode "Schnell")

    DB auf Hosting mit phpmyadmin erstellt. ("Keine zugehörigen Websites") Dabei Nutzer erstellt. ("Hat Zugriff auf alle DBs", "Remoteverbindung von beliebigem Host zulassen")

    Dump importiert. - Klappt. Alles ist drin


    Insofern kann ich das Verhalten nicht nachstellen. (Gut für mich. Schlecht für dich ;) )

  • Ok der Import hat jetzt geklappt, die Webseite lässt sich aber nicht öffnen - "Error establishing a database connection"


    Ich habe zuvor alle Dateien per FTP von meinem alten Server auf meinen Rechner kopiert und diese in das Verzeichnis bei Netcup kopiert.

    In der wp-config.php habe ich Datenbank Name, User und Password angepasst.


    Soweit war das doch richtig oder?

  • Wieso nutzt du denn kein Plugin für den Umzug?

    Zurück zu deinem Problem: Hat sich denn die TLD bzw. die URL geändert?

    Wenn ja, dann musst du in deiner DB unter wp_options für siteurl und home die URL entsprechend anpassen.


    Achtung: Ich gehe mal davon aus das du die gängigen sicherheitsrelevanten Verbesserungen durchgeführt hast. Falls ja, wird der Präfix abweichen.

    2x Webhosting 8000 SE BF22 & 2x Webhosting 1000 SE BF22 & 1x Webhosting Spezial 100

    • Best Answer

    In der wp-config.php habe ich Datenbank Name, User und Password angepasst.

    Der häufigste Fehler, der hier gemacht wird ist, dass in der wp-config.php beim DB-Server entweder "localhost" oder die IP des Webservers eingetragen ist.

    Da muss die IP des Datenbankservers rein (Die liegt bei netcup nicht auf dem gleichen Server) Die findest du im WCP (Oder im CCP? :/ )

  • Der häufigste Fehler, der hier gemacht wird ist, dass in der wp-config.php beim DB-Server entweder "localhost" oder die IP des Webservers eingetragen ist.

    Da muss die IP des Datenbankservers rein

    Das war es! Vielen Dank

  • Tomasio

    Selected a post as the best answer.