Nextcloud - web-ui failing on bits and pieces

  • Hi Everone,

    See also attached images:

    Recently, netcup had an outage that required restoring a backup. Since that moment, bits-and-pieces of the Nextcloud web-ui are failing - a few examples:

    • no login fields with Chrome (Firefox and Edge are working as expected)
    • no folders and files after login with my account
    • no icons in the top-right from the installed-apps (i.e. calendar, files, contacts, etc).
    • nothing on "more"
    • no logout with right-click on user icon

    The weird thing is that except for the folders and files, everything is available when going via search.

    Meaning click on search and type (for example) settings, it shows me the settings with all entries. The same is for calendar, contacts and all others - just not for folders and files.

    I tried severall occ-commands like occ files:scan and occ files:cleanup. But nothing seems to work until now.

    I also tried debug-logging with the config below:

    'debug' => true,
    'loglevel' => 0,
    'log_type' => 'file',
    'logfile' => 'nc-itv.log',
    'logdateformat' => 'F d, Y H:i:s',

    But while lots of details, I didn't notice anything that may point to the root-cause.

    Any suggestions where to go from here?

    With warm regards - Will


    Empty login - IT visibility.pngEmpty files - IT visibility.pngHi Everone,

  • Hi,

    first i would check the permissions. Maybe some of them are not correct after restoring.

    Do you use a server or webhosting?

    You could install a fresh version of nextcloud in a second folder! and redirect the domain to it.
    Set it up so it works as usual and then move the old nextcloud_data folder into the fresh install and import the old database.

    Or if you only have one user and few plugins - recreate the user by hand.

    Best regards.


  • Homwer :


    Set it up so it works as usual and then move the old nextcloud_data folder into the fresh install and import the old database.

    Thank you for the quick response!

    Can you move the data-folder just like that to another location? Or only when the accomanied database is attached to it?

  • I'm using webhosting and VPS.

    Webhosting is giving me these hassles - VPS is working as expected.

    Tried with creating a new subdomain in a new folder and a new database => same endresult!

  • Did you try to perform an integrity check as well?

    Yes - did the core-check => some messages popped up - all referring to the logs folder in the docroot

    Perhaps this causing issues => contacted netcup support; also because an error about the logs-folder pops-up when creating a new subdomain.

    The error message is:


    relink-vhost-logs failed: './' already exists, but has wrong access rights. Specify --force to override. ERROR: Cannot relink logs. Target directory '/var/www/vhosts/' is in invalid state.

    Thank you for the quick response!

    With warm greetings,

    - Will | IT visibility

  • So you tried with a total new installation and get the same error?
    Might be something in your computer / browser - try a different machine or contact netcup support.

    Yes - correct.

    Also tried different browsers: FF, Edge and Chrome.

    On Chrome I don't even get a login. On FF and Edge the behavior is the same.

    My biggest problem is that I don't have files and folders in the webui since the outage.

    Netcup-support is not willing to help as Nextcloud is not supported.

    On top of that, everything is in the green on their site - which is probably true.

    With warm greetings,

    - Will | IT visibility