htpasswd - korrekter Pfad?

  • Hi,


    ich versuche einen Basis Passwortschutz zu implementieren - und denke das ich nicht den richtigen Pfad kenne. Habt Ihr Tips für mich?
    Der Passwortpromt kommt, aber ich finde keinen Weg eine valide user/passwd zu generieren.


    Apache Configuration
    # .htaccess-Datei für Web-Verzeichnis
    BasicAuthName "Password Required"
    AuthUserFile .htpasswd
    Require myuser



    Das habe ich noch probiert - gleiches Ergebnis.

    Apache Configuration
    AuthUserFile /httpdocs/.httaccess


    Ich vermute es müsste so aussehen, da appache nicht in meinem chroot environment läuft. Ich war überrascht nichts derartiges in der wiki / forum zu finden, vielleicht liege ich falsch?

    Apache Configuration
    AuthUserFile /..whatever_real_path../httpdocs/.httaccess



    Ich habe eine valide .htpasswd mit einem sehr einfachen temporärten Passwort.

    Code
    cat .htpasswduser:$1$rx[wKD@a$Vae8CQSBHf3390yKSVqVg.


    Thanks!Alex

  • Habe mich doch nur mal umgedreht und schon eine Antwort - man seid Ihr schnell :)


    Der Tip mit php.ini war gut - so habe ich es jetzt probiert.

    Apache Configuration
    AuthUserFile /var/www/vhosts/system/DOMAIN.de/httpdocs/.htpasswd


    Was du mit den xxxen meinst hat sich mir nicht erschlossen. Aber die phpinfo zeit mir das hier als php.ini

    Apache Configuration
    AuthUserFile /var/www/vhosts/system/DOMAIN.de/etc/php.ini


    Klappt leider immer noch nicht :(



    Alex

  • Ich habe das einmal durchgetestet. Mit folgender .htaccess hat es bei mir gerade geklappt:


    Apache Configuration
    AuthType Basic
    AuthName "Password Required"
    AuthUserFile /var/www/vhosts/XXXXXXXXXX/httpdocs/.htpasswd
    Require valid-user


    Die ist ein wenig anders als Deine Version. In /httpdocs/.htpasswd stand zum Test das:


    Code
    user:$apr1$v8U3sYdh$a/G9Fhp67ajMzDh/5TPol.


    Benutzer "user"; Passwort "passwd". Bei AuthUserFile gehört wieder Deine Domain ersetzt, anstatt der X.



    MfG Christian

  • Strange,


    klappt auch per copy & paste bei mir nicht. Vielleicht noch ein accountsetting? Habe aber gesehen als 2tschönste Lösung gibt es eine WebOption 'passwordgeschützte Verzeichnisse' im WCP.


    Bin aber noch experimentierfreudig wenn es weitere Tips gibt..


    Alex

  • Hi,


    Du lagst richtig - an anderer Stelle habe ich einen Pfad wie von dir beschrieben gefunden. Damit klappt auch htpasswd 1a. So richtig klar ist mir nicht wofür der Inhalt der Xe steht - aber da ich den für mich passenden Pfad jetzt kenne brauche ich das evlt. auch nicht zu verstehen.


    Respekt für die Frage nach den Linebreaks - kreative nach Problemen gesucht!


    /var/www/vhosts/hostingXXXXX.afXXXXX.netcup.net/httpdocs/




    /edit/ Auch kapiert - findet man im WCP als Default domain /edit/




    Danke Dir!
    ItsMee