Weiterleitung http zu https - Problem gelöst !

  • Guten Nachmittag,


    hoffentlich trage ich mit dem Thema hier nicht Eulen nach Athen:


    Vorauszuschicken wäre, dass ich kein Computerexperte bin.


    Mir geht es um Folgendes:


    Ich betreibe eine Webseite über netcup, basierend auf einer Drupal-Anwendung.


    Für die betreffende Webseite wurde ein kostenloses ssl-Zertifikat beantragt und erhalten.


    Dennoch wird die Seite bei Aufruf noch immer als http:... und mit dem Zeichen "nicht sicher" (durchgestrichenes Schloß) angezeigt.


    Ich erhielt nun den Hinweis, dass ich in der .htaccessDatei der Seite eine Umleitung einrichten müsse.


    Dazu habe ich aus dem Netz aus diversen Anleitungen zuletzt folgendes Zeilen kopiert


    RewriteEngine On

    RewriteCond %{HTTPS} !=on

    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


    und so versucht, diese an verschieden Stellen in die htaccess-Datei einzufügen:


    Mal ganz am Anfang, mal in der Mitte vor "Rewrite Rules" etc.


    Jedesmal jedoch das Gleiche Ergebnis:


    Es tat sich nichts.Ich war nach wie vor auf der unverschlüsselten Seite.


    Daher meine Frage:


    Was mache ich falsch ?


    Welche Zeilen muss ich wo wie einfügen ?


    Danke


    Eulenspiegel

  • Dazu brauchst du keine .htaccess, zumal die ja nur der apache Server auswertet. Benutze einfach im WCP die Hosting-Einstellungen:

    - SSL/TLS-Unterstützung

    - Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS

  • Danke, aber das funktioniert deswegen nicht, weil es die Einstellmöglichkeit in meinem alten Tarif bei netcup nicht gibt (habe ich bereits mit dem support abgeklärt). Eine Migration auf einen neuen Tarif nur für diese Funktion wäre mit einem unverhältnismäßigen Arbeits- und Kostenaufwand verbunden.


    Daher steht die Frage nach wie vor.

  • Welchen Tarif hast Du denn? Also welches Control Panel verwendest Du?

    1. Cloud Webhosting (Plesk Onyx) über das CCP bzw. *.webhosting.systems
    2. Webhosting Control Panel (WCP) über webhostingcontrolpanel.de
    3. Confixx über *.netcup.net

    Die erste Option scheint es laut Deiner Aussage ja nicht zu sein. Die dritte Option wurde bzw. wird mittlerweile eingestellt, das also wohl auch nicht.


    Somit wären wir beim alten WCP, also die zweite Option? :)


    Dort verwende ich folgendes in einer .htaccess Datei, das ist somit getestet:

    Apache Configuration
    RewriteEngine on
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]

    Dort gibt es sowieso nur Apache und noch keinen Nginx, das sollte also ohne Konfigurationsänderung im WCP klappen.

  • Danke.


    Es ist zum Verzweifeln. Es fnktioniert nicht.


    Habe diese drei Zeilen ganz oben, also in den Anfang der .htacess - datei hineinkopiert - ohne weiteres Feststellzeichen, überschriften oder anderes.


    Es tut sich aber nicht.


    Das Gleiche, wenn ich es in der Datei weiter unten in den Bereich diverser Rewrite - Rules einfüge.


    Irgendwie scheine ich wirklich zu doof zu sein.

  • Korrektur:


    Danke ! Es funktioniert doch.


    Ich hatte ganz einfach das falsche Wurzelverzeichnis genommen.


    Jetzt bei dem richtigen probiert und passt.


    DANKE !

  • Eulenspiegel

    Changed the title of the thread from “Weiterleitung http zu https” to “Weiterleitung http zu https - Problem gelöst !”.