Posts by Georg

    Nee, ich poste keine Namen von Mitarbeitern, mit welchen ich Kontakt hatte, im öffentlichen Forum. Aus Datenschutz und Respekt. Möchte niemanden bloßstellen.

    Hey killerbees19,


    danke für deine schnelle Antwort.

    Ich habe ein ncLabs Produkt, aber scheinbar keine Rechte in dem von dir verlinkten Unterforum. Der Support hilft mir unter der Begründung, es sei keine Supportleistung, welche in den ncLabs Produkten enthalten ist, nicht weiter. Ich soll mich an den Admin des Forums hier wenden...

    TCP/UDP auf Port 53 sind auf beiden Servern offen.


    Folgende Log Ausschnitte sind eben noch aufgetaucht:

    Ich hatte auch probiert die Berechtigungen (für den Test) für die

    Code
    1. /etc/bind/db.domain.tld

    auf 777 zu erweitern. Sowohl auf dem Master, als auch Slave. Bringt leider nichts. Kann es sonst noch an Berechtigungen im Verzeichnis liegen?

    Die named.conf schaut so aus:

    Die named.conf.options so:

    Die named-conf.local hatte ich oben ja schon eingefügt im ersten Post.

    Und die named.conf.default-zones so:

    Ist alles der Standard, habe bis auf das Einfügen der eigenen Zonen nichts geändert. Eine bestimmte control Richtlinie ist mir nicht bekannt.

    Ich wollt noch folgenden Log Ausschnitt hinzufügen:

    Code
    1. May 26 14:09:49 srv25 named[6212]: zone domain.tld/IN: refresh: unexpected rcode (SERVFAIL) from master XX.XX.XX.XX#53 (source 0.0.0.0#0)
    2. May 26 14:10:18 srv25 named[6212]: received control channel command 'retransfer domain.tld'

    Leider hilft mir das überhaupt nicht weiter. Habe auch schon mit den forwarders probiert, auch ohne Erfolg. Wisst ihr sonst noch was?

    Das ist des Rätsels Lösung. Problem ist scheinbar, dass bei mir die IPv6 config unter /etc/network/interfaces.d/50-cloud-init.cfg

    auf

    Code
    1. auto eth0:1
    2. iface eth0:1 inet6 static

    statt

    Code
    1. auto eth0
    2. iface eth0 inet6 static

    steht.


    Leider erhalte ich bei der Änderung der config einen Fehler beim Restart des Netzwerkes und die V6 Adresse wird gar nicht gebootet.

    Der Server ist über Port 80 erreichbar. Ein Reverse Proxy existiert nicht. Die Ports gehen direkt zum Container.

    Die Logs zeigen folgendes:

    Code
    1. 26.5.2019, 00:49:57 Use SKIP_LETS_ENCRYPT=y in mailcow.conf to skip it permanently.
    2. 26.5.2019, 00:49:57 Cannot validate hostnames, skipping Let's Encrypt for 1 hour.
    3. 26.5.2019, 00:49:57 Cannot match your IP NO_IPV6_LINK against hostname mail.domain.tld (IPv6)
    4. 26.5.2019, 00:49:57 Found AAAA record for mail.domain.tld: IPv6 - skipping A record check
    5. 26.5.2019, 00:49:57 Cannot match your IP NO_IPV6_LINK against hostname autodiscover.domain.tld (IPv6)
    6. 26.5.2019, 00:49:57 Found AAAA record for autodiscover.domain.tld: IPv6 - skipping A record check
    7. 26.5.2019, 00:49:53 OK
    8. 26.5.2019, 00:49:05 Detecting IP addresses...
    9. 26.5.2019, 00:49:05 Using existing Lets Encrypt account key /var/lib/acme/acme/account.pem
    10. 26.5.2019, 00:49:05 Using existing domain key /var/lib/acme/acme/key.pem

    werden die Update gezogen, wenn du "rndc retransfer DOMAIN" eingibst?

    hast du auch den SOA angepasst?

    Nein, mittels rndc werden die Updates nicht gezogen. Es kommt aber auch keine Fehlermeldung. Ist es richtig, dass ich den Befehl auf dem Slave ausführe?

    Was meinst du genau mit SOA anpassen? Ich habe nur den ns1 als primären dort stehen.


    darf man fragen, welche Linux Distri hier zur Anwendung kommt?

    sollte es am Slave nicht einen Folder bereits geben, in dem die vom Master empfangenen Zone-Files abgelegt werden?

    SELinux?


    "/etc/bind/..." f. die ZONE-Files kommt mir jetzt etwas seltsam vor ...

    Verwendet wird Debian 9. Ich hatte nur BIND9 als Paket installiert. Fehlt vielleicht eine Erweiterung?

    Das Verzeichnis zones auf dem Slave habe ich bereits manuell angelegt.

    Wo sollten stattdessen die Zone-Files abgelegt werden?

    Hallo,


    ich habe zwei BIND Server. Die named.conf.local sieht so aus:

    Code
    1. zone "domain.tld" IN {
    2. type master;
    3. allow-transfer { X.X.X.X; };
    4. notify yes;
    5. also-notify { X.X.X.X; };
    6. file "/etc/bind/zones/domain.tld";
    7. };

    Die named.conf.local auf dem Slave Server so:

    Code
    1. zone "domain.tld" IN {
    2. type slave;
    3. masters { XX.XX.XX.XX; };
    4. file "/etc/bind/zones/domain.tld";
    5. };

    Wenn ich es richtig verstanden habe, sollte sich jetzt der Slave Server die Zone vom Master ziehen bzw. der Master den Slave über eine Änderung informieren. Leider scheint kein Abgleich stattzufinden.

    Was mache ich falsch? Muss ich neben dem Ordner zones auch noch die Datei domain.tld anlegen?

    Hallo,


    wenn ich keine aktiven Verträge mehr mit netcup habe, folgt dann gleich im Anschluss die Löschnug meines Accounts oder darf ich später wiederkommen? :)

    Hallo,


    welchen Jabber Server könnt ihr empfehlen? Gerne einen der leicht zu konfigurieren ist, wenig Aufwand in der Wartung benötigt und möglichst keine Nachrichtenverlust entstehen.

    Ach so, danke für die Unterstützung. Ich habe mich gewundert, weshalb auch der ZSK (Type 256) bei der Vergabestelle hinterlegt werden kann. Den ZSK zu hinterlegen wäre also Quatsch, es reicht der KSK (Type 257)?

    Hallo,


    wie sieht eure Mailorganisation aus? Ich hatte es mal mit den Ordnern Zu beantworten, bearbeiten, archiv, löschen probiert. Allerdings bin ich da ganz schön durcheinnander gekommen, auch mit den gesendeten Elementen und daraus einen einheitlichen Konservationsverlauf basteln. Gibt es noch andere Möglichkeiten, außer Ordner und Flags?