Posts by TobiasH

    Hallo,


    hannip hast du es mittlerweile gelöst? Ich bin zwar soweit, dass meine Container alle eine IPv6 Adresse erhalten, von außen jedoch nicht erreichbar sind. Mit dem Einsatz von neigh proxy funktioniert es zwar, ich würde es jedoch gerne so lösen wie oliver.g , klappt jedoch nicht.

    Mein Vorgehen:


    Schritt 1: Wie im netcup Wiki beschrieben IPv4+IPv6 für das Netzwerk Interface ens3 einstellen: https://www.netcup-wiki.de/wik…IP_Adresse_konfigurieren: /etc/network/interfaces


    Schritt 2: https://docs.docker.com/engine…ing/default_network/ipv6/


    Da habe ich mich an dem Absatz "Often servers or virtual machines get a /64 IPv6 subnet assigned [...]" orientiert.

    In /etc/docker/daemon.json folgendes eingetragen:


    Code
    1. {
    2. "ipv6": true,
    3. "fixed-cidr-v6": "2a03:4000:6:****:1::/80"
    4. }


    Folgende Befehle ausgeführt (wobei der erste nicht nötigt scheint, setzt Docker auch von selbst - siehe später ; die letzten 2 Befehle sind mittlerweile in /etc/sysctl.d/50-IPv6.confeingetragen):


    Code
    1. $ ip -6 route add 2a03:4000:6:****:1::/80 dev docker0
    2. $ sysctl net.ipv6.conf.default.forwarding=1
    3. $ sysctl net.ipv6.conf.all.forwarding=1


    Alle Docker Container ohne Netzwerk Angabe erhalten eine IPv6 aus dieser Range, z.B. 2a03:4000:6:****:1::2 (2a03:4000:6:****:1::1 hat docker0 als Gateway).



    Lege ich mit docker-compose ( https://docs.docker.com/compos…ipv4_address-ipv6_address ) weitere Container mit einem Netzwerk mit eigenem Subnetz an...


    Code
    1. networks:
    2. mynetwork:
    3. driver: bridge
    4. enable_ipv6: true
    5. ipam:
    6. driver: default
    7. config:
    8. - subnet: 172.20.0.0/24
    9. - subnet: 2a03:4000:6:****:2::/80

    ... erhalten die Container auch eine IP aus dem Subnetz und Docker richtet eine Route ein.



    Die Container sind aber wie schon geschrieben von extern nicht erreichbar. Firewall (iptables 4/6) ist (noch) nicht konfiguriert, lässt also alles durch. (Die Network ID bzw. bridge br-** und interfaces sind dynamisch generiert.)


    Was übersehe ich bzw. hat jemand einen Tipp? Hab schon das ein oder andere erfolglos versucht. oliver.g wie sieht den deine Netzwerkkonfig. (/etc/network/interfaces) aus?

    Schade um Froxlor...... , ich finde es einfach, übersichtlich und nicht so "aufgeblasen" wie andere. Bei anderen Control Panels habe ich das Gefühl, dass man zu viel "vorgeschrieben" bekommt. Bei Froxlor gibt es dagegen nur die Beispielkonfigurationen, an denen man sich orientieren konnte.
    (Aktuell fehlt mir, dass man eine (Sub-)Domain nicht gleichzeitig für IPv4 und IPv6 nutzen kann. Sowie SSL für Subdomains manuell in der Datenbank aktivieren muss, da die entsprechenden Felder in Froxlor fehlen.)


    Es freut mich, das netcup einen Fork starten möchte und bin mal gespannt. :)



    Edit: Wie erhalte ich den für den netcup-Mirror den GPG-Key? Wie im Wiki beschrieben gehts leider nicht mehr und der von dieser Seite geht damit auch nicht.

    Mal ne Frage zur Partitionierung: Partitionierung KVM-Server – netcup Wiki


    Wie komme ich in den "Rettungsmodus"??, ich hab den bisher bei netcup noch nie gebraucht. ^^


    Folgendes hab ich gemacht:
    1. Server ausgeschaltet
    2. Netzwerk an oberste Stelle fürs booten
    3. Rettungssystem gestartet .. weitere - im Wiki-Beitrag erwähnte - Anweisungen blieben aus und deshalb
    4. einfach mal unter Steuerung auf "Starten" geklickt, war wohl falsch....ist "normal" gestartet.
    Kann mir jemand weiterhelfen?



    Achso, kann es sein das rDNS Einstellungen für IPv6 nicht gespeichert werden/bleiben? Ich erhalte die Meldung, dass erfolgreich gespeichert wurde, beim erneuten Aufrufen der Seite im CCP steht jedoch "Für dieses Subnet wurden noch keine rDNS-Einträge angelegt."

    Da KVM, anders wie Linux-VServer keine flexiblen RAM hat

    Hat man dann auch eigene Core/CPU's? Aktuell "teilt" man sich das irgendwie alles und hat keinen festen zugwiesen. :)
    (Ich habe aktuelle nur ein Vergleich mit vServern die mit Hyper-V visualisiert sind und dort find ich das gut.)


    Welche Vorteile/Nachteile hat man da noch? z.B. iptables Nutzung?


    bevor die Migration regulär frei gegeben wird?


    Wie würde so eine Migration ablaufen? Es stand bereits in einem Beitrag, dass eine Neuinstallation nötig ist. Wäre es eventuell auch
    möglich ein selbsterstelltes Backup vom VCP zu verwenden?
    Ansonsten fände ich es gut, wenn man die vServer für z.B. max. 2 Tage parallel laufen lassen könnte, um die Daten zu kopieren. (Dann würde ich das in meinen Semesterferien im Februar machen. ^^ )



    Dann zum CCP zurück: Ich versteh momentan nicht, warum bei mir unter Produkten 1x "Domain" und 1x "Domain - Domains" auftaucht. Ist ersteres die inkl. Domain und dann bei Domains alle anderen? Desweiteren werden im Tab Leistungen Webspace mit 5GB usw. aufgelistet, ist das so gewollt?, aktuell haben die Domains keine eigene Kategorie.

    Mal eine Frage an alle, die eine eu-Domain (vorzugsweise bei netcup) haben:


    Kann es sein, dass bei einer whois Abfrage nur der Technische Admin angezeigt wird und nicht der Inhaber?
    z.B. bei Whois Result | EURid


    Ich hab direkt bei einem Zertifikat-Austeller (kein Reseller) ein SSL-Zertifikat bestellt und er weigert sich, weil anscheinend nur netcup GmbH in der whois Abfrage auftaucht....


    EDIT: Das Problem scheint zu sein, dass netcup als "Onsite" statt "Technical" angezeigt wird, vergleiche: europa.eu
    Interessant ist auch Punkt 2.4 WHOIS-Politik für .eu Domänennamen | EURid


    PS: Ich weiß, dass man Mittlerweile auch bei netcup Zertifikate bekommt, aber ich habe bei dem Anbieter bereits auch für andere Domains (de, usw.) welche .....

    Läuft soweit ganz gut, auch wenn ich bis jetzt nur das Email senden und empfangen getestet hab (Webmail + Smartphone). ^^ Sync mit Kalender und co folgt noch.


    Ich hätte aber schon ein Wunsch:
    Aktuell kann man den Inhabernamen eines Postfaches nur beim Anlegen bestimmen, zumindest ab ich sonst dafür keine Einstellung gefunden. Ich würde es gut finden, wenn man ihn auch später noch bearbeiten kann.


    Edit:

    aber ich hatte grade so nen schönen fall wo eine email angeblich nicht mehr vorhanden war ^^ nachdem ich aber wieder auf "Abrufen" geklickt habe war alles okay.

    Das ist mir auch grad passiert.

    Danke, ... ganz so "einfach" ist das für mich jetzt nicht ^^, aber wenn meine 2te SD-Karte ankommt, werd ich mich mal dran versuchen.


    Edit: Ich glaub die RPi ist so auch schon überfordert. Wobei man die ja auch Übertakten kann, bis auf 1GHz sogar ohne die Garantie zu verlieren, soweit ich weiß. Bräuchte nur etwas mehr Ram. Diesbezüglich wäre das Hackberry interessant. ;)

    killerbees19 Mich würde mal interessieren, wie du das auf deiner RPi umsetzt? ^^


    Meine nutze ich mithilfe von Raspbmc hauptsächlich als Mediacenter, auch für Tvheadend. Nebenbei unter anderem noch als kleinen Webserver (lighttpd + sqlite3). Hatte auch mal ownCloud installiert, aber bleib doch bei bekannten Cloud-Anbietern, alleine wg. der Bandbreite.

    Auf jeden Fall Debian.

    Für die Pi auf jeden fall nicht Fedora

    hmm, also spar ich mir die Zeit und teste Fedora nicht ^^


    Ich frag mich nur, womit bzw. wie die es in den Videos teilweise schaffen (HD-)Videos abzuspielen, mir will das nicht so gelingen.... vltt. hab ich am Wochende nochmal was Zeit zum rumspielen ^^


    Hat hier noch wer ne Pi?

    Ich hab meine Pi (Model B) letzte Woche bekommen. :)


    Nutze momentan Debian, möchte aber auch noch Fedora testen. Mal schauen was besser geeignet ist....

    Ja, hab ich auch bei einem Server, ob das evt. mit den Wartungsarbeiten an einem Node letzte nacht zusammen hängt, dass da das VCP jetzt verrückt spielt. Bei mir steht sogar überall die Meldung "Der vServer ist nicht gestartet." , dabei läuft er ganz normal. ^^


    Bei dem anderen Server stimmts. :)

    Hab die App auch mal installiert.

    Scheint an den viele IPv6 Adressen

    Ja, das (grüne) hab ich auch, eine IPv6 reich schon.


    Dann ist mir noch aufgefallen:

    • die oberste IP wird 2x angezeigt
    • wenn man den Bildschrim (in den Querformat) dreht, dann möchte die "Lade..." Anzeige manchmal nicht mehr aufhören, auch wenn im Hintergrund anscheinend schon alles geladen wurde.
    • startet man direkt im Querformat, dann fehlt eine Möglichkeit zum scrollen (alternativ: Quer-Modus abstellen/verweigern)


    Ansonsten eine nützliche App, Danke :thumbsup:


    PS: Getestet mit SGS2 - Android 2.3.4