Das längste Thema

  • Hey Leute, habe Probleme mit der DNS Api. Ich nutze den Client von linux-inside (https://github.com/linux-insideDE/ncdapi). Login-Daten habe ich natürlich angepasst, leider erhalte ich trotzdem immer nur das:


    Code
    1. root@<hostname>:~/ncdapi# time ./ncdapi.sh -d -g <meine-domain>.de
    2. Login successful
    3. {"serverrequestid":"<blabla>","clientrequestid":"","action":"infoDnsRecords","status":"error","statuscode":4013,"shortmessage":"Validation Error.","lgmessage":"Value in field domainname does not match requirements of type: domainname. ","responsedata":""}
    4. Error: {"serverrequestid":"<blabla>","clientrequestid":"","action":"infoDnsRecords","status":"error","statuscode":4013,"shortmessage":"Validation Err.","longmessage":"Value in field domainname does not match requirements of type: domainname. ","responsedata":""}
    5. Logout successful
    6. real 0m56,482s
    7. user 0m0,076s
    8. sys 0m0,016s

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Hay,

    CmdrXay Dein Screenshot ist ein 404er

    Ich habe keinen 404 und um ganz sicher zu gehen (caching, localer Pfad) habe ich den Thread auch nochmal auf meinem Tab angeschaut. Da geht!

    lol, jetzt, zwei Tage später ist bei mir sowohl auf dem PC wie auch auf dem Tablet (auf dem ich die Seite vorher nie offen hatte) auch nur ein Link mit anschließendem 404 zu sehen. Kann es sein, dass da ein Front-End-Cache oder ein reverse Proxy fürs Forum im Spiel ist?


    CU, Peter

  • Es gab letztens Anpassungen der DNS API. Kann das die Ursache sein?

    Kann sein. Wollte die API heute das erste mal nutzen, vorher hatte ich nur den SCP-Webservice verwendet. Kennt jemanden einen Client, der mit der aktuellen API funktioniert? https://www.netcup-wiki.de/wiki/API_Clients Die sind ja dann wahrscheinlich alle veraltet, wenn die API geändert wurde.


    Eigentlich möchte ich nur die Zone einer bestehenden Domain duplizieren auf eine/mehrere andere Domain(s).

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Hi zusammen,

    mfnalex das Skript funktioniert immer noch. Bei dir tritt nur ein Parsing Error auf, den ich noch abfangen muss. Lass einfach das Debug Flag weg und es kommt zu keinem Fehler mehr.

    Eigentlich möchte ich nur die Zone einer bestehenden Domain duplizieren auf eine/mehrere andere Domain(s).

    Hierfür empfehle ich dir lieber das -b Flag, dass lädt dir die Records + SOA in eine JSON Datei ("backup-DOMAIN.DE-DATUM-UHRZEIT.txt") und für den Restore das -R Flag. Du musst um die Zone auf eine andere Domain zu übertragen in der Datei nur die aktuelle Domain austauschen ("soa.name") und dann den Restore durchführen. Viel Spaß dabei.


    Welche Änderung bei der DNS-API? Habe ich was verpasst?

    Es gab keine grundlegende Änderung bei der API. Vor kurzem sind nur neue RRs hinzugekommen.



    Ein Backup von 10 kleinen Zonen dauerte bei mir gestern rund 30 min. . Sind bei euch die API Requests in letzter Zeit auch viel langsamer geworden?

    Meine Produkte: VPS 1000 Plus | RS 2000 Plus SAS G8 | VPS OsterEi 18 | Webhosting 16 Years | Webhosting Bestprice Classic

  • Oh ja, ohne Debug Flag ging es. Hatte den Debug mode aktiviert, weil mir die Laufzeit sehr lang erschien. Das Backup einer Zone mit nur 3 RR hat über eine Minute gedauert, aber damit kann ich problemlos leben. Vielen Dank für die schnelle Antwort :)

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Gerade mal alte Backups durchgesehen und das NetCup-Installations-Script für die Images gefunden... hat das schon mal jemand entdeckt? Ganz interessant ^^


    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Nach einer fehlgeschlagenen Image-Intallation lagen die mal im /root/-Ordner. Hatte sie natürlich nicht löschen wollen ^^


    Den Inhalt der Skripte zeig ich lieber nicht, habe ja NetCup nicht um Erlaubnis gebeten.


    EDIT: Ach ja: wer die Skripte selbst sehen möchte: ich glaube es reicht, in der Bildschirmkonsole (oder wie das Ding heißt) auf Strg+Alt+Entf zu drücken während "Post-Installation running" da steht. Dann im Rettungssystem /dev/sda mounten.


    EDIT2: In der RTFM steht nur dass man den Ordner nicht verschieben soll :)

    Code
    1. root@*:~/ncImageEngine# cat RTFM
    2. #dmt = dont move this!

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Hallo,
    ich habe das VLAN bei mir eingerichtet. Auf rootserver und vServer gleich (entsprechend nur das Interface angepasst).

    Allerdings kommt beim vServer eine Route mit, die ich mir nicht erklären kann:

    46.0.0.0/8 dev ens6 proto kernel scope link src 46.38.243.234


    grep findet in /etc/* zu der Gateway-IP nichts. Allerdings blockiert die Route den Zugriff des Servers ins Netz (bzw auf den repository server). Mit heruntergefahrenem ens6 funktioniert es logischerweise.

    Hat da jemand eine Idee, wo so eine Route herkommen kann? Ist ein Debian Stretch

  • Hast du das interne Subnetz auf dein externes Interface gelegt? ens6 ist doch normalerweise die externe NIC (so ist es zumindest bei meinen Servern).

  • ens6 ist bei mir die NIC für das VLAN, ens3 ist die NIC ins Internet.


    Auf ens3 habe ich nur das IPv6 Netz und die IPv4-Adresse,

    auf ens6 eine Adresse aus dem 10-er Netz:


    Code
    1. auto ens6
    2. iface ens6 inet static
    3. address 10.XYZ
    4. netmask 255.XYZ
    5. broadcast 10.XYZ

    ... ist alles zu ens6 aus der /etc/network/interfaces


    Gleiches funktioniert (mit eth statt ens, ohne komische route) beim rootserver.