Server-Antwortzeit Webhosting 8000

  • Guten Tag Frank,



    ich habe Ihre Website eben aufgerufen. Das scheint an einer Art Endlosschleife in Ihren Scripten zu liegen. Andere Webistes auf dem Node funktionieren problemlos.


    Wenn sie unseren Support angeschrieben haben, prüft das das aber nochmals intensiv. Ich bin mir aber sehr sicher, dass nur Sie das Problem lösen können.



    Mit freundlichen Grüßen


    Felix Preuß

  • Ich mache meine Daten auch mal zugänglich - RS 1000 SSD G7SE:



    Code
    1. Laufzeit gesamt: 2004ms pro Zyklus(Schnitt): 0.133600ms
  • Hallo,

    die Seite / die Serverantwort laden bei mir in unter einer Sekunde. Was mein Laptop (Lenovoo Ideapad) mit Lubuntu sehr zum ruckeln bringt sind die ganzen Einblend-Effekte, wo Inhalte und Bilder (zB: Block REFERENZEN) geladen werden.

  • Ich möchte hier auch meine Ergebnisse Teilen:


    Code
    1. Standard C 2018: Laufzeit gesamt: 40388ms pro Zyklus(Schnitt): 2.692533ms
    2. Webhosting Spezial Ostern 2018: Laufzeit gesamt: 1482ms pro Zyklus(Schnitt): 0.098800ms
    3. Standard M: gesamt: 5652ms pro Zyklus(Schnitt): 0.376800ms (Alter Tarif von 2014)

    Der Standard C 2018 Tarif ist mit Abstand der langsamste von mir, obwohl es ein neuer SSD Tarif ist. der Standard M ist von 2014 und die PHP-Version ist noch 5.3, die beiden neuen Tarife laufen mit PHP7-FPM.


    Ich denke ich sollte mich mit dem Standard C 2018 Ergebnis wohl beim Support melden. :)

  • Bei den Webhostingtarifen hat man ja keine exklusiven cores, oder? Daher können die Ergebnisse schwanken, je nachdem, ob gerade der Server ausgelastet ist, oder nicht.


    Das war auch der Hauptgrund, warum ich zu einem rootserver wechselte.


    Also am besten die Benchmarks zu unterschiedlichen Tageszeiten mehrfach machen und die Ergebnisse mitteln.

  • Bei den Webhostingtarifen hat man ja keine exklusiven cores, oder? Daher können die Ergebnisse schwanken, je nachdem, ob gerade der Server ausgelastet ist, oder nicht.


    Das war auch der Hauptgrund, warum ich zu einem rootserver wechselte.


    Also am besten die Benchmarks zu unterschiedlichen Tageszeiten mehrfach machen und die Ergebnisse mitteln.

    Meines Wissens nach hat man keine exklusiven Cores. Aber ich hatte mit meinen kleinen privaten Seiten und einem kleinen SMF-Forum nie Probleme mit der Performance bei Netcup. Erst der Umstieg auf den Standard-C Tarif mittels Soft-Migration hat erste Performanceprobleme bei mir aufgezeigt. Das es auch anders läuft beim Plesk-Onyx-Hosting habe ich jetzt erst erfahren durch das Oster-Spezial Hosting. Auf dem Papier deutlich kleiner ist doch die I/O-Performance bei dem Benchmark Script 27x schneller als beim Standard C Traif.


    Ich habe mich jetzt an den Support gewendet und hoffe das der Standard C Tarif bald besser läuft. :)


    EDIT: Wegen schwankend: Die Performance bleibt auch bei mehreren Tests vergleichbar mit den oberen Zahlen. Hab es natürlich mehrfach in Abständen laufen lassen.

  • Kannst ja die Tests Ende der Woche wieder durchführen und dann schauen wie es um die Performance steht, die Umstellung dauert noch an und dein Account ist wohl noch nicht auf die "neue" Speicherlösung umgestellt worden;)

    Den Post vom Herrn Preuß hatte ich ganz übersehen. Dann Ende der Woche nochmal. :)

  • Ich möchte an dieser Stelle eine kurze Wasserstandsmeldung geben: Leider konnten noch nicht alle Server umgestellt werden. Wir arbeiten weiterhin mit Hochdruck an der Thematik und sind zuversichtlich bis Mitte nächster Woche diese Thematik abgeschlossen zu haben.

  • Was ist eigentlich momentan mit dem Hosting los, ich bin auf solch einem "langsamen" NAS und ich bekomme permanent "504 Gateway Time-out" bei meinem Wordpress Blog. Der Blog ist eine einfache Seite, keine großen Plugins, nicht viel Content, also nichts besonderes.


    Aktuell ist die Uptime schon nur innerhalb der letzten 30 Tage unter 99,4% gesunken (laut externem Monitoring). Alle Downtimes, sofern ich sie mitbekommen habe, konnte ich auch im Browser selbst nachvollziehen (504er HTTP Status Code meistens)

  • Oh scheint wohl doch am Umzug gelegen zu haben, hab die ganze Zeit nach jeder längeren Downtime den IO-Test gemacht und ich war immer über 2ms pro Zyklus, jetzt bin ich immer unter 0.2ms, meist sogar im Bereich 0,1ms.


    Damit hat sich das ganze jetzt hoffentlich erledigt :)


    Die Wordpress Seite generiert jetzt auch in unter 0,2 Sekunden, eigentlich fast immer in unter 0,15 Sekunden (gemessen mit dem Wordpress Query Monitor Plugin). Vorher lag der Wert mindestens beim doppelten, also war es die Downtimes doch Wert, hätte ich nur einmal mehr darüber hinwegsehen müssen :saint::thumbup:

  • Ich möchte auch nochmal aktuellere Daten zur Verfügung stellen:


    RS 1000 G7 SE SSD (2018):

    Code
    1. Laufzeit gesamt: 1520ms pro Zyklus(Schnitt): 0.101333ms
    Code
    1. PHP version : 7.1.15-1
    2. Platform : Linux
    3. --------------------------------------
    4. test_math : 0.261 sec.
    5. test_stringmanipulation : 0.366 sec.
    6. test_loops : 0.234 sec.
    7. test_ifelse : 0.160 sec.
    8. --------------------------------------
    9. Total time: : 1.021 sec.

    RS 2000 G7 SE SAS (2017):

    Code
    1. Laufzeit gesamt: 1740ms pro Zyklus(Schnitt): 0.116000ms
    Code
    1. PHP version : 7.1.15-1
    2. Platform : Linux
    3. --------------------------------------
    4. test_math : 0.258 sec.
    5. test_stringmanipulation : 0.364 sec.
    6. test_loops : 0.236 sec.
    7. test_ifelse : 0.159 sec.
    8. --------------------------------------
    9. Total time: : 1.017 sec.


    Beide nutzen exakt die gleiche Konfiguration. Gleich zweimal bin ich verwundert:

    1. PHP-Bench

    Hätte ich mit mehr Unterschied gerechnet.

    2. IO-Bench

    Hier hätte ich definitiv mit mehr Unterschied gerechnet. Die SSD Tarife werden doch hier immer als "DIE WAFFE" verkauft.


    Und weil ich schonmal am Schreiben bin: Ich habe aktuell oft Probleme mit der Netzwerkgeschwindigkeit. Am Anfang meiner Tariflaufzeit war ich im Schnitt immer bei 450-750 MBit/s im Down- und Upload. Jetzt kann ich froh sein, wenn beim speedtest-cli die 300 MBit/s mal geknackt werden. In den meisten Tests hänge ich bei 130-200 MBit/s herum. Den Support interessiert es nicht. Die üblichen Ausreden wie immer, Rettungssystem...bla bla bla... Das beste war der Hinweis zur dedizierten NIC 1 GBit/s - für knapp 36 € pro Monat :D:wacko::thumbdown:


    Am Anfang war ich echt zufrieden mit dem Gesamtpaket "netcup". Aber die Fassade bröckelt ganz schön... das musste ich mal loswerden.

  • Tobias992 Dass es keinen Unterschied in PHP-Bench gibt ist klar, die CPUs sind die gleichen - egal ob SSD oder SATA.

    Außerdem wird nur ein Core genutzt.


    Dass das IO auch nicht viel schneller ist liegt simpel daran dass der Test ordentlich im Cache des Betriebssystems landet.

    Um das zu verhindern müsste der Test deutlich komplizierter sein.

    (Bei bonnie++ ist wohl die Empfehlung mindestens die doppelte RAM Größe an Dateien zu schreiben)

  • Ich möchte auch nochmal aktuellere Daten zur Verfügung stellen:

    Aber das hat doch gar nichts mit dem Thema hier zu tun, du liegst doch nicht auf den betroffenen "langsamen" SAN und deine Speichertechnologie wurde auch nicht verändert :/

    Jetzt kann ich froh sein, wenn beim speedtest-cli die 300 MBit/s mal geknackt werden. In den meisten Tests hänge ich bei 130-200 MBit/s herum.

    "durchschnittlich" 200 MBit/s werden garantiert, oftmals hat man aber mehr zur Verfügung. Die Frage ist halt wie aussagekräftig ein einzelner Speedtest zu einer einzelnen Gegenstelle ist.

  • Aber das hat doch gar nichts mit dem Thema hier zu tun, du liegst doch nicht auf den betroffenen "langsamen" SAN und deine Speichertechnologie wurde auch nicht verändert

    Irgendwie hatte hier "jeder" seine Daten reingestellt und ich dachte "ich mach einfach mal mit" :D



    "durchschnittlich" 200 MBit/s werden garantiert, oftmals hat man aber mehr zur Verfügung.

    Also ich kann da auch nur von meinen Servern sprechen. Wenn ich teilweise ein 50 MB Backup von Wordpress herunterlade, wird mir der Downloadspeed oft nur in kb/s angezeigt.

    Ich habe ja auch nur festgestellt, das zu Vertragsbeginn alles Super war und jetzt so langsam sich hier und da ein kleiner Haken aufkommt.

  • Auch unsere Website läuft auf einem Webhosting 8000 Tarif. Seit vorgestern ist die Antwortzeit des Servers plötzlich dramatisch in die Höhe gegangen. Teilweise über 10 Sekunden.


    Nachfolgend die Testergebnisse aus den Benchmarks, die unsere subjektive Empfindung beim Aufruf der Website deutlich wiederspiegelt.


    Auf Nachfrage beim Netcup-Support wurde uns sinngemäß mitgeteilt, dass wir beim Webhosting-Tarif mit diesen Schwankungen leben müssen und auf einen Managed-Server wechseln können.


    Natürlich bin ich mir bewusst, dass wir auf einem Shared-Server mit Schwankungen leben müssen. Ist es aber nicht so, dass man auch beim Webhosting von einer gewissen Mindest-Performance ausgehend darf?

  • Nein leider ist das nicht der Fall, es werden ja nur Grenzewerte angegeben, wie z.B. PHP Memory, aber keine Zugriffszeiten geschweige dedizierte Cores. Leider, habe das selber feststellen müssen das teilweise 3 Sekunden reine Antwortzeit des Servers war (natürlich schwankend). Ich habe dann leider Konsequenzen ziehen müssen, da das nicht hinnehmbar war. Wichtig ist aber auch den Preis des Webhosting in Relation zur Leistung zu sehen.

  • @Vicman : Sie haben bei uns mit die billigsten Webhosting-Tarife (weniger als 20 Cent / Monat Kosten) gebucht in denen wir zum Teil bewusst geringere Leistungen ausgewiesen haben. Ich sehe in Ihrem hinterlegten Kundenaccount keinen Webhosting 8000 Tarif. Beziehen Sie sich eventuell auf einen anderen Kundenaccount?


    Ab dem Webhosting 2000 können Sie bei uns sogar von garantierten RAM profitieren. Ich denke bei Ihren Ansprüchen empfiehlt sich zumindest ein Wechsel in einen regulären Tarif.


    Mit freundlichen Grüßen


    Felix Preuß