Forum: Autologin/Passwortspeicherung

  • Hi,


    ich nutze für Foren normalerweise die in Chromium eingebaute Speicherfunktion für Passwörter. Das hat bis vor Kurzem auch immer perfekt geklappt. Dann habe ich einmal eine komplette Bereinigung gemacht und alle gespeicherten Passwörter gelöscht. Seitdem bietet mit der Browser keine Möglichkeit mehr es abzuspeichern, sobald ich mich erfolgreich eingeloggt habe.


    Da es auf allen anderen Websites nach wie vor funktioniert, vermute ich stark, dass es mit der hier eingesetzten Forensoftware zusammenhängt. Kann das irgendeiner der anderen User bestätigen? Mein System ist Xubuntu 14.04 mit aktuellster Chromium-Version 39. Ein im Internet gefundenes Codeschnipsel als Bookmark bringt leider auch nichts:


    Code
    1. javascript:(function(){var ca,cea,cs,df,dfe,i,j,x,y;function n(i,what){return i+" "+what+((i==1)?"":"s")}ca=cea=cs=0;df=document.forms;for(i=0;i<df.length;++i){x=df[i];dfe=x.elements;if(x.onsubmit){x.onsubmit="";++cs;}if(x.attributes["autocomplete"]){x.attributes["autocomplete"].value="on";++ca;}for(j=0;j<dfe.length;++j){y=dfe[j];if(y.attributes["autocomplete"]){y.attributes["autocomplete"].value="on";++cea;}}}alert("Removed autocomplete=off from "+n(ca,"form")+" and from "+n(cea,"form element")+", and removed onsubmit from "+n(cs,"form")+". After you type your password and submit the form, the browser will offer to remember your password.")})();



    MfG Christian

  • Da es auf allen anderen Websites nach wie vor funktioniert, vermute ich stark, dass es mit der hier eingesetzten Forensoftware zusammenhängt. Kann das irgendeiner der anderen User bestätigen?


    Die Forensoftware speichert deine Cookies nicht ab, die werden nur bei dir selber im Browser gespeichert.
    Du schreibst ja auch selber dass dieses Problem erst dann entstanden ist, also du bei dir dein Browser bereinigt hast.


    Ein ähnliches Problem hatte ich mal mit FireFox und hier fragte mich der Browser nach einer Löschung nicht mehr ob gespeichert werden sollte. Das lang daran dass der Browser irgendwo ein Vermerkt hatte dass das Passowort schon gespeichert war und daher nicht mehr nachfragte. Für den FireFox gibt es aber ein Add-on(Saved Password Editor 2.8.1) um gespeicherte Passwörter zu bearbeiten oder neue hinzufügen zu können.


    Gruß Coolman

  • Mir ist der Unterschied zwischen dem Autologin (mittels Cookie) und der Passwortspeicherung (vom Client) durchaus bekannt. Ich habe nur den Threadtitel eventuell missverständlich gewählt… ;)


    Und Nein, es gibt keine Ausnahmeregel. Die habe ich damals alle mitgelöscht und dort steht kein *netcup* Eintrag. Die Forensoftware kann afaik aber die Passwortspeicherung versuchen zu umgehen. Zuletzt abgespeichert wurde es vor 1-2 Jahren, danach wurde es ja immer nur automatisch ausgefüllt. Von daher hatte ich den Verdacht, dass da eventuell durch irgendein Update etwas geändert wurde, da es überall anders funktioniert.


    Der reine Cookie-basierte Autologin ist deshalb unpraktisch, da ich oft verschiedene Geräte nutze und es somit überall machen müsste. Hinzu kommt, dass ich dann überall eine Cookie-Ausnahme für *netcup* bräuchte, da Cookies bei mir mit dem Schließen des Browser komplett gelöscht werden. Deshalb nutze ich lieber die andere Methode mit der Passwortspeicherung.



    MfG Christian

  • Und Nein, es gibt keine Ausnahmeregel. Die habe ich damals alle mitgelöscht und dort steht kein *netcup* Eintrag. Die Forensoftware kann afaik aber die Passwortspeicherung versuchen zu umgehen. Zuletzt abgespeichert wurde es vor 1-2 Jahren, danach wurde es ja immer nur automatisch ausgefüllt. Von daher hatte ich den Verdacht, dass da eventuell durch irgendein Update etwas geändert wurde, da es überall anders funktioniert.


    Ein Update wäre schwer vorstellbar, da die Version 3.1 nicht mehr weiter entwickelt wird.
    Aktuell ist das WBB4.0 und zur Zeit wird sehr stark auf die neue Version 4.1 gearbeitet.


    Und egal mit welcher Version die Woltlab Forensoftware betrieben wird, hat die Forensoftware mit der Speicherung des Passwortes nichts zu tun, sondern nur mit der Speicherung einer Session damit man beim Besuch des Forum nicht ständig aus geloggt wird. Dein Problem liegt daher bei dir und nicht an am Forum.


    Kenne diese Forensoftware seit es sie gibt und betreibe selber ein Support Forum was sich speziell mit der Forensoftware Woltlab und Server bezieht.
    Versuche mal den Caches und die Cookies mal zu löschen, vielleicht bringt dass was.

  • Der Cache ist nicht permanent und die Cookies werden (wie bereits geschrieben…) beim Schließend es Browsers sowieso gelöscht ;)


    Trotzdem kann man explizit verbieten, dass es der Browser anbieten soll ... http://aktuell.de.selfhtml.org/artikel/html/autocomplete/


    Danke! Oder auch durch zufällige Feldnamen im Formular. Die Liste ist beliebig erweiterbar…



    MfG Christian