DNS Problem

  • Guten Tag,


    Wir haben bei Netcup einen Vserver und eine Domain gebucht. Und wir haben jetzt versucht unsere IP über diese Domain laufen zu lassen und zu erreichen. Das klappte jedoch nicht so ganz. Wir haben jetzt einige Zeit gewartet und auch nochmal alles kontrolliert aber die Seite die wir zum Test erstellt haben ist über die IP erreichbar aber nicht über die Domain. Wir haben dann versucht die Domain anzupingen und haben zu unserer Verwunderung auch eine Response bekommen. Bitte um hilfe.

  • Hallo, ein paar grundlegende Dinge über DNS sind hier zusammengefasst:

    https://grundsoli.de/dns-transfer-cheat-sheet/


    Auch, wenn es hier nicht um einen Transfer geht, kann das vielleicht helfen.


    Häufige gemachte Fehler im DNS wären etwa, das man den gesamten Domainnamen anstelle nur eines Hostnamens einträgt.

    Verwechslungen, wann ein A, AAAA oder CNAME Eintrag zu machen sind, passieren auch oft. Eine Domain etwa darf keinen CNAME enthalten - nur ein Hostname unterhalb der Domain.


    Das mit der Wartezeit hängt auch von vielen Faktoren ab. Die in der Zone eingestellte Time to Live ist nur eine davon.


    Wenn es dann noch um den Webserver geht, muss der Webserver auch wissen, dass er für den Hostnamen zuständig ist.


    Also, was die Fehlerbeschreibung anbelangt, kannst Du gerne noch ein paar Daten liefern. Meine wahrsagerischen Fähigkeiten, wie auch die unserer Mitposter werden beizeiten überschätzt ;)

  • Bei den spärlichen Infos ist es schwierig gescheit zu helfen. Um nun keinen Roman mit allen nur erdenklichen Fehlern zu schreiben, hier mal weitere hilfreiche Links:


    Netcup-Wiki DNS: https://www.netcup-wiki.de/wiki/Domains_CCP

    DNS Checker: https://dnschecker.org/ (<- wie sieht das Ergebnis eurer Domain da aus?)


    ggf. nennst du uns auch einfach mal die Domain und/oder zeigst ein Screenshot eurer DNS-Einstellungen.


    Edit: stimmt denn die IP-Adresse bei eurem Ping? Dann wäre ein DNS-Problem komplett auszuschließen und es geht eher Richtung Konfiguration Webserver.

  • In die Spalte Host gehört nur der Subdomainteil und nicht die Domain. Wenn Du dort www.path-of-novus.de einträgst, gilt der Eintrag für www.path-of-novus.de.path-of-novus.de. Also bitte in diesem Fall nur "www" eintragen. Wenn es für die Domain selbst gelten soll, wird ein "@" verwendet.


    Bitte beachte, dass es 24-48 Stunden dauern kann, bis die DNS-Caches aller beteiligten Resolver in der Kette abgelaufen und Deine Änderungen bekannt sind.

  • In die Spalte Host gehört nur der Subdomainteil und nicht die Domain. Wenn Du dort www.path-of-novus.de einträgst, gilt der Eintrag für www.path-of-novus.de.path-of-novus.de. Also bitte in diesem Fall nur "www" eintragen. Wenn es für die Domain selbst gelten soll, wird ein "@" verwendet.

    Das verstehe ich nicht so ganz,das müsstest du mir nochmal erklären?


    Den Dnschecker habe ich ausprobiert und das klappt alles. Dennoch kommt man mit path-of-novus.de nicht auf die gewünschte Adresse sondern in meinem falle nur auf die Seite "Domain ist geparkt"

  • Das verstehe ich nicht so ganz,das müsstest du mir nochmal erklären?

    Ich finde KB19 hat die Problematik und deren Lösung schon sehr gut & ausführlich beschrieben.


    Was genau verstehst du denn nicht?


    Zudem ist der Tipp von DerRené ins netcup-wiki zu schauen definitiv nicht verkehrt. Erklärung inkl. Beispielen zu deinem Thema findest du speziell unter dem Punkt DNS.


    Dennoch kommt man mit path-of-novus.de nicht auf die gewünschte Adresse sondern in meinem falle nur auf die Seite "Domain ist geparkt"

    Browser/Router Cache leeren.

  • B. Es wird automatisch die Domain angehängt.

    Wenn du www einträgst, wird www.path-of-novus.de draus. Weil du www.path-of-novus.de eingetragen hast, wurde www.path-of-novus.de.path-of-novus.de

    draus.


    Das ist bei den meisten DNS Anbietern so, aber nicht bei allen.

    CentOS 7 / nginx / php-fpm / postfix / rspamd / clamav / dovecot / nextcloud running on RS 1000 SSDx4 G8 / VPS 500 G8 / VPS 2000 G8 Plus

  • Häufige gemachte Fehler im DNS wären etwa, das man den gesamten Domainnamen anstelle nur eines Hostnamens einträgt.

    B. Es wird automatisch die Domain angehängt.

    Wenn du www einträgst, wird http://www.path-of-novus.de draus. Weil du http://www.path-of-novus.de eingetragen hast, wurde http://www.path-of-novus.de.path-of-novus.de

    draus.

    In die Spalte Host gehört nur der Subdomainteil und nicht die Domain. Wenn Du dort http://www.path-of-novus.de einträgst, gilt der Eintrag für http://www.path-of-novus.de.path-of-novus.de. Also bitte in diesem Fall nur "www" eintragen. Wenn es für die Domain selbst gelten soll, wird ein "@" verwendet.

    Schön, wenn man sich so einig ist ;)

    Ventus Problem beseitigt? Alles Klärchen?

  • Schön, wenn man sich so einig ist ;)

    Ventus Problem beseitigt? Alles Klärchen?

    In Ordnung. Das mit dem WWW habe ich verstanden, wieso man auf http://www.path-of-novus.de.path-of-novus.de/ kommt aber nicht auf den normalen WWW Link. Aber wieso komme ich nicht drauf ohne das www davor? Das sollte doch richtig eingetragen sein oder nicht?

    Und nun, selbst wenn ich draufkomme und zB auf unser Wiki gehe, kommt wieder die IP anstelle der Domain. Muss ich da was mit vhost machen oder so?

  • Das sollte doch richtig eingetragen sein oder nicht?

    Auf deinem Screenshot oben ist es jedenfalls falsch, wie dir schon mehrfach gesagt wurde. Hast du denn mittlerweile Änderungen vorgenommen? Wenn ja, zeig uns diese bitte, sodass man gezielt helfen kann.


    Hat es einen besonderen Grund, wieso ihr auf einen Server setzt statt auf ein Webhosting?

  • Hat es einen besonderen Grund, wieso ihr auf einen Server setzt statt auf ein Webhosting?

    Gute Frage, es scheint ja doch ein wenig Verwirrung zu herrschen. Habt ihr denn den Server wenigstens erst mal abgesichert? Wenn ihr das vorinstallierte Image benutzt oder ein anderes von netcup angebotenes Image installiert ohne weitere Absicherung, dann ist das ziemlich gefährlich.

  • netcup handelt sicherlich nicht fahrlässig und liefert gefährliche Images aus. Die Images haben halt nur eine Basisabsicherung die man auf jeden Fall seinen Bedürfnissen anpassen muss/sollte.

  • Ein Ubuntu Minimalimage ist zunächst mal sicher.

    Was sollte denn da auch groß passieren?

    Der einzige Benutzer ist root und das vorgegebene Passwort ist wohl kaum zu finden.

    Es laufen auch noch keinerlei Dienste, die unsicher oder von außen angreifbar wären.

    Wie sollte da jemals jemand reinkommen?

    Unsicher wird es erst, wenn der Benutzer anfängt loszulegen. ;)

    Klar, spätestens wenn man dann einen Webserver aufsetzt (was ja mit einem einzigen Befehl geht) sollte man sich über die Absicherung Gedanken machen.

  • Ja, aber:

    • SSH-Login als root per Passwort möglich, wenn auch per Default mit einem relativ sicheren Passwort
    • Seit Erstellung des Image naturgemäß keine Updates enthalten für OS, Webserver etc
    • Firewall lässt per Default auch erst mal alles durch, wenn ich das recht in Erinnerung habe

    Zuallermindest das sollte man wohl schon erst mal beheben.

  • Kann man mittlerweile wählen, welches Image am Anfang draufgespielt wird? Hmm, nach kurzer Recherche auf der netcup-Seite:

    Quote

    Die Softwareausstattung der vServer

    Die vServer werden mit einem fertigen LAMP-System und Froxlor ausgeliefert. Das System wird mit den aktuellsten, stabilen Softwareversionen ausgeliefert und wurde von uns auf Fehler überprüft. Ein bei uns bezogener vServer ist also sofort startbereit für den Einsatz als Webserver.

    Wenn da ein wirklich aktuelles System aufgespielt wird mit allen wichtigen Updates, dann meinetwegen ok. Trotzdem ist das dann alles andere als ein Minimalsystem und sollte zuallermindest regelmäßig mit Updates versorgt werden. Und nicht umsonst ist Root-Zugang per SSH mit Passwort offenbar für alle "Experten" (ich kann es im Einzelfall nicht einschätzen) nicht gut. Spätestens wenn man das Root-Passwort auf den Namen des jüngsten Kindes abgeändert hat, sollte man anfangen sich Sorgen zu machen. Besser schon vorher ;).

  • Auf deinem Screenshot oben ist es jedenfalls falsch, wie dir schon mehrfach gesagt wurde. Hast du denn mittlerweile Änderungen vorgenommen? Wenn ja, zeig uns diese bitte, sodass man gezielt helfen kann.


    Hat es einen besonderen Grund, wieso ihr auf einen Server setzt statt auf ein Webhosting?

    Webhosting wären nur zusätzliche Kosten, die wir momentan nicht zahlen wollen. Ändernungen habe ich vorgenommen. Jetzt ist komischerweise die Seite nicht mehr aufrufbar. Wie ich aber nur path-of-novus.de hinbekomme weiß ich immernoch nicht, da ja sobald ich etwas eingegebe das anscheined eine Subdomain wird. www. zeigt halt Apache2 fehler.