Weiterleitung über DNS einrichten

  • Hallo,


    Ich habe bei netcup die domain twin-wheels.de gekauft und will dass beim Aufruf dieser domain an die domain twinwheels.tk
    weitergeleitet wird. Dort ist meine Homepage...


    Deshalb habe ich im CCP unter DNS beim host www unter dem Typ CNAME die Zieldomain eingetragen und auch beim host * unter dem Typ CNAME die selbe Zieldomain, aber es funktioniert nicht.
    Ich werde immer auf die Startseite von dot-tk weitergeleitet. ( also auf Dot TK – Free Domains for All ) :-(
    Wo ist mein Denkfehler bzw. was läuft falsch?
    kennt sich jemand aus und hat mir nen Tipp? Ich dachte, ich müsste nur
    unter CNAME das Ziel der Weiterleitung eingeben...
    Ich habe bei netcup kein Hostingpaket!

  • URL records sind kein Standard.
    DNS macht nichts anderes als Namen zu IP-Adressen übersetzen.
    Wenn du einen CNAME record erstellst, wird die Domain zwar auf den Webserver geleitet, aber der hat keine Ahnung was er damit anfangen soll.


    Zusätzlich zu dem CNAME musst du auch noch bei einem Hoster einstellen, dass du die neue Domain zusätzlich verwenden willst.

    Current Servers

    morpheus: Root-Server M SSD v6a2
    apoc: VPS 50 G7
    link: Storage-Server S 1000 G7

  • Ja, aber auf der Seite von netcup kannst du nix machen.
    Die Domain zeigt ja korrekt auf den Server von dot.tk.
    Sofern es auf Seite von dot.tk keine Möglichkeit gibt, diese zusätzliche Domain anzumelden, kannst du nicht wirklich viel machen.


    Begründung:
    Auf dem Server liegen ja vermutlich diverse Webseiten. Der Browser schickt aber den Namen mit, den er haben möchte. Danach schaut dann der Webserver in seiner Datenbank nach und liefert die korrekte Webseite an den Besucher aus. Wenn jetzt einfach eine "neue" Domain auf den Server zeigt, hat der natürlich keine Ahnung welche der vielen Seiten er ausliefern soll.

    Current Servers

    morpheus: Root-Server M SSD v6a2
    apoc: VPS 50 G7
    link: Storage-Server S 1000 G7

  • Hallo,

    ich wärme hier vielleicht einen uralten Thread auf, aber ich habe ein passendes Problem:

    ich habe bei netcup eine domäne gekauft und möchte auf google hosting service verweisen.

    Eintrag:

    http://www.mydomain.eu CNAME ghs.googlehosted.com

    info.mydomain.eu CNAME ghs.googlehosted.com


    wenn ich den Eintrag kontrolliere, z.B. https://www.heise.de/netze/tools/dns/


    liefert http://www.mydomain.eu KEIN ERGEBNIS

    dafür aber http://www.mydomain.eu.mydomain.eu das "korrekte" Ergebnis.

    Der naheliegende Eintrag

    www CNAME ghs.googlehosted.com

    liefert einen Fehler ("gültig" = no) im CCP.


    Bitte um Unterstützung !


    Bernd

  • Punkt. Es fehlt ein Punkt - respektive ist eine Domain zuviel.


    Wenn man in Zonefiles einen Hostnamen einträgt, der nicht auf „.“ endet, wird die Domain (=$ORIGIN) angehängt.

    Die meisten Web-Zoneneditoren hängen diesen Punkt von sich aus an, zeigen ihn aber nicht an, sondern hängen die Domain einfach dran.


    Daraus resultieren Fehlbedienungen:

    User tragen dann gerne einmal den gesamten Hostnamen samt Domain ein (FQDN).


    Möchte man auf die Domain selbst verweisen nimmt man „@“:

    pasted-from-clipboard.png


    Möchte man den www-Eintrag erstellen lautet dieser „www“:


    pasted-from-clipboard.png


    Das, was Du beschrieben hast würde in einem „echten“ Zonefile nicht so aussehen:

    www.mydomain.eu CNAME ghs.googlehosted.com


    sondern so:

    www.mydomain.eu. CNAME ghs.googlehosted.com.


    oder so:

    www CNAME ghs.googlehosted.com.


    Der Web-Editor verschluckt die Punkte also bleibt nur die Kurzform:


    www CNAME ghs.googlehosted.com


    Punkt.

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • Hay,

    sondern so:

    http://www.mydomain.eu. CNAME ghs.googlehosted.com.

    die verdammten "externe-link-symbole" verbergen fast komplett das wichtigste und der sprachlich korrekte Ausdruck könnten zu Verwirrungen führen :D


    http://www.mydoman.eu. CNAME ghs.googlehosted.com

    der rote Punkt ist hier das wichtigste, während der Punkt, der dann oben bei eripek hinter googlehosted.com steht, nur ein Satzzeichen ist.


    CU, Peter

  • die verdammten "externe-link-symbole" verbergen fast komplett das wichtigste und der sprachlich korrekte Ausdruck könnten zu Verwirrungen führen

    Ich wollte die Formatierung eh ausbessern - aber wir wissen ja, wie das mit dem Zeitablauf und den Postings hier ist: „Sie haben nicht die notwendigen Rechte, um ... “

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • Hallo,


    vielen Dank für die Hilfe!


    Ich antworte auf meine eigene Frage, weil ich die Lösung zum Problem

    Der naheliegende Eintrag

    www CNAME ghs.googlehosted.com

    liefert einen Fehler ("gültig" = no) im CCP.


    gefunden habe (nachdem ich mit dem "Punkt" experimentiert habe):


    Der Eintrag "www CNAME ..." MUSS DER EINZIGE EINTRAG sein - und ich hatte
    (wegen Google-Site-Authentication) noch einen Eintrag "www TXT ..." in meiner

    Konfiguration. Das ist nicht erlaubt.

    Jetzt funktioniert es :)


    Vielen Dank an alle!


    LG Pythonstuff

  • Der Eintrag "www CNAME ..." MUSS DER EINZIGE EINTRAG sein - und ich hatte
    (wegen Google-Site-Authentication) noch einen Eintrag "www TXT ..." in meiner

    Konfiguration. Das ist nicht erlaubt.

    Für die Google-Site-Auth kannst Du ja wohl auch einen „@“ TXT eintragen, oder?

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░