man. PS 2000 php5-Support

  • Hallo,
    für einen Kunden benötigen wir einen Server mit php5.6-Support. Wird dies auf neu bestellten Managed-Servern (man. PS 2000) noch unterstützt und falls ja, wie lange noch? Es handelt sich um ein älteres Projekt, welches nicht kurzfristig auf php7 umgestellt werden kann.

  • Bei so was solltest du netcup direkt fragen. Das hier ist ein Kunden-helfen-Kunden - Forum.


    Die Antwort ist ja. Man bekommt auf Anfrage noch alte PHP-Versionen bereitgestellt. Die Begründung PHP-Migration reicht vollkommen aus.

  • Nachdem ich sogar im Shared Hosting noch Versionen bis zurück zu 5.3.29 auswählen kann - und natürlich auch PHP 5.6 (5.6.33 und 5.6.40), sollte das doch eigentlich auf einem Managed Server kein Problem darstellen.

  • Falls es noch jemanden interessiert: Antwort vom Support war, dass bei neuen Servern Debian 10 eingesetzt wird und dieses php5.6 nicht mehr unterstützt und auch nicht nachinstalliert werden kann.

  • Folgende Mail habe ich zum managed Server vor kurzem bekommen:

  • Oha, da wäre natürlich dann interessant, was denn die nur angedeuteten technischen Einschränkungen bei der noch weiterhin zur Verfügung gestellten Version PHP 5.6 sein werden und wie lange die noch mindestens zur Verfügung stehen wird. Aber auch das ist eine Frrage, die wohl nur netcup beantworten kann.


    Unabhängig davon sollten ältere Projekte sowieso (aller)spätestens jetzt überarbeitet werden im Hinblick auf PHP 7 Kompatibilität, am besten dann gleich auf die 7.3. Wenn man das nicht kurzfristig schafft, dann eben mittelfristig, je früher desto besser. Sonst steht man damit irgendwann endgültig am Abgrund und findet nirgends mehr ein entsprechendes Hosting. Die Lage wird durch weiteres Abwarten jedenfalls garantiert nicht besser, die Uhr tickt.