Plesk mag FTP-Speicher nicht ("Goodbye" / "Rejected")

  • Moin!

    Habe mal wieder probiert, einen FTP-Speicher für Backups hinzuzufügen. Habe dazu eine USB-Festplatte an meine Fritzbox gehangen. FileZilla etc nehmen das auch an, nur Plesk mag es nicht so wirklich:

    Code
    Fehler: Zugriff auf Speicher nicht möglich: Transport error: unable to list directory: Curl error: (28) Timeout was reached: Last FTP request: Last FTP response: Vergewissern Sie sich, dass Sie die korrekten Speichereinstellungen eingegeben haben. Sie können dies unabhängig mit dem folgenden Befehl überprüfen: curl -v -P - --ssl -k -u Benutzer 'ftp://blabla.myfritz.net//Volume/Extern/webserver/'

    Also einmal auf meinem im Heimnetz laufenden Pi ausprobiert, da kommt das raus:

    pasted-from-clipboard.png

    Mit exakt dem aus dem Panel kopierten Befehl. Meine Konfiguration ist:

    pasted-from-clipboard.png

    Die Häkchen bei Passivmodus und FTPS ändern da auch nichts, genau so wie der Versuch das / vor dem Verzeichnis (oder gleich das ganze Verzeichnis) zu entfernen. Hat da jemand einen Rat?

    Wie ändert man seinen Benutzernamen? :pinch:

  • Verbinde Dich doch mal über SSH mit dem Webhosting und führe den cURL-Befehl dort aus. Vielleicht bringt das neue Erkenntnisse.


    Was Du sonst noch prüfen kannst:

    • Ist der externe FTP-Zugriff in der FRITZ!Box überhaupt aktiviert? ("Internetzugriff auf Ihre Speichermedien über FTP/FTPS aktiviert")
    • Hast Du überhaupt eine öffentliche IP(v4)-Adresse an Deinem Internetanschluss oder ist das ein CGN mit privater IP-Adresse?
  • Die Adressen *.myfritz.net verwenden ja normalerweise die öffentlichen IP-Adressen aber das Auflösen des Hostnamen ist ein guter Hinweis, falls da doch irgendwie eine nicht öffentlich erreichbare IP-Adresse hinterlegt worden wäre. (CGN musste ich selber erstmal nachschlagen)


    Mit relativ aktuellem FRITZ!OS 7.29 auf einer 7530 hätte ich die Option ("Internetzugriff auf Ihre Speichermedien über FTP/FTPS aktiviert") nicht gefunden ... allerdings muss bei mir für den eingerichteten Benutzer die Checkbox im Benutzer unter Zugang aus dem Internet gesetzt sein: [ ] Zugang auch aus dem Internet erlaubt

    Dass der Benutzer schon den korrekten Zugang zu den NAS Inhalten hat, schließe ich aus dem erfolgreichen Versuch den curl Befehl vom lokalen Pi abzusetzen.


    Danke auf jeden Fall an den Fragesteller für den Anreiz das jetzt auch einrichten zu wollen. 😊

    WH8000 SE 🥚 20 | WH1000 SE OST22 🦆 VPS 200 🇺🇦🕊️

  • Was Du sonst noch prüfen kannst:

    • Ist der externe FTP-Zugriff in der FRITZ!Box überhaupt aktiviert? ("Internetzugriff auf Ihre Speichermedien über FTP/FTPS aktiviert")
    • Hast Du überhaupt eine öffentliche IP(v4)-Adresse an Deinem Internetanschluss oder ist das ein CGN mit privater IP-Adresse?

    Habe über den lokalen Pi die .myfritz.net Domain genutzt, entsprechend ist das wie ein Zugriff von außen. In FileZilla geht es auch mit genau der Konfiguration die ich Plesk angegeben habe. Das forwarding übernimmt Fritz soweit ich weiß.

    Verbinde Dich doch mal über SSH mit dem Webhosting und führe den cURL-Befehl dort aus. Vielleicht bringt das neue Erkenntnisse.

    Nicht nur vielleicht!

    Code
    *   Trying ****:****:1000:a1::35cc...
    * TCP_NODELAY set
    * connect to ****:****:1000:a1::35cc port 21 failed: Permission denied
    *   Trying ***.***.237.203...
    * TCP_NODELAY set

    Und das war's dann. Aber komisch dass es mit dem gleichen Befehl aus dem Heimnetz geht, aber nicht auf dem Webserver.

    Zudem scheint das gleiche auch aus dem Mobilfunk der Fall zu sein. Ich denke mal dass das ein Konfigurationsfehler ist, entsprechend werde ich da mal nachsehen und bedanke mich schon einmal für die Hilfe!

    Mit relativ aktuellem FRITZ!OS 7.29 auf einer 7530 hätte ich die Option ("Internetzugriff auf Ihre Speichermedien über FTP/FTPS aktiviert") nicht gefunden

    Das ist da wo man auch die Laufwerke ansehen kann, etwas versteckt unten.

    Danke auf jeden Fall an den Fragesteller für den Anreiz das jetzt auch einrichten zu wollen. 😊

    Bei mir war der Grund eher der Unwille, teilweise 20€ im Monat für 1 TB Speicher zu bezahlen und dass ich noch eine externe HDD rumliegen hatte (aber letzendlich reicht jeder USB-Stick aus). Falls du interne Platten rumliegen hast: Adapter von SATA auf USB gibt's für knapp 10€.

    Wie ändert man seinen Benutzernamen? :pinch:

  • Bei mir war der Grund eher der Unwille, teilweise 20€ im Monat für 1 TB Speicher zu bezahlen und dass ich noch eine externe HDD rumliegen hatte (aber letzendlich reicht jeder USB-Stick aus). Falls du interne Platten rumliegen hast: Adapter von SATA auf USB gibt's für knapp 10€.

    Ich hab zu viel Hardware rumliegen ;)
    Ein alter HP Proliant Microserver mit Synology Bootimage ist aktuell mein NAS ... an der Fritz!Box hängt aktuell nur ein 16 GB USB 3.0 Stick ... ich werde also eher zum Ausprobieren auf einem Raspi einen FTP Server draufpacken und dort debuggen, was der von Netcup abgesetzte curl Befehl genau macht.

    Bei Dir scheint es aber vermutlich eher an der Erreichbarkeit des 21 Ports zu liegen (Timeout was reached). Daher musst Du noch den korrekten Port angeben.

    Ich habe die Option "Diese Option ermöglicht den Zugriff auf die Speichermedien an der FRITZ!Box aus dem Internet." jetzt auch gesetzt und musste dann einen eigenen TCP Port angeben. Nicht den Standard FTP Port 21 wie aus Deinen Protokollen.

    Und direkt unter der Option steht sowieso nochmals erklärt welche Bedingungen der Benutzer haben muss:
    Zugang haben alle FRITZ!Box-Benutzer, denen im Menü "System > FRITZ!Box-Benutzer" die Rechte "Zugang auch aus dem Internet erlaubt" und "Zugang zu NAS-Inhalten" eingeräumt wurden.

    Ich berichte gleich, ob es bei mir klappt ...

    WH8000 SE 🥚 20 | WH1000 SE OST22 🦆 VPS 200 🇺🇦🕊️

    Edited 3 times, last by Copro: Hinweis auf FTP Port. Der Rest war Blödsinn oder wurde schon geschrieben. ().

  • Hay,

    Habe über den lokalen Pi die .myfritz.net Domain genutzt, entsprechend ist das wie ein Zugriff von außen

    das muss nicht sicher so sein und solltest Du bitte über einen traceroute vom pi aus absichern. Wenn der Verkehr über die Fritzbox nach außen geht - die Fritzbox weiß, dass sie über DynDNS schließlich selbst gemeint ist - kann es sein, dass sie da einfach eine Abkürzung macht und eben das eigene Netz nicht so richtig verlässt.


    'ftp://blabla.myfritz.net//Volume/Extern/webserver/'

    Hier fallen mir zunächst einmal die doppelten "/" auf, den Dein Screenshot vom pi NICHT zeigt.


    Cu, Peter

    Peter Kleemann // https://www.pkleemann.de // +49 621 1806222-0 // Kann Programme, Internet, Netzwerke und Telefon.

    Like 2
  • Habe über den lokalen Pi die .myfritz.net Domain genutzt, entsprechend ist das wie ein Zugriff von außen. In FileZilla geht es auch mit genau der Konfiguration die ich Plesk angegeben habe. Das forwarding übernimmt Fritz soweit ich weiß.

    Diese Annahme ist falsch, ein Zugriff über die externe IP aus dem lokalen Netz ist nicht gleichzustellen wie ein wirklicher externer Zugriff.


    Die FRITZ!Box sieht ja dass der Zugriff aus dem internen Netz kommt.

  • Habe über den lokalen Pi die .myfritz.net Domain genutzt, entsprechend ist das wie ein Zugriff von außen.

    Vorsicht! Hier mal nicht täuschen lassen!.

    Ein lokaler Zugriff via myfritz-Adresse verlässt niemals das eigene Netzwerk, d.h. es bleibt ein lokaler Zugriff! Die Fritzbox erkennt ihre eigene Adresse und routet entsprechend lokal, d.h. auch die Firewall am WAN-Port kommt hier gar nicht zum tragen!


    Hier mal ein Beispiel, ich versuche beide Male auf Port 21 (FTP) zuzugreifen, einmal aus dem lokalen Netz, und einmal aus dem Internet - aber beide Male mit der myfritz-Adresse:



    Daher wie schon mehrfach vorgeschlagen: teste zunächst einmal, ob du wirklich von außen(!) über deine myfritz-Adresse auf dem Port erreichbar bist. Z.b. mit einem Server wie ich oder einfach einem Online-Tool, zb der hier. Mögliche Fehlerquellen wurden auch bereits genannt (CGNAT, Fritzbox Einstellungen, etc).


    Edit: hmpf... Patrick ist mir zuvorgekommen. :D:thumbup:

  • Daher wie schon mehrfach vorgeschlagen: teste zunächst einmal, ob du wirklich von außen(!) über deine myfritz-Adresse auf dem Port erreichbar bist. Z.b. mit einem Server wie ich oder einfach einem Online-Tool, zb der hier. Mögliche Fehlerquellen wurden auch bereits genannt (CGNAT, Fritzbox Einstellungen, etc).

    Das wurde schon gemacht in #4 - habe ich aber auch übersehen:

    Code
    connect to ****:****:1000:a1::35cc port 21 failed: Permission denied

    Ich musste einen extra Port angeben bzw. mir wurde zufällig der 41584 gesetzt ... daher denke ich dass der Default Port 21 vielleicht das Problem ist.
    FB_FTP_DefaultPort.png

    Zu finden unter "Internet - Freigaben - Fritz!Box-Dienste" (ein Teil davon also der FTP/S Zugriff ist auch unter "Heimnetz - USB / Speicher" konfigurierbar) aber da ist alles auf einem Blick.

    Mit diesen Einstellungen konnte ich jetzt den FTPS korrekt hinzufügen und das sollte mit Deinen Daten auch klappen:

    netcup_FTP_BackupManager.png

    Hostname oder IP des FTP-Servers: blabla.myfritz.net:<hierDenPortAusDerFritzBoxKonfigurationErgaenzen>

    Verzeichnis zum Speichern von Backupdateien: /Volume/Extern/webserver/


    (wie im "Zum Beispiel" den Slash zu Beginn angeben was zur Verdopplung der Slashes führt, wie CmdrXay schon angemerkt hat. Das macht zwar nichts also funktioniert in beiden Fällen und schaut nur nicht schön aus. Alle vier Varianten von "16GB_NTFS/netcup" bis "/16GB_NTFS/netcup/" funktionieren und sorgen dafür dass der FTPS als gültiges Backup-Ziel verfügbar ist.)

    Ich will Dich nicht entmutigen ... aber das Backup hochladen war aber dann doch nicht möglich wegen folgendem Fehler ;(
    Unable to create the remote backup: Transport error: unable to check directory existence: Curl error: (19) FTP: couldn't retrieve (RETR failed) the specified file: Last FTP request: QUIT Last FTP response: 221 Goodbye

    Jetzt geht es hier weiter ... da hatte im November 2021 ein anderer netcup Kunde schon einmal das Problem gemeldet:
    Backup/Remote-FTP funktioniert nicht mehr - WCP (Webhosting Control Panel) - netcup Kundenforum

    Ich habe bevor ich die TCP Dumps von der fritz.box ansehe noch schnell einen ProFTPD auf meinem Pi eingerichtet, eine Portweiterleitung an der Fritz!Box erstellt und dort hat das Ablegen des Backups auf Anhieb geklappt. Wenn also dasselbe Problem oben bei Dir auch auftritt - pack die Festplatte einfach an den Pi als Notlösung ;)
    (Ich vermute das Problem mit dem netcup/plesk Backup-Manager muss ich nochmal beim Support melden und das könnte länger dauern bis da ein Fix verfügbar ist wenn es überhaupt einen geben wird.)

    WH8000 SE 🥚 20 | WH1000 SE OST22 🦆 VPS 200 🇺🇦🕊️

    Edited 6 times, last by Copro: Hinweis auf Doppelung der Slashes ergänzt in der Lösung ;-( und Hinweis auf ProFTPD auf Pi ergänzt falls selbes Problem auftaucht. Man kann ja wirklich sehr lange und oft editieren. ().

    Like 1
  • Das wurde schon gemacht in #4 - habe ich aber auch übersehen:

    Code
    connect to ****:****:1000:a1::35cc port 21 failed: Permission denied

    Ich musste einen extra Port angeben bzw. mir wurde zufällig der 41584 gesetzt ... daher denke ich dass der Default Port 21 vielleicht das Problem ist.
    FB_FTP_DefaultPort.png

    Zu finden unter "Internet - Freigaben - Fritz!Box-Dienste" (ein Teil davon also der FTP/S Zugriff ist auch unter "Heimnetz - USB / Speicher" konfigurierbar) aber da ist alles auf einem Blick.

    ja, war auch mein Problem. Hätte meinerseits etwas mehr recherchieren können... Aber komisch dass das im hintersten Submenü ist. 3 verschiedene Menüs in 3 verschiedenen Oberkategorien finde ich jetzt nicht gerade intuitiv.

    Case closed, vielen Dank an alle Beteiligten! Mal sehen ob der Server es jetzt schafft oder auch nur ein "goodbye" und eine Träne von sich gibt.


    Edit: doch, tut er *seufz* dann ab zum Support

    Ich habe bevor ich die TCP Dumps von der fritz.box ansehe noch schnell einen ProFTPD auf meinem Pi eingerichtet, eine Portweiterleitung an der Fritz!Box erstellt und dort hat das Ablegen des Backups auf Anhieb geklappt. Wenn also dasselbe Problem oben bei Dir auch auftritt - pack die Festplatte einfach an den Pi als Notlösung ;)

    Hatte ich tatsächlich vor Ewigkeiten mal, aber dann lag der hier rum (und war selbst über LAN sehr langsam). Solange es technisch jetzt klappt lasse ich es auf der Box, sonst hänge ich die Platte an meinen armen kleinen Pi0 (die 7 tmux Sitzungen lassen grüßen).


    Was meinst du wie lang du mit 16 GB klar kommst? Ist das nicht in etwa genug für ein Backup, wenn überhaupt? Aber zum rumprobieren reicht's ja =) (das klingt harscher als es soll)

  • Was meinst du wie lang du mit 16 GB klar kommst? Ist das nicht in etwa genug für ein Backup, wenn überhaupt? Aber zum rumprobieren reicht's ja =) (das klingt harscher als es soll)

    Die 16 GB an dem Stick auf der Fritz!Box sind natürlich schon völlig am Limit und das ist ja auch nicht mein primäres NAS, aber für ein Test-Backup der reinen plesk Konfiguration mit 748 KB als tar taugt das doch und ich konnte damit das Problem nachstellen.


    fritz_USB.jpg

    Wenn ich den letzten Edit im Beitrag richtig verstehe bedeutet das:
    - FTP(S) unter "Einstellungen für den Remote-Speicher" bei Dir meldet jetzt auch "Einsatzbereit"

    - Beim [Backup erstellen] kommt es aber bei der Übertragen des Backups dann auch zu einem Fehler

    Der Titel "Plesk mag FTP der FritzBox nicht" ist wirklich gut gewählt, denn er scheint tatsächlich mit irgendeiner Antwort vom Fritz!Box ftpd aus dem Tritt zu kommen.

    Spoiler: Ich glaube ich habe einen Workaround gefunden und in dem anderen Beitrag dokumentiert.
    Backup/Remote-FTP funktioniert nicht mehr

    WH8000 SE 🥚 20 | WH1000 SE OST22 🦆 VPS 200 🇺🇦🕊️

    Edited once, last by Copro ().

  • Die 16 GB an dem Stick auf der Fritz!Box sind natürlich schon völlig am Limit und das ist ja auch nicht mein primäres NAS, aber für ein Test-Backup der reinen plesk Konfiguration mit 748 KB als tar taugt das doch und ich konnte damit das Problem nachstellen.

    Stimmt, macht absolut Sinn.

    Hätte ich einen USB-Stick der so aussieht, würde ich den schon alleine deswegen benutzen xD

    Wenn ich den letzten Edit im Beitrag richtig verstehe bedeutet das:

    - FTP(S) unter "Einstellungen für den Remote-Speicher" bei Dir meldet jetzt auch "Einsatzbereit"

    - Beim [Backup erstellen] kommt es aber bei der Übertragen des Backups dann auch zu einem Fehler

    Korrekt.

    Der Titel "Plesk mag FTP der FritzBox nicht" ist wirklich gut gewählt, denn er scheint tatsächlich mit irgendeiner Antwort vom Fritz!Box ftpd aus dem Tritt zu kommen.

    Zu dem Zeitpunkt war der Fehler ja noch nicht bekannt, daher der Titel. Aber ja, stimme dir zu. Sobald das tatsächliche Problem gefunden ist werde ich den Titel ändern.

    Spoiler: Ich glaube ich habe einen Workaround gefunden und in dem anderen Beitrag dokumentiert.

    Backup/Remote-FTP funktioniert nicht mehr

    Nachdem ich mich durchs unendlich langsame Plesk gearbeitet habe einmal ausprobiert und ein Backup auf Serverspeicher gemacht (Nur Konfiguration, damit's handlich ist) und es in das FTP-Zielverzeichnis kopiert. Tatsächlich taucht eine Backup-Datei auf meinem NAS auf und es funktioniert perfekt.


    Hier meine Theorie: Wenn ein Backup im Ordner ist wird irgendeine Prüfung o.ä. übersprungen, deshalb geht es dann.


    So oder so, danke für deine / eure Hilfe! :)

    Wie ändert man seinen Benutzernamen? :pinch:

    Thanks 1
  • OlMi1_YT I NETCRAFT

    Changed the title of the thread from “Plesk mag FTP der FritzBox nicht” to “Plesk mag FTP-Speicher nicht ("Goodbye" / "Rejected")”.