Wordpressinstallation migrieren

  • Hallo netcup-Community,


    wir, der Föderverein einer Grundschule, haben hier ein "Webhosting 1000 SE"-Paket und möchten unserer bisheriger Website, eine Wordpressinstanz bei Wordpress.com hierher umziehen.

    Derzeit zeigt die hier registrierte Domain, "fv-vls.de" auf die Wordpress.com-Instanz.

    Das Ziel ist jetzt, zunächst alle Inhalte und das Design zu migrieren und dann, wenn alles läuft, die Domain umzuleiten.

    Und ich bekomme es einfach nicht hin.

    Und zwar kann ich mich nicht einloggen, um die hier installierte Wordpressinstanz einzurichten.

    Vorgehen

    • Ich habe via "Anwendungen" Wordpress "in die fv-vls.de-Domain installiert" und es taucht dann im WP-Toolkit auch auf (ich habe Wordpress auch schon einmal manuell installiert, hatte aber den gleichen Fehler)
    • Die Links im Toolkit zu Anmelden bzw. Einrichten zeigen dann aber leider zu http://fv-vls.de/wp-login.php - das geht logischerweise nicht, da die Domain noch nicht umgestellt ist. D.h. der „Anmelden“-Knopf führt auch ins Leere. Aber ich kann da meine automatisch generierten WP-Adminzugangsdaten auslesen.

    Die Fehlermeldung so generell hilft nicht weiter. Ich gehe davon aus, dass sich hier durch die Domains (Aufruf über ip/plex/vorschau – Konfiguration aber auf fv-vls.de irgendetwas beißt).

    In der URL stehen dann auch Dinge wie „redirect“ zur Domain, was ja mit Sicherheit nicht funktioniert, da diese ja noch auf wp.com zeigt.

    http://188.68.47.126/plesk-site-preview/fv-vls.de/https/188.68.47.126/wp-login.php?redirect_to=https%3A%2F%2Ffv-vls.de%2Fwp-admin%2F&reauth=1


    Was habe ich getan? Gegoogelt.

    https://www.agentur-kreativdenker.de/wordpress-cookie-fehler-bei-login-beheben/

    Fehler in der wp-config.php: falsche Domain (WP_HOME, WP_SITEURL)? Falsche Cookie-Domain (COOKIE_DOMAIN)? Falsche (Leer-)Zeichen in der Datei?

    Nix davon ist in der wp-config.php enthalten.

    Irgendwo las ich auch (link verloren), dass Wordpress Teile der Konfiguration in der DB speichert. Also per phpymyadmin mal in der Tabelle „options“ geschaut und das hier gefunden:

    pasted-from-clipboard.png

    Wenn ich das aber umstelle auf unterschiedliche Kominationen aus der Domain der preview-URL, tut sich alles mögliche (mal ist das CSS weg, mal sind alle Links auf der Seite falsch), einloggen kann ich mich aber nie.


    Ich glaube, ich steh irgendwo auf dem Schlauch. Beim Wettbewerber habe ich schon zig mal Wordpress installiert und hatte nie ein Problem.

    Die Anforderung "erst komplett einrichten, dann Domain umbiegen" ist doch nicht sonderlich abstrakt?

    Wo hakts und wird es wieder haken, wenn ich dann SSL aktiviere?


    Viele Grüße und im Voraus danke.

    Philipp

  • Hallo Philipp =)

    Das Problem wird sein, das WP mit statischen URLs arbeitet, und die Domain noch beim alten Hoster sitzt.
    Sprich: WP ruft URLs ab die nicht zur Installation passen, und leitet so auch ggf. zur alten Installation um.

    Meine Empfehlung: Alles nochmal löschen, WP ohne Toolkit installieren und jetzt wichtig:
    Bei der WP Installation nicht die Domain angeben welche später mal auf die WP Installation zeigen soll, sondern die Domain, die während dem Umzug auf die Installation zeigt. z.B. einfach hosting123456.kb019.netcup.net

    Dann alles umziehen, und sobald die die neue Installation verwenden willst im WP Dashboard auf "Einstellungen" und dann "Allgemein". Hier kannst du dann die "WordPress-Adresse" und die "Website-Adresse" final ändern.

    Hoffe das hilft dir weiter.

    2x Webhosting 8000 SE BF22 & 1x Webhosting 4000 SE KI23 & 2x Webhosting 1000 SE BF22

  • Hallo Bud,


    danke für die schnelle Rückmeldung.


    Ich hab nun WP in hosting181634.a2f7e.netcup.net installiert und es klappt. Danke für den Hinweis.

    Dort sollte ich in der Lage sein, alles so einzurichten, wie ich möchte.


    WIe bekomme ich anschließend die Domain da hin umgebogen? Ich sehe zwei Möglichkeiten:

    1. Im CCP den Dokumentenstamm der Domain von "fv-vls.de/httpdocs" auf "hosting181634.a2f7e.netcup.net/httpdocs/" ändern.
    2. Alles aus "hosting181634.a2f7e.netcup.net/httpdocs/" nach "fv-vls.de/httpdocs" kopieren.

    Und dann eben noch die Adressen in WP ändern (das sollte auch direkt in der Datenbank gehen, falls man sich ausgeschlossen hat.


    Muss man dann in der .htaccess noch irgend etwas umstellen?


    Ich werde das einfach mal Probieren. Auch wenn man sich nicht einloggen kann, die Inhalte wurden auf der Preview-Seite immer angezeigt.

    Jetzt (eher Donnerstag/Freitag) gehts also ans Wursteln.


    Ich geben Rückmeldung.

    Philipp

  • ich empfehle, die dokumentenstämme der domains immer getrennt zu halten.

    damit nimmt man sich später nicht die möglichkeit, die interne netcup.net-domain für anderweitiges oder zum testen zu benutzen.

    also erst alle domainstämme anlegen lassen, dann die daten kopieren oder verschieben und anpassen.

    »Hauptsache BogoMIPS!«

    Anas Ananas

    Like 1
  • WIe bekomme ich anschließend die Domain da hin umgebogen? Ich sehe zwei Möglichkeiten:

    1. Im CCP den Dokumentenstamm der Domain von "fv-vls.de/httpdocs" auf "hosting181634.a2f7e.netcup.net/httpdocs/" ändern.
    2. Alles aus "hosting181634.a2f7e.netcup.net/httpdocs/" nach "fv-vls.de/httpdocs" kopieren.

    ich empfehle, die dokumentenstämme der domains immer getrennt zu halten.

    Ähnlich wie Olivetti schon erwähnt hat, würde ich dir empfehlen die Dokumentenstämme immer getrennt und eindeutig zu halten. Ich persönlich habe dies bei mir z.B. folgendermaßen strukturiert:

    Und dann eben noch die Adressen in WP ändern (das sollte auch direkt in der Datenbank gehen, falls man sich ausgeschlossen hat.

    Ja, wenn man sich ausgeschlossen hat kann man das auch in der DB ändern ;)

    Muss man dann in der .htaccess noch irgend etwas umstellen?

    Ich bin mir gerade nicht sicher was in der Standard-.htaccess von WP steht. Im Zweifel aber einfach mal rein schauen ob ein Domaineintrag geändert werden muss.

    Ich geben Rückmeldung.

    Würde mich freuen :)

    2x Webhosting 8000 SE BF22 & 1x Webhosting 4000 SE KI23 & 2x Webhosting 1000 SE BF22

    Like 1
  • Für Umzüge gibt es Plugins: backup migration funktioniert wunderbar

    Mit dem Umzug selbst hat der TE ja keine Probleme. Aber falls doch, ist meiner Meinung nach Duplicator bestens geeignet. Das Video (OT englisch) auf der Plugin-Seite zeigt wie man vorgehen muss.

    2x Webhosting 8000 SE BF22 & 1x Webhosting 4000 SE KI23 & 2x Webhosting 1000 SE BF22

  • Weil ich es gerade sehe. Was für eine PHP Version hast du denn eingestellt? Für WP sollte man aktuell 8.1 nutzen.

    2x Webhosting 8000 SE BF22 & 1x Webhosting 4000 SE KI23 & 2x Webhosting 1000 SE BF22

  • Für Umzüge gibt es Plugins: backup migration funktioniert wunderbar

    Neben den Kosten auch ein Grund, von wp.com wegzugehen: In derem günstigsten Tarif kann man gar keine Plug-ins installieren.


    PHP habe ich auf 8.2 gestellt; die Installation "in" die generische Domain hat gut funktioniert; Kopieren der Inhalte ebenfalls; Aufrufen über Vorschau auch, auch wenn da natürlich alle Links & Verknüpfungen noch auf die generische Domain verweisen. D.h. in der Wp-Konfig die Domain umstellen und dann werden wir am Wochenende mal die Domain umschalten, SSL aktivieren und dann gucken, ob alles klappt.

  • ...und dann werden wir am Wochenende mal die Domain umschalten, SSL aktivieren und dann gucken, ob alles klappt.

    Du wirst auch noch in der DB die ganzen urls mit dem domainnamen ändern müssen. (Am einfachsten per plugin)

    Leider verdrahtet WP bei der Installation den Domainnamen in der DB

  • Hier der Erfahrungsbericht:


    Ich habe wordpress unter der generischen Domain installiert. Dort konnte ich mich einloggen und alles richtig einrichten.

    Die Inhalte habe ich per Export/Import-Funktion übertragen, dabei "Medien runterladen" angeklickt.

    Da kommt dann ab und an 504, Timeout, dann lässt man es eben noch einmal laufen.

    Schneller geht dass dann aber per Plugin "Auto Image Uploader" (auch da kommt das Timeout aber es werden mehr Medien übertragen und man muss nicht immer Autoren zuweisen klicken).


    Das Ganze dann in das httpdocs-Domainverzeichnis kopiert, Domain umgestellt.

    Dann ist es erst ein wenig kaputt, dann habe ich direkt in der Datenbank die WP Einstellungen der Domain geändert.


    Die Bilderlinks in den Beiträgen wollte das o.g. Plugin dann nicht ändern, das hat dann das Plugin "Velvet Blues Update URLs" übernommen (auch mit WP 6.1 lauffähig).


    Vergessen hatte es allerdings die Links zu den Logos und zum Hintergrundbild (Themes => Customize), die habe ich dann von Hand geändert (also neu hochgeladen und zugewiesen.


    Benutzer noch anpassen und ab.


    Im Grunde also alles, wie hier im Thread erarbeitet. Passt.

    Danke für die Unterstützung.


    laberlaib