.APP-Domain auf Root-Server

  • Hallo,

    kann es sein dass es entweder bei meiner Konstellation oder generell nicht möglich ist, eine .APP-Domain (bei netcup) auf einen Root-Server (netcup) zu verweisen?

    Ich habe von einer .DE Telekom (Hosting) auf eine .App Domain bei Netcup gewechselt und möchte wieder auf meinen Root-Server verweisen.
    Bei der Telekom ging das, aber - obwohl ich auf die gleiche IP verweise (nämlich per " * A +IP", " @ A +IP", " www A +IP" auf die IPv4 des Root-Servers).

    Merkwürdigerweise werde ich aber auf das Verzeichnis des Webhostings verlinkt - obwohl vom Webhosting gar keine IP in irgendeinem DNS-Eintrag steht.


    Hat hier jemand noch eine Idee?

  • Lange genug gewartet nach der Eiingabe der obigen Records? Eventuell noch auf vorhandene AAAA-Records prüfen. Welches Webhosting überhaupt? Ist oder war die Domain einem Webhosting Paket zugeordnet? Ansonsten ist meine Glaskugel kaputt, dann bitte die DNS-Einstellungen posten.

  • Kontrolliere mal, ob unter Domains in CCP (netcup ccp (customercontrolpanel.de)) evtl. schon eine Zuweisung auf ein Webhosting Paket vorgenommen wurde und hebe diese Zuweisung mit einem Klick auf [Zuweisung aufheben] auf. Die korrekten Einstellungen für die .app Domain nimmt man dann im Reiter "DNS" vor.

    Hilfeseite dazu: netcup - Domain mit Server verbinden

    Und daran denken, dass DNS Einstellungen gecached werden und für Experimente und schnelle Änderungen eventuell die TTL auf 300 Sekunden (5 Minuten) heruntergesetzt werden sollte - ansonsten kann es bei der Standardeinstellung bis zu 24 oder sogar 48 Stunden dauern, bis die Änderung weltweit auf allen DNS verfügbar ist.

    :!:

    WH8000 SE 🥚 20 | WH1000 SE OST22 | WH1000 SE OST23 | WH1000 SE OST24 | WH 🥚🧶🥛🐖 | 🦆 VPS 200 🇺🇦🕊️

    Thanks 1
  • Verstehe dein Problem leider auch nicht so ganz. Vielleicht kannst du das nochmal etwas strukturierter beschreiben.


    Allgemein ist bei einer .app-Domain aber zu beachten, dass nur HTTPS klappt:

    The .app top-level domain is included on the HSTS preload list, making HTTPS required on all connections to .app websites — no individual HSTS registration or configuration required.

    RS Brezn | VPS 500 G8 Plus | 2× VPS Karneval 2020 | VPS Pocket Admin | RS Cyber Quack | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

    Like 1 Thanks 1
  • Lange genug gewartet nach der Eiingabe der obigen Records? Eventuell noch auf vorhandene AAAA-Records prüfen. Welches Webhosting überhaupt? Ist oder war die Domain einem Webhosting Paket zugeordnet? Ansonsten ist meine Glaskugel kaputt, dann bitte die DNS-Einstellungen posten.

    Sind inzwischen etwas über 36h - Am Anfang war ja (logischerweise) gar keine DNS Einstellung aktiv - und inzwischen komme ich auf mein Webhosting.
    Es ist ein Webhosting-Paket zugewiesen, ja - da Mails über den Netcup-Mailserver davon laufen sollen.


    Kontrolliere mal, ob unter Domains in CCP (netcup ccp (customercontrolpanel.de)) evtl. schon eine Zuweisung auf ein Webhosting Paket vorgenommen wurde und hebe diese Zuweisung mit einem Klick auf [Zuweisung aufheben] auf. Die korrekten Einstellungen für die .app Domain nimmt man dann im Reiter "DNS" vor.

    Hilfeseite dazu: netcup - Domain mit Server verbinden

    Und daran denken, dass DNS Einstellungen gecached werden und für Experimente und schnelle Änderungen eventuell die TTL auf 300 Sekunden (5 Minuten) heruntergesetzt werden sollte - ansonsten kann es bei der Standardeinstellung bis zu 24 oder sogar 48 Stunden dauern, bis die Änderung weltweit auf allen DNS verfügbar ist.

    :!:

    Zuweisung auf Webhosting ist aktiv, aber laut DNS-Eintrag dürfte die Domain dahin nicht verweisen.

  • Update:
    Wurde dem Webhosting wieder zugewiesen - ohne Sicherheitszertifikat ist die Domain so garnicht nutzbar.
    Über "DNS" Checker wird immer nur die "richtige" IP angezeigt (vom Root-Server) erreichen tatsächlich tue ich aber nur das Webhosting.

    Hier muss doch was faul sein...

  • nämlich per " * A +IP", " @ A +IP", " www A +IP" auf die IPv4 des Root-Servers

    Da existiert nicht zufällig noch ein AAAA-Record für die gleiche Subdomain, der auf das Webhosting verweist?


    Den würde Dein Browser nämlich womöglich bevorzugen, wenn Du eine IPv6-Internetverbindung hast.

    "Wer nur noch Enten sieht, hat die Kontrolle über seine Server verloren." (Netzentenfund)

    Thanks 1
  • Poste doch bitte mal einen Screenshot deiner DNS-Settings. Ich würde ja gern helfen, aber so ist’s aktuell wirklich schwierig.

    RS Brezn | VPS 500 G8 Plus | 2× VPS Karneval 2020 | VPS Pocket Admin | RS Cyber Quack | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

    Thanks 1
  • So, und was ist jetzt genau dein Ziel? Sowohl studiogoldhammer.app als auch *.studiogoldhammer.app sollen auf die IPs vom Root-Server zeigen?


    Diese sind 193.31.25.62 und 2a03:4000:30:eef8::16:2278?

    RS Brezn | VPS 500 G8 Plus | 2× VPS Karneval 2020 | VPS Pocket Admin | RS Cyber Quack | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Nicht auch auf 2a03:4000:30:eef8::16:2278?

    Dann solltest du zunächst mal die AAAA-Einträge (IPv6) löschen.


    Als nächstes solltest du passende Zertifikate installieren. Das aktuelle ist nur für app.studiogoldhammer.de ausgestellt worden.

    RS Brezn | VPS 500 G8 Plus | 2× VPS Karneval 2020 | VPS Pocket Admin | RS Cyber Quack | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

    Thanks 1
  • Da existieren aber eben auch AAAA-Records...


    Und wenn das nicht die IPv6-Adresse des Zielservers ist, sollte klar sein, warum Du woanders landest. ;)


    EDIT: Zu langsam.

    "Wer nur noch Enten sieht, hat die Kontrolle über seine Server verloren." (Netzentenfund)

    Edited once, last by KB19 ().

    Thanks 1
  • Nicht auch auf 2a03:4000:30:eef8::16:2278?

    Dann solltest du zunächst mal die AAAA-Einträge (IPv6) löschen.


    Als nächstes solltest du passende Zertifikate installieren. Das aktuelle ist nur für app.studiogoldhammer.de ausgestellt worden.

    Habe das Zertifikat schon "mehrfach" erneut ausgestellt, ich weis nicht woher diese "alte" Domain (app.studio...) kommt

  • Habe das Zertifikat schon "mehrfach" erneut ausgestellt, ich weis nicht woher diese "alte" Domain (app.studio...) kommt

    Und wie hast du das ausgestellt und auf deinem Server installiert? Falls über das WCP, dann wird das Zertifikat auf dem Webhosting-Server installiert. Das hilft deinem Root-Server ja erst mal nichts. Der hat dann immer noch kein Zertifikat.

  • Und wie hast du das ausgestellt und auf deinem Server installiert? Falls über das WCP, dann wird das Zertifikat auf dem Webhosting-Server installiert. Das hilft deinem Root-Server ja erst mal nichts. Der hat dann immer noch kein Zertifikat.

    Hm... ganz Blöd; wie gehe ich da vor?