Let's Encrypt - automatische Verlängerung geht nicht

  • Hallo,


    ich bekomme vermehrt Mails vom Let's Encrypt Expiry Bot das meine SSL Zertifikate demnächst ablaufen.

    Im CCP sehe ich in der Beschreibung unter Let's Encrypt, dass diese eigentlich automatisch verlängert werden sollten (Hinweis: Das Zertifikat wird automatisch 30 Tage vor Ablauf verlängert.)

    Wenn ich aktive auf Ernuern klicke funktioniert es, bloss die automatisierte Erneuerung klappt nicht.


    Bin ich ein Einzelschicksal oder gibt es generell ein Problem damit?


    Danke und lG

    Stefan

  • Wenn ich das richtig in Erinnerung habe, wird im WCP erst 7 oder 8 Tage vor Ablauf erneuert

    Die Angabe der "30 Tage" ist falsch. Sollte die Erneuerung aber nicht klappen, bekommst du

    eine Nachricht von netcup. Genauso, wenn das Zertifikat verlängert wird.

    It's me, only me, pure michi

    RS 500 SAS G8 Ostern 19

    VPS: 50 G7 |B Ostern 2017|200 G8 Aktion| 200 G8

    WH: SmallEi | Adv17 Spezial Family |4000 SE|1000 WaD

  • Wenn ich das richtig in Erinnerung habe, wird im WCP erst 7 oder 8 Tage vor Ablauf erneuert

    Die Angabe der "30 Tage" ist falsch. Sollte die Erneuerung aber nicht klappen, bekommst du

    eine Nachricht von netcup. Genauso, wenn das Zertifikat verlängert wird.

    am 24.5 läuft es ab und bis dato ist nichts passiert. Ein paar Tage habe ich ja noch.

  • Die Option muss deaktiviert sein, damit das klappt. LE erwartet Statuscode 200 und nicht 301. Hat früher so geklappt, jetzt wohl nicht mehr

    Ich weiß zwar nicht in welchen Abständen LE es versucht, aber ich habe nachdem ich dir geantwortet habe die Umleitung entfernt, jedoch hat sich bis jetzt noch nichts getan. Wie bereits erwähnt warte ich noch einfach ein paar tage. Was sagt den der Netcup Support dazu?

  • Ich weiß zwar nicht in welchen Abständen LE es versucht, aber ich habe nachdem ich dir geantwortet habe die Umleitung entfernt, jedoch hat sich bis jetzt noch nichts getan. Wie bereits erwähnt warte ich noch einfach ein paar tage. Was sagt den der Netcup Support dazu?

    Der Support wird dir genau das sagen, was ich dir gesagt habe. Am einfachsten ist es einfach das Zertifikat zu verlängern

  • Die Option muss deaktiviert sein, damit das klappt. LE erwartet Statuscode 200 und nicht 301. Hat früher so geklappt, jetzt wohl nicht mehr

    Das kann eigentlich nicht sein. Ich habe die Option bei meinen Domains aktiviert und die automatische Verlängerung funktioniert trotzdem.

  • Das kann eigentlich nicht sein. Ich habe die Option bei meinen Domains aktiviert und die automatische Verlängerung funktioniert trotzdem.

    Dann scheint das wohl von Instanz zu Instanz unterschiedlich zu sein. Beim Reseller Tarif (also die neuste Plesk Version) ist genau dies der Fall und mir wurde das so vom Support zurückgegeben, dass diese Option deaktiviert werden soll für LE. Bei meinen alten Tarifen war diese Funktion aber immer aktiv und es hat trotzdem geklappt.

  • KlausWei

    Ich würde es lieber anders machen, wie bereits oft im Forum vorgeschlagen: Domain auf einen eigenen Ordner zeigen lassen und dort mittels .htaccess-Datei umleiten. Dann hast Du für die ursprüngliche Domain bei Bedarf sogar HTTPS über Let's Encrypt ;)


    Die Weiterleitungsoptionen in Plesk sind zwar für den schnellen Einstieg recht nett und praktisch, aber im Endeffekt schränkt man sich damit nur unnötig ein.

  • Hi Zusammen,


    per Zufall habe ich Euer Thread gesehen. Probiert mal bei Lets Encrypt Zertifikat die Häkchen für Wildcard rauszunehmen, denn das funktioniert bei mir leider nicht.


    Ich zitiere Support-Antwort auf meine Anfrage:

    Find ich eigentlich schwach, aber was solls...


    Viele Grüße

    Floh

  • am einfachsten im browser auf's schloß der "beispiel.domain.de" klicken und dann zu den zertifikatsdetails durchhangeln.


    oder mit der shell:

    Code
    # beispiel für forum.netcup.net
    echo | openssl s_client -connect forum.netcup.net:443 2>/dev/null | openssl x509 -noout -dates
    Code
    # output
    notBefore=Nov  4 13:35:18 2021 GMT
    notAfter=Feb  2 13:35:17 2022 GMT

    »Hauptsache BogoMIPS!«

    Anas Ananas

  • Das ist aber (leider) nicht anders möglich. In der Plesk Doku (https://support.plesk.com/hc/e…Plesk-with-Let-s-Encrypt-) steht auch geschrieben, dass eine Erneuerung von Wildcard-Zertifikaten nur dann möglich ist, wenn der DNS-Service über Plesk läuft. Dies ist bei Netcup jedoch nicht der Fall.


    Legst du jedoch für jede Domain und Subdomain ein eigenes Zertifikat über den OneClick-Button für LetsEncrypt an, dann werden deine Zertifikate auch automatisch verlängert.


    VG

  • Genau. Ich weiss jetzt nicht mal, im Zuge welchen Updates die Änderung bei den LE-Zertifikaten eingeführt wurde. Für alle, die noch nicht so lang Webhosting-Kunden sind: Davor gab es die Möglichkeit eines Wildcard-Zertifikats bei netcup nicht, sondern nur Zertifikate, welche entweder die Hauptdomain, wahlweise inklusive www-Subdomain, oder einzelne Subdomains abdeckten. Diese wurden automatisch verlängert. Daran hat sich jetzt geändert, dass zusätzlich auch Wildcard-Zertifikate immerhin überhaupt möglich sind, auch wenn hier dann eine automatische Verlängerung nicht gegeben ist. Die Einzelzertifikate für Hauptdomain oder Subdomains werden auch weiterhin automatisch verlängert. Schwach oder nicht schwach, ich kenne mehrere renommierte Webhoster, da gibt es gar keine LE-Zertifikate, egal ob mit oder ohne automatische Verlängerung. Und die sind alle deutlich teurer als vergleichbare netcup-Angebote, soweit man Webhostingpakete mit Dutzenden Bestandteilen überhaupt so pauschal vergleichen kann.


    Ich bin kein Ex-Präsident der USA, ich sage nicht, dass meine Atomrak... ähhh Webhostings hier bei netcup Tippitop sind, sie haben durchaus auch ihre Schwächen. Aber LE-Zertifikate gehören da aus meiner Sicht nicht wirklich dazu.