.htaccess mit +FollowSymlinks erzeugt Fehler 500

  • Ich habe Joomla! im Einsatz. Ich verwende die (geprüfte) Standard-htaccess Datei, die mit Joomla "ausgeliefert" wird.

    Die htaccess liegt in meinem Seiten-root-Verzeichnis /httpdocs/meineseite/html/

    Diese Zeile erzeugt einen Fehler 500


    Options +FollowSymlinks


    Wenn ich die Zeile auskommentiere, kann ich die Seite aufrufen, jedoch werden die URLs nicht mehr per mod_rewrite "übersetzt".
    Muss hier in der php.ini irgendwetwas angepasst werden? (Ich habe keinen Zugriff, Produkt Webhosting 2000 de a1)
    Muss sonst etwas in der Hosting Konfiguration beachtet, bzw. explizit eingestellt sein?


    Website liegt hier:

    http://kast.hosting104559.af9ae.netcup.net/

  • Hallo,


    tausche in der .htaccess-Datei den Wert "+FollowSymlinks" gegen diesen aus: "+SymLinksIfOwnerMatch"

    Dann sollte alles funktionieren. Ersatzweise schalte unter "Einstellungen für Apache & nginx" im WCP die Einstellung "Fähigkeit, symbolischen Verknüpfungen zu folgen, einschränken" ab.


    Ist schlussendlich "Geschmackssache":

    Erst genannten Option bedeutet eigenes ändern der Joomla-Installation bzw. dessen Grundeinstellungen und die zweite Option nimmt (ein wenig) Sicherheit weg. Muss man sich je nach Einsatzzweck der Seite und erlaubter Aktionen der User entscheiden was man macht.



    Beste Grüße

    Patrick

  • Es gilt für alle Bilder im Inhalt:


    Beispiel:

    http://kast.hosting104559.af9a…inie-fuer-heimtiernahrung



    Log:

    Error37.228.234.243 404 GET /referenzen/projekte/getreidetechnik/images/006_referenzen/061_projekte/613_getreidetechnik/613_1_Halle.jpg


    Der Link zum Bild müsste aber /images/006_referenzen/061_projekte/613_getreidetechnik/613_1_Halle.jpg   lauten


    Rewrite Base in der htaccess ist / (root)

    Es macht aber keinen Unterschied ob Rewrite Base / aktiv oder auskommentiert ist.

  • Es macht keinen Unterschied, ob ich Options +FollowSymlinks mit oder ohne +SymLinksIfOwnerMatch aktiv habe, Ebenso Rewrite Base / macht keinen Unterscheid, außer wenn man die Seite nicht über die Subdomain, sondern über http://hosting104559.af9ae.net…t/kastenmueller.com/html/ aufruft. Das ändert aber nichts an diesem Problem:


    Die Bilder sind da, allerdings werden diese versucht relativ zur aktuellen Seite und nicht relativ zur root zu erreichen.

    Also /solutions/silos/images/usw/bild.jpg anstatt /images/usw/bild.jpg


  • Wie schaut denn die Einstellung unter "Einstellungen Webserver" bzw. "Einstellungen für Apache & nginx" der Domain wo das Problem auftritt inzwischen aus?

    Ist der Haken bei "Fähigkeit, symbolischen Verknüpfungen zu folgen, einschränken" gesetzt oder nicht?


    Beide Einstellungen, also "+FollowSymlinks" und "+SymLinksIfOwnerMatch", zu setzen macht keinen Sinn. Ich würde nur "+SymLinksIfOwnerMatch" wählen und "+FollowSymlinks" rausschmeißen - dann ist es egal ob der eben abgefragte Haken gesetzt ist oder nicht. Der Besitzer der Dateien solltest du immer sein bei PHP mit FPM.


  • Der Haken bei "Fähigkeit, symbolischen Verknüpfungen zu folgen, einschränken" ist nicht gesetzt, damit funktioniert garnischts mehr.


    PHP ist mit FPM.


    Nur +SymLinksIfOwnerMatch habe ich auch probiert, ohne Erfolg