mysqldump schlägt fehl

  • Öhm, vielen Dank dafür!!! Das werde Ich gleich mal testen... 👍🏼👍🏼👍🏼


    Top...

  • Moin moin,


    nochmal vielen Dank, habe es jetzt genau so eingerichtet wie du es ausführlich beschrieben hast.


    Das Backup wird erstellt, jedoch bekomme Ich beim Testen kleinere Fehler angezeigt.

  • Die Fehler deuten auf eine falsche Zeichenkodierung der backup-datenbank.sh hin. Diese bitte einmal überprüfen und gegebenenfalls korrigieren.

    Ist richtig...


    Und genau mein Script wie du sagst kann es auch nicht sein. Weil 5 Zeilen Text ist mein Beispiel garnicht 😘


    Wenn du in Windows Shell Scripts schreibst solltest du dir mal Sublime Text oder Notepad++ angucken. Die setzen dir die Codierung richtig wenn du eine Sh Datei bearbeitest.

  • Ich glaube irgendetwas läuft bei mir falsch.


    ich hatte als erstes Script deine kopiert und oben über das Script $dbname = dbname; (die Gänsefüßchen oben fehlen) etc, das hat irgendwie nicht funktioniert bzw. da sind die Fehler gekommen, dann habe Ich alle $dbname, $dbserver etc. direkt eingefügt, jetzt spuckt er den Fehler


    mysqldump: Got error: 2002: "Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2 "No such file or directory")" when trying to connect


    aus, keine Ahnung warum... 🥺

  • was hast du z.B. für $dbhost eingetragen? localhost 127.0.0.1 oder liegt der mysql Server extern? und auf einem anderen Port

    jeder der einen Schreibfehler in meinem Post findet, darf ihn Kommentarlos behalten

    P.S. gilt auch für Schignaturen ;)

  • aus, keine Ahnung warum... 🥺

    Sicher, dass du die "--host" Option gesetzt hast?

    Er versucht den lokalen Mysql Server über den Socket zu erreichen. Allerdings liegt der mysql in deinem Fall ja auf einem anderen Server

    Meine (Netcup) Produkte: VPS 1000 G7 SE, S 1000 G7, VPS 200 G8 Ostern 2019, IPs, Failover..

  • So, hatte die .sh Datei nochmal gelöscht und mittels Notepad++ eine neue sh erstellt, es hing wohl an der Formatierung, die beiden Bindestriche -- waren unterschiedlich lang, jetzt ist es ohne Fehler.


    Sorry für meine Unwissenheit. 😁


    Ich danke euch für die Geduld mit mir!