Database Remote connection

  • Hi,


    I am having problems with my mysql client. I couldnt connect to my database. I did create a database from froxlor and set a password for it but when I try to login with these credentials I am getting 2003 error. (10061) .


    I did set all privilages to my user for my database from console. From console I can see the database.


    Thanx in advence.

  • Assuming you're really trying to connect to the database from another server, there are multiple things you have to consider:

    • "bind-address" in my.cnf has to be active with an value other than 127.0.0.1. e.g.: 0.0.0.0
    • "skip-networking" in my.cnf has to be not active
    • Your firewall has to not block port 3306
    • The users created by froxloar are only allowed to connect from localhost (as these databases are indend for the created vhost webs). So you have to grant access via console or phpmyadmin to connect from external.


    Opening the MySQL-Server for external access is not a good idea in my opinion. If external services needs access to your data you could consider creating a webservice.

  • You should use an SSH-Tunnel instead. That way there is no need to change most of those settings. Only no skip-networking has to be mentioned, but this is default setting.


    Or you could use phpMyAdmin instead of your client app.

  • I tried to install phpmyadmin too, and it says it is installed i see it under etc folder but when I try to open it with myserver.com/phpmyadmin , there is no folder like that under my www folder. So it cant be accessable. I couldnt understand what i did wrong.


    Thanx

  • Try accessing it with your ip instead of your domain-name. phpMyAdmin installs by default to the main directory root, but when you access a vhost-domain, an other directory is used.

  • Hi,


    The problem is "there is no phpmyadmin under root var/www/" .


    I added in apache.conf include etc/phpmyadmin/ manually. ut ofcourse this is not the solution of that. I am trying to find out where did I put that phpmyadmin folder.