vServer PHP update

  • Tag zusammen,

    leider haben mich die Suchfunktion und Google nicht weitergebracht. Habe zurzeit PHP 5.4.4-14+deb7u8 drauf, benötige jedoch eine neuere Version. Habe vServer mit Froxlor. Wie kann ich das kurz und schmerzlos machen? Außer paar älteren CMS läuft auf dem Server nichts.


    Danke!

  • Da du noch Debian 7 drauf hast, solltest du aller schnellstens dein Betriebssystem updaten oder neu installieren.

    Debian 7 erhält seit dem 31.05.2018 keine Updates mehr.


    PHP 5.4 ist seit 2015 auch nicht mehr.


    Evtl. solltest du dir die Verwaltung eines eigenen Servers nochmal überlegen und ggf. auf ein Webhosting Paket umsteigen.

  • Verwaltung ist mir ganz ehrlich zu teuer. Habe schon diverse Sachen selbst gemacht, nur ich weiß einfach nicht wie man mit den Systemen rumspielt. Eine einfache Anleitung/Tipps würden reichen. Das mit dem Betriebssystem ist mir bewusst. Es bleibt die Frage "wie"?


    Danke!

  • Tag. Habe genau den Anleitungen befolgt. Die Seiten auf dem Server sind zurzeit nicht erreichbar "You don't have permission to access / on this server.", Apache ist 2.4.25. Hier ist eine meiner Webseiten: richstaker.com. Debian ist jetzt 9.9, Froxlor zeigt jetzt die PHP 5.6.40 Version. Hättest Du ein Tipp für mich?

  • Hättest Du ein Tipp für mich?

    Code
    1. #Apache 2.2
    2. Order allow,deny
    3. Allow from all
    4. #Apache 2.4
    5. Require all granted

    Einmal die Konfigurationsdateien nach oberen Muster ersetzen, und nach unterem ersetzen.

    Was sagt der error log? Die Verzeichnisse, die dort aufgelistet werden sind ggf. nicht World-Readable oder betretbar für Apache.


    Edit: ggf. Froxlor mitteilen, dass es eine geänderte Apache Version gibt und die Konfiguration neu generieren lassen.

  • In der apache2.conf steht bei mir:


    Code
    1. <Directory /var/www/>
    2. Require all granted
    3. </Directory>

    In diesem Ordner (var/www) sind Froxlor, PHPmyadmin etc. drin.


    Error log zeigt einige Zeile mit:

    Code
    1. "OPTIONS * HTTP/1.0" 200 126 "-" "Apache/2.4.10 (Debian) (internal dummy connection)"

    Froxlor sieht die aktuelle Apache-Version

  • sorry, hatte im falschen Log geschaut. Das sind die Meldungen von heute seit dem Upgrade.

  • Schmeiß erstmal den ioncube Loader aus deiner PHP Config raus.

    Der 403 von heute morgen taucht da aber nicht auf. Haben vHosts bei dir extra error Logs?


    [Tue Jul 02 09:51:56.488847 2019] [mpm_prefork:notice] [pid 25192] AH00163: Apache/2.4.10 (Debian) PHP/5.6.40-0+deb8u4 configured -- resuming normal operations

    09:51 und Debian 8 (ggf. UTC Zeit) - passt das zusammen? Wenn nicht, bist du noch nicht vollständig auf Stretch.

  • Schmeiß erstmal den ioncube Loader aus deiner PHP Config raus.

    Der 403 von heute morgen taucht da aber nicht auf. Haben vHosts bei dir extra error Logs?


    [Tue Jul 02 09:51:56.488847 2019] [mpm_prefork:notice] [pid 25192] AH00163: Apache/2.4.10 (Debian) PHP/5.6.40-0+deb8u4 configured -- resuming normal operations

    09:51 und Debian 8 (ggf. UTC Zeit) - passt das zusammen? Wenn nicht, bist du noch nicht vollständig auf Stretch.

    habe in der Dati 20-ioncube.ini im Ordner etc/php5 vor dem Text

    Code
    1. zend_extension = /usr/lib/php5/20100525/ioncube_loader_lin_5.4.so

    ein # gesetzt. Habe nichts anderes zu dem Ioncube gefunden.


    Von Apache-Logs habe ich access.log (sauber), error.log wie oben und other_vhost_access.log

  • Außer paar älteren CMS läuft auf dem Server nichts.

    Wenn du den Server nur für ein Webhosting benutzt, willst du ein Webhosting Paket buchen, da ist das alles für dich gemacht worden.


    Die logs zeigen deinen Apache und default host, nicht deinen vHost. Der hat wohl eigene logs.

    Die Fehlermeldung zeigt, dass das Rootverzeichnis deines vhosts für den Webservernutzer nicht lesbar ist.

    Grundsätzlich geht dein Setup, ich kann zumindest dein Froxlor aufrufen. Das Problem liegt also in der vhost config, in der du die Konfigurationsänderung, die H6G in Post 7 gepostet hat, durchführen musst.


    Die Änderung kannst du vermutlich in Froxlor machen (kenne Froxlor nicht, kann nichts dazu sagen) oder direkt in den Dateien unter /etc/apache2/sites-enabled/ vermutlich werden direkte Änderungen später aber wieder von Froxlor überschrieben

  • Danke Leute, es läuft jetzt einwandfrei und ich bin auf dem neusten Stand :)

    Habe anstatt <Directory /var/www/> <Directory /var/> genommen, zusätzlich noch unter /etc/apache2/sites-enabled dasselbe eingetragen (war noch nach Apache 2.2 Art). Dann hatte ich den Fehler 500 bekommen, nach kurzem googeln unter folgendem Link den richtigen Text für .htaccess kopiert und es läuft jetzt!


    https://github.com/Laverna/laverna/issues/110


    Kämpfe jetzt mit dem upgrade von PHP. php -v zeigt:

    Code
    1. PHP 7.3.6-1+0~20190531112735.39+stretch~1.gbp6131b7 (cli) (built: May 31 2019 11:27:35) ( NTS )

    Froxlor zeigt jedoch immer noch 5.6.40-0+deb8u4. Wo könnte der Hacken sein?